Jump to content
Marcio N

[VisualG] com algoritmo

Recommended Posts

Olá.

Eu gostaria de solicitar ajuda com um exercício no qual estou tendo um pouco de dificuldade.

Segue o seu enunciado:

Faça um programa que leia um número indeterminado de valores, correspondentes a notas,

encerrando a entrada de dados quando for informado um valor igual a -1 (que não deve ser

armazenado). Após esta entrada de dados, faça:

Mostre a quantidade de valores que foram lidos;

Exiba todos os valores na ordem em que foram informados, um ao lado do outro;

Exiba todos os valores na ordem inversa à que foram informados, um abaixo do outro;

Calcule e mostre a soma dos valores;

Calcule e mostre a média dos valores;

Calcule e mostre a quantidade de valores acima da média calculada;

Calcule e mostre a quantidade de valores abaixo de sete;

Encerre o programa com uma mensagem;

 

Até agora apenas fiz o seguinte:

[tr]var n,cont,cont7,contmedia,soma,numeros: inteiro

media: real

 

inicio

cont:=-1 //como o programa contará o "-1" pressionado ao encerrá-lo, automaticamente diminuirá-se 1 unidade da variável cont

cont7:=-1

contmedia:=0

enquanto (n <> -1) faca //condição para encerramento do programa

escreva ("digite um número:")

cont:=cont+1

leia (n)

soma:= (soma + n )

se n <7 entao

cont7:=cont7 +1 //segundo variável contadora, utilizada para contar apenas números menores que 7

fimse

fimse

fimenquanto

escreval ("Quantidade de números digitados:",cont)

escreval ("Soma dos números digitados",soma + 1)

media:=(soma + 1)/cont

escreval ("A média dos números digitados é de:",media)

escreval ("A quantidade de números menores que 7 é de:", cont7)

escreval ("A quantidade valores acima da média é de:", contmedia)

Escreval ("Fim do programa :D")[/tr]

Se possível, eu gostaria que me dessem dicas, ou até mesmo, mostrassem a resolução de tal problema.

Obrigado desde já.

Share this post


Link to post
Share on other sites

Amigo poste na área correta, e se possível use as tags [.code], código sem identação é horrível de ler =/.

 

[]s

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.