Jump to content
gabrieldmello

AspMaxRequestEntityAllowed

Recommended Posts

Boa noite galera, recentemente venho tendo problemas com ASP Upload, tenho uma aplicação que funcionava normalmente, do nada parou de funcionar, dando um erro como se o componente estivesse desinstalado, tentei usar outros métodos de upload, mas o limite de up é curto, 200kb,segundo minha metabase.xml. Vi na net que é possível mudar esse valor, me guiaram para habilitar a edição da metabase no IIS 6.0, já estava habilitado, fui tentar editar a metabase, porém quando eu edito, salvo, quando vou ver, ela voltou ao valor original. Já fiz isso com o IIS desconectado, e também volta ao valor original.

 

O error que deu do nada na aplicação, eu já citei em outro tópico aqui no forum.

 

Outro tópico: http://forum.imasters.com.br/topic/540788-erro-asp-0177-800401f3-falha-em-servercreateobject/

Share this post


Link to post
Share on other sites

painel central, abra “Request Filtering” e depois, no lado direito, “Edit Features Settings”. Na tela de configuração, edite o valor consigurado para “Maximum allowed content length”,

 

Você também pode realizar a alteração usando a ferramenta “appcmd”, via linha de comando. Neste caso, abra o prompt (Start > run > digite cmd > clique em OK) e na tela digite:

%windir%\system32\inetsrv\appcmd set config -section:requestFiltering -requestLimits.maxAllowedContentLength:VALOR_DESEJADO

E reinicie o IIS (iisreset) ,no menu inicar do seu windows , no executar, digite reset inetserv

Se mesmo assim ele não guardar as alterações, verifique se seu Windows está atualizado, e se os componentes do IIS estão integros, senão faça uma reparação nos mesmos.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.