Jump to content
  • 0
Maroto

[RESOLVIDO] Erro de memória com algoritimo no VisualG

Question

Olá, pessoas.

 

Criei um programa com fins de estudo no visualg, cuja finalidade é preencher uma matriz com valores aleatórios e, em seguida, conferir e armazenar numa segunda atriz se o valores gerados são pares ou ímpares. Todavia o programa fica dando um erro ("Access violation at address xxxx in module" visualg30.exe). Não sei se eu que estou errando na lógica, se meu pc está quebrado ou se é um bug do visualg. 

Abaixo deixo meu código para quem puder me ajudar. Obrigado :)

 

Var
   // Seção de Declarações das variáveis
   matriz1: vetor [0..2, 0..2] de inteiro
   matriz2: vetor [0..2, 0..2] de caractere

  // Procedimento que gera valores inteiros aleatorios para preencher a matriz1.
  procedimento preencheMatriz
  var
     // Variaveis contadoras
     i1, i2: inteiro
  inicio
     para i1 de 0 ate 1 passo 1 faca
        para i2 de 0 ate 2 passo 1 faca
           aleatorio on
           leia (matriz1[i1,i2])
           limpatela
           aleatorio off
        fimpara
     fimpara
     // Imprimindo a matriz na tela
     para i1 de 0 ate 1 passo 1 faca
        para i2 de 0 ate 2 passo 1 faca
           escreva (matriz1[i1,i2])
        fimpara
        escreval ("")
     fimpara
  fimprocedimento

  // Procedimento que verifica se os valores das posições da matriz1 são pares
  // ou ímpares.
  procedimento verificaParImpar
  var
     i1, i2: inteiro
  inicio
     para i1 de 0 ate 1 passo 1 faca
        para i2 de 0 ate 2 passo 1 faca
           se (matriz1[i1, i2] MOD 2=0) entao
              matriz2[i1,i2] <- "par"
              escreva(matriz2[i1,i2], " ")
           senao
              matriz2[i1,i2] <- "ímpar"
              escreva(matriz2[i1,i2], " ")
           fimse
        fimpara
        escreval(" ")
     fimpara
  fimprocedimento

Inicio
   // Seção de Comandos, procedimento, funções, operadores, etc...
   preencheMatriz
   verificaParImpar
Fimalgoritmo

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By credson
      Elabore um algoritmo que possa descobrir, através de perguntas e respostas, qual meio de transporte o usuário está pensando.
      O usuário deverá escolher uma das seguintes opções:
      - Trator
      - Moto
      - Bicicleta
      - Trem
      - Carro
      - Caminhão
      - Ônibus
      - Paraquedas
      - Balão
      - Avião
      - Helicóptero
      - Submarino
      - Barco
      - Navio
      - Lancha
      Para chegar ao resultado, só devem ser usadas perguntas que retornem "Sim" ou "Não".
      Exemplo:
      É terrestre? Sim.
      Cabe apenas uma pessoa? Sim.
      É pesado? Não.
      Tem pedal? Sim.
       
       
       
      alguem sabveria pode ser  qualquer linguagem
    • By andersonseifert
      boa tarde, podem me ajudar em uma logica ?
      tenho um numero exemplo 300 , quero aumentar ele sempre +1 , tipo usuario digitou que precisa de 50 numeros depois dos 300 exemplo : 301,302,303... ate 305.
       O que me recomendam fazer ? um array ou for somando +1 ?
       
       
       

    • By Rafael da Silveira
      Bom dia Pessoal, tudo bem?
      O problema aqui está mais para matematica do que para programação. Mas como sei que aqui só tem fera e pode ser que alguem tenha passado por algo semelhante...

      Tenho um cliente que precisa de uma página, onde ele coloca o valor do produto a vista, e ele joga o valor com as taxas da maquinha de cartão dele...
      A principio é tranquilo, pega o valor, soma taxa, multiplica taxa e pronto...
       
      O problema é que essas taxas são cobradas em cima do valor final, o que depois dos descontos acaba saindo abaixo do valor a vista.
      E ele que receber o valor á vista, deixando para o cliente pagar essa diferença...

      Como resolver essa questão? Alguém poderia me ajudar?
       
    • By thiago_tw
      eu to com uma tarefa que preciso de ajuda, já tentei alguns algoritmos que achei por aqui mas nunca dá certo, mandei a imagem do que é para ser feito, agradecido se me ajudarem

    • By Dcdbbvb
      Faça um código que deverá ter uma matriz de qualquer tamanho(Você define o tamanho) no qual o usuário irá digitar os números que serão armazenados na matriz. Construa uma função que deverá somar todos os números digitados. No final o programa mostrará a matriz e o valor total da somatória.
       
      por favorrrr alguém me ajuda
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.