Ir para conteúdo

Pesquisar na Comunidade

Mostrando resultados para as tags ''visualg''.

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Todas as áreas do Fórum

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Encontrar resultados em...

Encontrar resultados que...


Data de Criação

  • Início

    FIM


Data de Atualização

  • Início

    FIM


Filtrar pelo número de...

Data de Registro

  • Início

    FIM


Grupo


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Encontrado 90 registros

  1. Rapaziada estou meio adoentado é preciso entregar uma tarefa simples amanha a noite, Preciso fazer um algorítimo em visualg que calcule o tempo gasto de saída de casa é chegada ao trabalho é mostre as horas gastas os minutos gastos é os segundos gastos. Consegui fazer ate a metade mais não estou conseguindo processar o resto. Quem poder da um tombo te agradeço muito. Fiz uma parte Var he,hs,me,ms,hora:inteiro Inicio escreva ("Digite a hora de entrada: ") leia (he) escreva ("Digite os minutos de entrada: ") leia (me) escreva("Digite a hora de saida: ") leia (hs) escreva ("Digite os minutos de saida: ") leia(ms) hora:= hs-he escreva("Passou", hora , ":horas") Fimalgoritmo
  2. guiilhermej

    Ajuda Portugol

    Galera, to com um impasse em umas questões passadas na faculdade, eu realmente gosto de resolver meus exercícios, pois só assim sei que irei aprender, mas acontece que to meio perdido nessas questões, alguem me da um help por favor. 6. Escreva um algoritmo que peça um número n ao usuário, e que gere um novo n de acordo com a seguinte regra: • se n é par, n = n / 2 • se n é impar, n = 3 * n + 1 • imprime n • O programa deve parar quando x tiver o valor igual a 1. Por exemplo, para n = 13, a saída será: 40 -> 20 -> 10 -> 5 -> 16 -> 8 -> 4 -> 2 -> 1 7. Fazer um algoritmo que leia um número que servira para controlar os primeiros números ímpares. Deverá ser impressa a soma desses números. Suponha que o número informado será maior que zero, caso não seja, informar o erro. Informe um número: 5 1 3 5 7 9 A soma dos 5 valores impares é: 25 8. Fazer um algoritmo que leia os limites inferior e superior de um intervalo e o número cujos múltiplos se deseja que sejam impressos no intervalo aberto. Suponha que os dados digitados são para um intervalo crescente. Exemplo: Valor inicial: 5 Valor final: 15 Divisor: 3 6 9 12 15 9. Fazer um algoritmo que leia a quantidade de números que se deseja digitar para que possa ser impresso o maior e o menor número digitado. Não suponha que todos os números lidos serão positivos. Exemplo: Quantos números deseja digitar? 5 Informe um numero:3 Informe um numero:-2 Informe um numero:5 Informe um numero:6 Informe um numero:19 O maior numero informado foi: 19 O menor numero informado foi: -2
  3. GabrielMoura

    Dúvida em VisualG

    Boa noite pessoal, Sou novo aqui no fórum, então um Oi para todos. Sou novo na programação e estou com um exercício que está difícil de resolver. Uso VisualG para testar. Preciso inserir uma palavra e apresentar como saída a inversão de duas em duas letras. Exemplo: digitar a palavra EXEMPLO e ter como saída: XEMELPO, inclusive quando a palavra tiver um número ímpar de letras a última não modifica. Já tentei alguma coisa, mas não sei se uso vetor mesmo, em todos os exemplos de inversão de palavras o vetor é usado. Alguém pode me dar uma luz? Segue o código: algoritmo "semnome" // Função : // Autor : // Data : 26/10/2018 // Seção de Declarações var palavra: caracter vet: vetor [1..30] de caracter tamanho: inteiro i: inteiro inicio escreva ("Digite uma palavra: ") leia (palavra) tamanho <- compr (palavra) escreva ("A palavra tem ", tamanho, " letras.") para i de 1 ate tamanho faca se ((i mod 2) = 0) entao vet <- vet [i+1] fimse palavra <- vet fimpara escreva ("A palavra agora é ", palavra) fimalgoritmo Obrigado desde já.
  4. Algoritmo "semnome" // Disciplina : [Linguagem e Lógica de Programação] // Professor : Antonio Carlos Nicolodi // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : João dos ceus // Data atual : 03/09/2018 Var // Seção de Declarações das variáveis dados: vetor[1..5,1..5] de caracter i,j: inteiro letras: vetor[1..6] de caracter k: inteiro contador:inteiro opcao,opcao2:inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... repita Escreval("------ Menu principal ------") Escreval("Selecione uma das opções") Escreval("1. Inserir sopa de letras") Escreval("2. Sair") leia(opcao) escolha opcao caso 1 escreval("Introduza as letras para a sopa de letras:") para i de 1 ate 5 faca para j de 1 ate 5 faca leia (dados[i,j]) fimpara fimpara escreval ("") escreval("A sopa de letras é:") para i de 1 ate 5 faca para j de 1 ate 5 faca escreva (dados[i,j]) fimpara escreval ("") fimpara escreval ("") escreval(" As letras introduzidas são:") para i de 1 ate 6 faca leia (letras) fimpara para i de 1 ate 5 faca para j de 1 ate 5 faca para k de 1 ate 6 faca se letras[k]=dados[i,j] entao contador<-contador+1 escreval("") escreval ("-> Letra:") escreval (dados[i,j]) escreval ("->> Coordenada:") escreva (i,j) escreval("") escreval ("->>> Numero de vezes que a letra foi repetida:") ESTOU COM DIFICULDADES NESTE CODIGO AQUI, QUERO QUE ME DIGA QUANTAS VEZES A LETRA ESCOLHIDA FOI REPETIDA NA MATRIZ fimse fimpara fimpara fimpara caso 2 fimalgoritmo fimescolha Fimalgoritmo
  5. Olá, pessoas. Criei um programa com fins de estudo no visualg, cuja finalidade é preencher uma matriz com valores aleatórios e, em seguida, conferir e armazenar numa segunda atriz se o valores gerados são pares ou ímpares. Todavia o programa fica dando um erro ("Access violation at address xxxx in module" visualg30.exe). Não sei se eu que estou errando na lógica, se meu pc está quebrado ou se é um bug do visualg. Abaixo deixo meu código para quem puder me ajudar. Obrigado :) Var // Seção de Declarações das variáveis matriz1: vetor [0..2, 0..2] de inteiro matriz2: vetor [0..2, 0..2] de caractere // Procedimento que gera valores inteiros aleatorios para preencher a matriz1. procedimento preencheMatriz var // Variaveis contadoras i1, i2: inteiro inicio para i1 de 0 ate 1 passo 1 faca para i2 de 0 ate 2 passo 1 faca aleatorio on leia (matriz1[i1,i2]) limpatela aleatorio off fimpara fimpara // Imprimindo a matriz na tela para i1 de 0 ate 1 passo 1 faca para i2 de 0 ate 2 passo 1 faca escreva (matriz1[i1,i2]) fimpara escreval ("") fimpara fimprocedimento // Procedimento que verifica se os valores das posições da matriz1 são pares // ou ímpares. procedimento verificaParImpar var i1, i2: inteiro inicio para i1 de 0 ate 1 passo 1 faca para i2 de 0 ate 2 passo 1 faca se (matriz1[i1, i2] MOD 2=0) entao matriz2[i1,i2] <- "par" escreva(matriz2[i1,i2], " ") senao matriz2[i1,i2] <- "ímpar" escreva(matriz2[i1,i2], " ") fimse fimpara escreval(" ") fimpara fimprocedimento Inicio // Seção de Comandos, procedimento, funções, operadores, etc... preencheMatriz verificaParImpar Fimalgoritmo
  6. Prezados, tenho um trabalho pra entregar e resolvi 98% do mesmo, só uma questão que não estou conseguindo, dai pediria ajudar de vcs... O trabalho é este: Faça um algoritmo em VisualG que, dado o salário bruto de uma pessoa, calcule o salário líquido sabendo que há o desconto de dois impostos, de acordo com a tabela abaixo: Tabela IRPF Tabela INSS Salário até R$1500,00 será 0% de imposto; Salário até R$3000,00 será 15% de imposto; Salário acima de R$3000,00 será 27,5% de imposto. Importo fixo de 11% do salário, sendo que o total do imposto não pode ser superior a R$400,00. (aqui onde o bicho pega, não sei como limitar a esse valor) Atenção para calcular o IRPF você poderá utilizar uma estrutura de decisão encadeada, já para o INSS você poderá utilizar uma estrutura de decisão composta. Depois de avaliar as duas estruturas (IRPF e INSS) você então calculará o salário líquido. Para que você possa conferir se seu algoritmo está correto execute com os valores do salário bruto dado abaixo e confira se o salário líquido será o apresentado abaixo: Salário Bruto Salário Líquido R$ 5000,00 R$ 3225,00 R$ 3500,00 R$ 2152,50 Retorno de resultado R$ 1800,00 R$ 1332,00 R$ 1400,00 R$ 1246,00 Meu algoritmo ficou assim (funcionando porém com valores que dão mais de R$ 400,00 de INSS ele não limita, porque não sei como fazer, me ajudem por favor): var salarioB, irpf, inss: real inicio //IRRF: //Até 1.500 | - //De 1.500 até 3.000 | 15,0 //Acima de 3.000 | 27,5 //INSS: //Fixo | 11,0 | Limite de desconto 400 escreva("Digite o salário:") leia (salarioB) se (salarioB<1500.00)ou(salarioB=1500.00) entao inss<- salarioB*11/100 escreval("Seu SalarioB Liquido é", salarioB - inss) senao se (salarioB>1500.01)e(salarioB<=3000.00) entao irpf<- salarioB*15/100 inss<- salarioB*11/100 escreval ("IRPF a ser descontado é", irpf) escreval ("INSS a ser descontado é", inss) escreval("O salário Líquido é", salarioB - irpf - inss) senao se (salarioB>3000.00)ou(salarioB= 3000.00) entao irpf<- salarioB*27.5/100 inss<- salarioB*11/100 escreval ("IRPJ a ser descontado é", irpf) escreval ("INSS a ser descontado é", inss) escreval("O salário Líquido é", salarioB - irpf - inss) fimse fimse fimse fimalgoritmo
  7. lucas25

    Algoritimo

    estou precisando de ajuda nessa questão: A companhia de aviação balanca mas nao cai ltda deseja automatizar o calculo de desconto durante o procedimento de vendas de passagens areas para os seus 2500 voos. Dessa forma, confeccionar um algoritimo que: a. leia cada venda: o dia da semana do voo (2-3-4-5-6-7-0) o turno do voo (diurno ou noturno) a quantidade de passagens o valor da passagem. estou precisando de ajuda não estou conseguindo faze.
  8. Meu código tá dando erro no fim algoritmo algoritmo "Calculador de Maioridade" var an : inteiro var anoa : inteiro var qfuac : caractere var facf : caractere var cpf : caractere inicio escreval ("Qual seu ano de nascimento ") leia (an) anoa <- (2018) an <- (anoa - an) se (an > 18) entao escreval ("Voce tem " , an) escreval ("Voce e maior de idade") escreval (" Voce quer fazer uma faculdade?") leia (qfuac) se (sim ou Sim ) entao escreval ("Qual faculdade voce quer fazer?") leia (facf) escreval ("Quer fazer seu cadastro para ", facf" ?") se (sim ou Sim) entao escreval ("Digite seu CPF") leia (cpf) escreval ("Digite seu RG") leia (rg) escreval ("Pronto Cadastro Feito. Boa sorte") fimse senao escreval ("Voce tem " , an) escreval ("Voce e menor de idade") fimse fimalgoritmo Da esse erro: Dados incorretos : [46:0] = fimalgoritmo Alguém me ajuda
  9. matheusfenomeno

    O meu Visualg não esta reconhecendo o codigo enquanto

    algoritmo "semnome" var nome:caractere c,n:inteiro inicio escreva("Qual é o seu nome ? ") leia(nome) Escreval("Prazer ",nome,".") escreval("Escolha um numero") leia(n) c <- 0 Enquanto (c<=n) faca c <- c + 1 fimEnquanto fimalgoritmo
  10. Olá pessoal podem me ajudar com esses exercicios? anexei a foto das questoes no post, Obrigado a todos pela atenção! 1) Considerando a=5, b=2, e c=8, escreva qual será o valor impresso pelo algoritmo quando valor a ser lido(valor de entrada): a) Valor de entrada, num = -2 b) Valor de entrada, num = 2 2) Escreva um algoritmo que leia dados de entrada 3 números, verificando se eles podem ou não ser lados de um triangulo. Caso sejam lados de um triangulo, calcular a area do mesmo e imprimir o resultado, caso nao sejam imprimir "não sao lados de um triangulo" para que o triangulo exista , um de seus lados deve ser maior que o valor absoluto (modulo) da diferença dos outros dois lados e menor que a soma dos outros dois lados: a > l b-c l, b > l a-c l, c > l a-b l ao calcular a area de um triangulo utilize a formulaçao sendo que a, b e c sao os lados do triangulo A=v(p x(p-a) x (p-b) x (p-c)) P= (a+b+c)/2
  11. Mühlmann

    Algoritmo-VisualG

    Dúvidas ja sanada durante a aula.
  12. Bom dia, estou com uma dificuldade em um algoritmo para um jogo da forca em VisuALG, o algoritmo foi solicitado para um trabalho e um dos requisitos é que ele tenha uma função, como vocês podem ver foi colocado uma função, porém a professora disse que aquela função não retorna nenhum valor, e por isso ela se encaixa como procedimento, pesquisei, tentei e não conseguir encaixar uma função nesse algorítimo, queria acrescentar também a cada final de rodada a opção de jogar ou não novamente. desde já agradeço a ajuda. abaixo segue o Algorítimo - obs o visuALG utilizado foi o 2.0 algoritmo "Jogo da forca" var op,frutas,ne,na:inteiro //op: opçao, ne: numero erro, na:numero de acertos l1,l2,l3,l4,l5,l6,l7,ld1,ld2,ld3,ld4,ld5,ld6,ld7,dig,verifica:caracter //linhas(l1,l2,l3...) serão usadas para o aleatorio, já as ld (ld1, ld2, ld3) serão usadas para verificar o acerto V,D:Caracter funcao Derrota () :caracter inicio Escreval("============================================================") escreval("============================================================") escreval escreval(" --------- FIM DE JOGO! ------- ") ESCREVAL ESCREVAL(" --------- GAME OVER =( ------- ") ESCREVAL Escreval("============================================================") escreval("============================================================") fimfuncao funcao vitoria () : caracter inicio limpatela Escreval("============================================================") escreval("============================================================") escreval escreval(" PARABÊNS VOCE VENCEU! ") ESCREVAL Escreval("============================================================") escreval("============================================================") fimfuncao inicio aleatorio on // ativa o modo aleatorio fonte, palavra on é opcional aleatorio 1,7 // seleciona o ranger do aleatorio, é preciso definir para o comando ter as opção para escolha leia (frutas) // todo leia vai ser lançado um numero aleatorio nesse caso de 1 a 3 aleatorio off // desativa o modo aleatorio, assim ele escolher uma das opções das palavras. limpatela // limpa tela repita // (repita 1) repitir o comando ate achar o comando interrompa escreval("---SEJA BEM VINDO---") escreval escreval(" ---JOGO DA FORCA--- ") escreval("Autores: Charles Ramos, Pedro Duca, Richard Vepo") escreval escreval escreval("Digite 1 para jogar e 0 para sair") leia(op) escolha op // verificar qual opção foi selecionada caso 0 //sair escreva("você escolheu a opção 0 para sair") escreval escreval fimalgoritmo // encerrar o algoritmo caso 1 interrompa // para o loop de escolher opção outrocaso // caso digite algo diferente de 0 ou 1 ele vai limpar a tela limpatela // limpa a tela, e vai voltar para o loop de opção. fimescolha fimrepita// fim repita 1 escolha frutas // palava que vai ser escolhida automaticamente pelo aleatorio no inicio do código em aleatorio on caso 1 l1 <- "d" l2 <- "a" l3 <- "m" l4 <- "a" l5 <- "s" l6 <- "c" l7 <- "o" caso 2 l1 <- "a" l2 <- "b" l3 <- "a" l4 <- "c" l5 <- "a" l6 <- "x" l7 <- "i" caso 3 l1 <- "a" l2 <- "b" l3 <- "a" l4 <- "c" l5 <- "a" l6 <- "t" l7 <- "e" caso 4 l1 <- "a" l2 <- "c" l3 <- "e" l4 <- "r" l5 <- "o" l6 <- "l" l7 <- "a" caso 5 l1 <- "l" l2 <- "a" l3 <- "r" l4 <- "a" l5 <- "n" l6 <- "j" l7 <- "a" caso 6 l1 <- "p" l2 <- "e" l3 <- "s" l4 <- "s" l5 <- "e" l6 <- "g" l7 <- "o" caso 7 l1 <- "g" l2 <- "u" l3 <- "a" l4 <- "r" l5 <- "a" l6 <- "n" l7 <- "a" fimescolha ld1 <- "_" // LINHAS USADAS PARA ESCREVER ld2 <- "_" ld3 <- "_" ld4 <- "_" ld5 <- "_" ld6 <- "_" ld7 <- "_" // inicio do jogo repita //repita2 se (ne > 7) entao // Se número de erros for maior que 6 que é o tamanho das palavras logo, jogador perde, ou seja, jogador possui 6 chances apenas. D<- Derrota FIMALGORITMO fimse se (ld1 <> "_") e (ld2 <> "_") e (ld3 <> "_") e (ld4 <> "_") e (ld5 <> "_") e (ld6 <> "_") e (ld7 <> "_") entao // Se as linhas forem diferentes de _ significa que existe letra no local, V<- Vitoria FIMALGORITMO fimse limpatela Escreval("============================================================") escreval("============================================================") escreval("") escreval(" /-----|") escreval(" / |") se (ne > 0 ) entao escreval(" / (x.x)") senao escreval(" /") fimse se (ne > 1 ) entao escreval(" | __||__ ") senao escreval(" | ") fimse se (ne > 2 ) entao escreval(" | /| |\\") senao escreval(" | ") fimse se (ne > 3) entao escreval(" | / |_____| \\") senao escreval(" | ") fimse se (ne > 4) entao escreval(" | || ||") senao escreval(" | ") fimse se (ne > 5) entao escreval(" | _|| _||") senao escreval(" | ") fimse se (ne > 6) entao escreval(" | |__||__|") escreval("===== ULTIMA CHANCE! ") senao escreval(" | ") escreval("===== ") fimse escreval("") escreval("Acertos: ",na) escreval("Erros: ",ne) escreval("") escreva("Palavra com 7 letras: ",ld1," ",ld2," ",ld3," ",ld4," ",ld5," ",ld6," ",ld7) Escreval("") escreval("Dica da palavra: FRUTA ") escreval escreva("digite uma letra: ") leia(dig) verifica <- "0" se (l1 = dig) e (ld1 = "_") entao ld1 <- dig na <- na + 1 verifica <- "1" fimse se (l2 = dig) e (ld2 = "_") entao ld2 <- dig na <- na + 1 verifica <- "1" fimse se (l3 = dig) e (ld3 = "_") entao ld3 <- dig na <- na + 1 verifica <- "1" fimse se (l4 = dig) e (ld4 = "_") entao ld4 <- dig na <- na + 1 verifica <- "1" fimse se (l5 = dig) e (ld5 = "_") entao ld5 <- dig na <- na + 1 verifica <- "1" fimse se (l6 = dig) e (ld6 = "_") entao ld6 <- dig na <- na + 1 verifica <- "1" fimse se (l7 = dig) e (ld7 = "_") entao ld7 <- dig na <- na + 1 verifica <- "1" fimse se (verifica = "0") entao ne <- ne + 1 fimse escreval("==============================================================") escreval("==============================================================") fimrepita fimalgoritmo
  13. Pessoal queria uma ajuda para fazer esse código funcionar corretamente, o problema é o seguinte, É pra desenvolver um algoritmo que fique recebendo números e quando for digitado o número 0 "zero" o programa pare e mostre o maior e o menor número digitado, usando a função repita - até. Vou deixar anexado a imagem do código que eu fiz.
  14. Heric De Souza Paiva

    Exercício de VisuAlg [VETOR]

    Faça um algoritmo que leia 20 notas de alunos e armazene em um vetor. Feito isso, o algoritmo deve calcular e mostrar a maior e a menor nota informada. [VisuAlg]
  15. Fernanda De Camargo Fernandes

    me ajuda por favor

    Uma tabela expressa os valores de imóveis de diferentes metragens em diferentes bairros da cidade de Vitória. As colunas dessa Matriz 5x5 contém os valores para cada metragem (100, 150, 200, 250 ou 300m2) e as linhas os valores para cada Bairro. Faça um algoritmo que a)Leia a matriz por completo; b)O usuário deverá informar a metragem (ou número da coluna da matriz) e o algoritmo deverá retornar o preço do apartamento mais barato para a metragem informada; O valor do apartamento deverá ser apresentado na tela; c)O usuário deverá informar um bairro (ou o número da linha da matriz) e a metragem (coluna) e a subrotina retorna o preço do apartamento; O Valor do apartamento deverá ser apresentado na tela; d)O algoritmo deverá informar a média dos preços dos apartamentos por metragem;
  16. jacqueline aparecida

    estrutura de pilha

    Implemente uma estrutura de pilha segundo o material dado e execute as seguintes operações: a. Empilhe: 5 b. Empilhe: 8 c. Empilhe: 22 d. Escreva o topo da pilha e. Desempilhe f. Imprima o topo da pilha g. Empilhe: 30 h. Empilhe: 32 i. Imprima o resultado de Desempilhe j. Imprima a quantidade de itens empilhados Ao final, dê um PRINT na tela de execução do VisualG e salve em um arquivo juntamente com o código fonte.
  17. o Estoque Cadastro de item no estoque Descrição / Quantidade / Preço de custo / Preço de venda Cadastro de combo promocional Descrição / Quantidade / Preço de custo / Preço de venda Retirar item do estoque Retira quantidade do item selecionado Relatório de itens no estoque. Todos os itens Olá! Estou desenvolvendo o código relacionado a estas funções: algoritmo "ESTOQUE" // Estoque // Cadastro de item no estoque // Descrição / Quantidade / Preço de custo / Preço de venda // Cadastro de combo promocional // Descrição / Quantidade / Preço de custo / Preço de venda // Retirar item do estoque // Retira quantidade do item selecionado // Relatório de itens no estoque. // Todos os itens tipo //dados do produto Produto = registro desc :caractere //descricao qtd :inteiro //quantidade pCusto:real //preco de custo pVenda:real //preco de venda fimRegistro var produtos :vetor [1..1] de Produto i,j :inteiro codItem :inteiro opc :caractere fim_cad :inteiro procedimento cadastro_item inicio codItem <- codItem+1 escreval("** Cadastro de produto **") escreva ("Descrição :") leia(produtos[codItem].desc) escreva ("Quantidade :") leia(produtos[codItem].qtd) escreva ("Preço de CUSTO :") leia (produtos[codItem].pCusto) escreva ("Preço de VENDA :") leia (produtos[codItem].pVenda) //Abaixo irá mostrar o último produto cadastrado // escreval ("Produto :",produtos[coditem].desc) //escreval ("Quantidade :",produtos[coditem].qtd) // escreval ("Preço R$:",produtos[coditem].Pvenda ,",00") // leia() i:= 0 fimProcedimento procedimento imprimir_produtos()//Prodedimento para imprimir os produtos cadastrados escreval ("Em breve.") fimProcedimento procedimento menu() inicio repita limpaTela escreval("--------- ESTOQUE - PDV--------") escreval() escreval(" 1-Cadastro de Item ") escreval(" 3-EM CONSTRUÇÃO ") escreval(" 4-EM CONSTRUÇÃO ") escreval(" 5-Sair ") escreval() escreval(" 0-*Imprimir produtos ") escreval("-------------------------------") leia(opc) escolha (opc) caso "1" limpaTela cadastro_item() //qdn esse método é invocado, ao finalizar, o programa vai continuar daqui... caso "3" limpaTela escreval("EM CONTRUÇÃO") caso "0' limpaTela imprimir_produtos() fimEscolha ate opc="5" fimProcedimento inicio codItem <- 0 menu() fimAlgoritmo A partir daqui minha mente travou, não vou para frente nem para trás. Alguém me da um start pls? Estou para desenvolver a parte de imprimir itens cadastrados, porém quero antes de tudo armazenar para poder imprimi-los.
  18. Olá, gostaria imensamente que alguém me ajudasse a colocar o resultado em letra maiúscula. Sei que existe uma função chamada "maiusc" mas não estou sabendo como usá-la. Obrigada, desde já
  19. Camilla03

    Visualg exercício enquanto

    Elabore um QUIZ de 10 perguntas e respostas sobre cada disciplina: Matemática, Sociologia e Filosofia do 1o ano. Cada pergunta deverá ter 5 opções de escolha de resposta. Além disso, cada questão contemplará duas tentativas do usuário, isto é, se o usuário responder uma resposta incorreta, terá uma 2a chance na questão que valerá 70% da nota desta questão. Cada questão deverá dar "feedback" (retorno ao usuário) de acerto ou dica se o usuário não acertar. O usuário escolherá no início do programa sobre qual disciplina ele deseja responder as questões. Ao final de cada rodada, exiba um ranking de notas.
  20. algoritmo "semnome" // Função : // Autor : Marlon R.Muniz // Data : 07/05/2018 // Seção de Declarações var id_cidade: inteiro nome: caractere acidentes: inteiro maior_acidentes: inteiro cidade_maior_acidentes: caractere id_cidade_maior_acidentes: inteiro veiculos: inteiro i : inteiro maximo: inteiro maior_veiculos : inteiro cidade_maior_veiculos: caractere id_cidade_maior_veiculos: inteiro menor_veiculos: inteiro cidade_menor_veiculos: caractere id_cidade_menor_veiculos: inteiro Inicio MAXIMO <- 2 maior_veiculos <- 0 menor_veiculos <- 0 para i de 1 ate MAXIMO passo 1 faca escreva("codigo da cidade:") leia (id_cidade) escreva("nome da cidade:") leia ( nome) escreva("numero de veiculos:") leia (veiculos) escreva("numero de acidentes:") leia (acidentes) //1. o cÓdigo e o nome da cidade que possuem o maior nuumero de veículos se maior_veiculos < veiculos entao maior_veiculos <- veiculos cidade_maior_veiculos <- nome id_cidade_maior_veiculos <- id_cidade fimse .//2. o código e o nome da cidade que possuem o menor n´umero de veículos se (menor_veiculos > veiculos) entao menor_veiculos <- veiculos cidade_menor_veiculos <- nome id_cidade_menor_veiculos <- id_cidade fimse //o valor do maior ´indice de acidentes de trˆansito, assim como o c´odigo e o nome da cidade `a qual pertence esse indice fimpara Escreval( "Cidade com maior quantidade de veículos" , cidade_maior_veiculos , "id" , id_cidade_maior_veiculos ) Escreval( "Cidade com menor quantidade de veiculos" , cidade_menor_veiculos , "id" , id_cidade_menor_veiculos ) _________ Fiz isso baseado em outro exercício que roda liso e de bônus alguém pode me ajudar a organizar o escreval? Quando aparece os dados, não aparece o espaço que coloquei, fica tudo misturado
  21. Não consigo lembrar para imprimir a tabela ascll no visual
  22. Lucas Carlos

    Gente alguém me ajuda já está quase pronto

    "Escreva um algoritmo que leia o nome, idade e sexo de 10000 pessoas finalizando a digitação quando o nome for igual a espaço. Mostrar o total de pessoas digitadas, o percentual de homens e de mulheres, a média de idade e o nome e idade da pessoa mais velha e da pessoa mais nova." Estou resolvendo esse exercício mas não consegui fazer a média dentro do para. Algoritmo "numero2" // Disciplina : [Linguagem e Lógica de Programação] // Professor : Antonio Carlos Nicolodi // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Lucas // Data atual : 21/04/2018 Var // Seção de Declarações das variáveis idade, x, pessoas, homens, mulheres : inteiro velha, nova:inteiro media, num : real nome, sexo, nomevelho,nomenovo : caractere Inicio // Seção de Comandos, procedimento, funções, operadores, etc... velha <- 0 nova <- 200 pessoas <- 0 homens <- 0 mulheres <- 0 num <- 0 para x de 1 ate 2 faca escreva ("Insira o seu nome: ") leia (nome) se nome=" " entao interrompa fimse escreva ("Insira seu sexo(F/M): ") leia (sexo) escreva ("Insira sua idade: ") leia (idade) limpatela media <- idade pessoas <- pessoas+ 1 se sexo="M" entao homens <- homens +1 fimse se sexo= "F" entao mulheres <- mulheres+1 fimse se idade > velha entao velha <- idade nomevelho <- nome fimse se idade < nova entao nova <- idade nomenovo <- nome fimse fimpara homens <- homens * 50 mulheres <- mulheres * 50 escreval ("A pessoa mais nova é: ",nomenovo,", sua idade é: ",nova) escreval ("A pessoa mais velha é: ",nomevelho,", sua idade é: ",velha) escreval ("O número total de pessoas é: ",pessoas) // escreval ("A media da idade é: ",media) escreval ("O percentual de homens é: ",homens, "%") escreval ("O percentual de mulheres é: ",mulheres,"%") Fimalgoritmo Gente deu tudo certo, só não consegui fazer a media das idades, se alguém puder ajudar agradeço muito. Obs: em vez de colocar 100000 eu coloquei só 2 para ficar mais fácil testar.
  23. Ddragon 345

    Como Faço esse exercicio

    Solicite dois números inteiros onde o segundo deverá ser no mínimo 20 unidades maior que o primeiro e no máximo 50 unidades, e posteriormente apresente todos os números primos deste intervalo.
  24. Rodrigo Yuzo Matsubara

    Duvidas com visual G

    Boa tarde pessoal, Sou novato em VisualG, não sei como fazer estes execícios abaixo, alguém poderia ajudar? Obrigado. 4) Solicitando 15 valores inteiros entre 10 e 200, apresente a quantidade de números pares informados. 5) Solicite 10 números inteiros entre -100 e 100, e apresente a quantidade de números ímpares, e a média aritmética dos números pares. 6) Construa um algoritmo que solicite 10 números e apresente a média aritmética dos mesmos. 7) Considerando que a nota bimestral de um aluno seja calculada através da média ponderada de 4 avaliações, solicite os dados (notas e respectivos pesos) e apresente a média. 8) Solicite 10 valores inteiros ao usuário e apresente a média harmônica deste conjunto. 9) Construa um programa que gere N números randômicos entre 64 e 1239 e os apresente ao usuário. O valor de N deverá ser indagado ao usuário. Dica: Utilize o comando RANDI. 10) Solicite dois valores inteiros (A,B) onde B deve ser obrigatoriamente maior que o valor de A. Posteriormente, apresente o produto entre as duas variáveis, sem no entanto utilizar o operador de multiplicação (*). 11) Solicite um número inteiro e positivo, e posteriormente apresente se o mesmo é ou não um número PRIMO. 12) Solicite um valor inteiro maior ou igual a zero, e posteriormente apresente o seu FATORIAL. 13) A sequência de Fibonacci é uma sequência de números inteiros, começando por 0 e 1, na qual cada termo subsequente corresponde a soma dos dois anteriores. Os números de Fibonacci, são, portanto, os números que compõem a seguinte sequência: 0, 1, 1, 2, 3, 4, 8, 13, 21, 34, 55, 89, 144, 233, ... Desta forma, desenvolva um algoritmo que apresente os N-primeiros termos da sequência de Fibonacci. O usuário deverá fornecer o valor de N. 14) Construa um algoritmo que solicite o divisor e o dividendo de uma expressão e posteriormente apresente o quociente inteiro desta operação sem no entanto utilizar o operador de divisão (/). O divisor obrigatoriamente deverá ser MENOR que o dividendo. 15) Solicite dois números inteiros onde o segundo deverá ser no mínimo 20 unidades maior que o primeiro e no máximo 50 unidades, e posteriormente apresente todos os números primos deste intervalo. 17) Uma universidade deseja saber algumas informações estatísticas referente a uma sala de aula com 40 alunos. Para isso, fora elaborado um questionário contendo as seguintes perguntas: - Nome do aluno - Data de nascimento (DD/MM/AAAA) - Sexo (F/M/O) - Signo - Altura - Peso Desta forma, deseja-se apresentar no final as seguintes informações: a) Percentual de alunos do sexo Feminino b) média de idade dos alunos c) nome e peso da pessoa mais pesada do sexo masculino d) quantidade de pessoas do signo de GEMEOS abaixo de 1,75m de altura e) nome e altura da pessoa mais baixa f) média aritmética de peso de todos os alunos entrevistados g) percentual de pessoas que nasceram em ano BISSEXTO h) quantidade de pessoas que nasceram em dias PRIMO J) quantidade de alunos por signo
  25. Problema: Numa fábrica de peças, o salário base de um operário da linha de fabricação é R$ 240,00. Além do salário base, o operário tem um adicional de produtividade baseado na quantidade de peças que ele fabrica por mês que é pago segundo os requsitos a seguir: Se o número de peças é inferior, ou igual a 500: receberá apenas o salário base. Se o número de peças é superior a 500 e inferior, ou igual a 750: Será adicionado R$ 0,50 por peça fabricada acima das 500. Ex. se fabricou 501 receberá R$ 240,50. Se o número de peças for superior a 750: Receberá R$ 350,00 (fixo) mais R$ 0,75 por peça fabricada acima das 750. Ex. se fabricou 751 receberá R$ 350,75 Desenvolva um algoritmo que permita entrar com o número de peças fabricadas por um operário e imprima seu salário.
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.