Jump to content
silver sanths

ajuda em script python

Recommended Posts

Como faço para retornar as notas da função cadastrar,  para a calcular a media dentro da função listar_notas?

 

 

import subprocess
def cadastrar():
    nota1 = float(input("Nota I: "))
    nota2 = float(input("Nota II: "))
    nota3 = float(input("Nota III: "))
    nota4 = float(input("Nota IV: "))

    arquivo = open('teste.txt', 'a')
    arquivo.write('{},{},{},{}\n'.format(nota1, nota2, nota3, nota4))
    arquivo.close()
    
    subprocess.run(["notepad" , "teste.txt"])
    
def listar_notas():
    
    arquivo = open('teste.txt', 'r')
    linhas = arquivo.readlines()
    arquivo.close()
    print("{:20}{:20}{:20}{:20}".format("Nota I", "Nota II", "Nota III", "Nota IV"))
    
    for linha in linhas:
        nota1, nota2, nota3, nota4 = linha.strip().split(",")
        print("{:20}{:20}{:20}{:20}".format(nota1, nota2, nota3, nota4))
        

while True:
    print('\n1. Cadastrar Notas')
    print('2. Listar Notas | Media')
    print('3. Sair')
    opcao = int(input())
    if opcao == 1:
        cadastrar()
    if opcao == 2:
        listar_notas()
    if opcao == 3:    
        break
 

Share this post


Link to post
Share on other sites

Oi, blz, espero que ajude, não sei se é exatamente isto que você precisa

 

 

import subprocess


def cadastrar():
    print('='*30)
    print('Inclusão de Notas:')
    nota1 = float(input('Nota I: '))
    nota2 = float(input('Nota II: '))
    nota3 = float(input('Nota III: '))
    nota4 = float(input('Nota IV: '))
    media = (nota1 + nota2 + nota3 + nota4) / 4

    arquivo = open('teste.txt', 'a')
    arquivo.write(f'{nota1},{nota2},{nota3},{nota4},{(media):.1f}\n')   #.format(nota1, nota2, nota3, nota4, media))
    arquivo.close()
    #subprocess.run(['notepad', 'teste.txt'])

def listar_notas():
    arquivo = open('teste.txt', 'r')
    linhas = arquivo.readlines()
    arquivo.close()
    print('=' * 91)
    print('{:20}{:20}{:20}{:20}{:20}'.format('Nota I', 'Nota II', 'Nota III', 'Nota IV', 'Média Geral'))
    print('=' * 91)
    for linha in linhas:
        nota1, nota2, nota3, nota4, media = linha.strip().split(',')
        print(f'{(nota1):20}{(nota2):20}{(nota3):20}{(nota4):20}{(media)}')
        #print('{:20}{:20}{:20}{:20}{}'.format(nota1, nota2, nota3, nota4, media))

while True:
    print('='*30)
    print('''=   1. Cadastrar Notas       =
=   2. Listar Notas | Media  =
=   3. Sair                  = ''')
    print('=' * 30)
    opcao = int(input('Digite sua opção: '))
    if opcao == 1:
        cadastrar()
    elif opcao == 2:
        listar_notas()
    elif opcao == 3:
        print('Programa Finalizado pelo Usuário!!!')
        print('==//'*7)
        exit()
    else:
        print('     OPÇÃO INVÁLIDA!!!\n'
              '    TENTE NOVAMENTE!!!')

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By TheLord23
      ESTOU COMEÇANDO AGORA NA PROGRAMAÇÃO COM VISUALG E TERIA QUE COLOCAR ESTE CODIGO EM UM LAÇO DE REPETIÇÃO.
      POREM NÃO ESTOU CONSEGUINDO PODERIAM ME AJUDAR ?
       
      SÓ PENSANDO QUE O USUÁRIO IRA DIGITAR O TAMANHO DO VETOR, APOS ISSO CADA OPÇÃO QUE ELE ESCOLHER E ELA SER EXECUTADA DE FORMA CORRETA ELE VOLTARA PARA O MEUNU PRINCIPAL DAS OPÇÕES ATE QUE ELE SELECIONE A OPÇÃO "F"
       
      POREM TENTEI ESCREVELO USANDO ENQUANTO MAS ACABOU QUE EU NÃO CONSIGO PREVINIR OS ERROS DO USUÁRIO QUANDO ELE COLOCA AS INFORMAÇÕES
       
      TIPO:
      -ARMAZENAR UM NÚMERO NO VETOR E ESSE NÚMERO NÃO SER SOBRESCREVIDO ATE QUE O PROGRAMA SEJA ENCERRADO
      -SE ELE DIGITAR PRA BUSCAR OU INSERIR O NÚMERO ZERO O PROGRAMA INFORMAR QUE O VALOR É INVÁLIDO
       
      TENTEI USAR PROCEDIMENTOS E FUNÇÕES MAS OS ERROS CONTINUARAM.
       
       
       
      Algoritmo "DESAFIO"
      Var
         AUX,CONTADOR,BUSCAR:INTEIRO
         POSICAO,AUX_TEMP:INTEIRO
         OPCAO:CARACTERE
         RESULT_BUSCA: LOGICO
         SOMA_VET:REAL
         NUMERO:VETOR[1..500]DE INTEIRO
      Inicio
         ESCREVAL("*********************************")
         ESCREVAL("* CADASTRO DE VETORES - DESAFIO *")
         ESCREVAL("*********************************")
         ESCREVA("DIGITE O TAMANHO DO VETOR A SER CADASTRADO: ")
         LEIA(AUX)
         NUMERO[AUX] <- AUX
         ESCREVAL("A - Cadastrar um novo número;")
         ESCREVAL("B - Buscar um número")
         ESCREVAL("C - Excluir um número;")
         ESCREVAL("D - Listar os números cadastrados;")
         ESCREVAL("E - Exibir a soma dos números do vetor;")
         ESCREVAL("F - Sair do sistema.")
         LEIA(OPCAO)
         OPCAO <- MAIUSC(OPCAO)
         ESCOLHA OPCAO
         CASO "A"
            PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA
               ESCREVA("DIGITE O VALOR QUE SERÁ ARMAZENADO NA",CONTADOR,"ª POSIÇÃO DO VETOR: ")
               LEIA(NUMERO[CONTADOR])
            FIMPARA
         CASO "B"
            ESCREVA("QUAL NÚMERO DESEJA ENCONTRAR: ")
            LEIA(BUSCAR)
            PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA
               SE NUMERO[CONTADOR] = BUSCAR ENTAO
                  RESULT_BUSCA <- VERDADEIRO
                  POSICAO <- CONTADOR
               FIMSE
            FIMPARA
            PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA
               ESCREVAL(NUMERO[CONTADOR])
            FIMPARA
            ESCREVAL("")
            ESCREVAL("---------")
            SE RESULT_BUSCA = VERDADEIRO ENTAO
               ESCREVAL("O NÚMERO",BUSCAR,"FOI ENCONTRADO E ESTA NA POSIÇÃO",POSICAO)
            SENAO
               ESCREVAL("O NÚMERO NÃO FOI ENCONTRADO !")
            FIMSE
         CASO "C"
            escreval("QUAL NÚMERO DESEJA EXCLUIR DO VETOR: ")
            leia(BUSCAR)
            SE NUMERO[CONTADOR] = BUSCAR ENTAO
               NUMERO[CONTADOR] <- 0
               ESCREVAL("O NÚMERO",BUSCAR,"NA POSIÇÃO",POSICAO,"DO VETOR FOI EXCLUIDO !")
            FIMSE
            PARA CONTADOR DE 1 ATE NUMERO[AUX]
               PARA AUX DE CONTADOR + 1 ATE AUX FACA
                  SE NUMERO[AUX] > NUMERO[CONTADOR]
                     AUX_TEMP <- NUMERO[AUX]
                     NUMERO[AUX] <- NUMERO[CONTADOR]
                     NUMERO[CONTADOR] <- AUX_TEMP
                  FIMPARA
               FIMPARA
               ESCREVA("VALROES DO VETOR: ")
               PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA
                  ESCREVAL(NUMERO[CONTADOR])
               FIMPARA
            CASO "D"
               ESCREVA("VALORES DO VETOR: ")
               PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA
                  ESCREVAL(NUMERO[CONTADOR])
               FIMPARA
            CASO "E"
               PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA
                  SOMA_VET <- SOMA_VET + NUMERO[CONTADOR]]
               FIMPARA
               ESCREVAL("")
               ESCREVA("A SOMA DO VETOR É:",SOMA_VET)
               
            CASO "F"
               ESCREVAL("ENCERRANDO SISTEMA...")
            OUTROCASO
               ESCREVAL("OPÇÃO INVÁLIDA !")
            FIMESCOLHA
      Fimalgoritmo
    • By Juliana dos Santos
      Oi gente, 
       
      Eu tenho uma tabela no banco de dados do snowflake que é atualizada por um flat file que é atualizado a cada quinze dias; Sempre que os dados são atualizados nesse flat file ele sobrescreve as informações anteriores e assim não temos histórico dos dados que estavam no banco antes da ultima atualização, isso esta causando uma dor de cabeça por que sempre que ocorre algum erro não temos como voltar para o resultado anterior e o flat file tem que ser refeito por algum analista.
       
      As configurações do banco de dados foram feitas em Sql, enquanto o esquema que rodam para jogar as informações do flat file para a tabela do banco esta em python.
       
      Eu acabei de chegar a essa área e herdei essa criança e tenho pensado em como resolve-lo e criar uma nova tabela que não sobrescreva mas sim empilhe as informações, porem existe uma grande pegadinha nesse processo, esse flat file é atualizado muitas vezes até que ele chegue a sua "versão final" que é utilizada para o fechamento, esse fechamento que não acontece sempre no mesmo dia. Para que o histórico seja confiável ele não pode empilhar os dados toda vez que atualizarmos, apenas quando realmente for fechado.
       
      Vocês conseguem me ajudar? O que devo fazer? Criar um fluxo com algum trigger? mudar a forma que o flat file é alimentado?
       
      Me ajudem a enxergar algum caminho para resolver o que foi criado antes da minha chegada
       
      Desde já agradeço,
      Um beijo e um queijo.
       
      Ju
    • By Mauricio Molina
      Ola pessoal, será que podem me dar uma força?
       
      Preciso fazer um calculo de subtração de valores, onde o administrador seleciona o mes, pego pelo ID, método GET, para edição.
       
      Como normalmente tem vários meses pagos, o script a seguir só esta funcionando no primeiro item da tabela.
       
      Como posso fazer para funcionar em todos os itens da tabela?
       
      Teria que dar um nome diferente no getValor (id no HTML) para cada um, mas como posso fazer isso?
       
      <!-- Calculo Devolucao--> <script type="text/javascript"> function id(valor_campo) { return document.getElementById(valor_campo); } function getValor(valor_campo) { var valor = document.getElementById(valor_campo).value.replace(',', '.'); /*document.write("Valor: " - valor);*/ return parseFloat( valor ) * 1; } function sub() { var total = getValor('v_recebido') - (getValor('v_devolvido')); id('resultadoDev').value = (total * 1) .toFixed(2, "."); } </script> <!-- Calculo Devolucao--> <div class="toggle"> <input name="v_devolvido" type="checkbox" id="foo<?php echo $rows_aluno['id']; ?>" value="<?php echo $rows_aluno['v_recebido']; ?>"> <label for="foo<?php echo $rows_aluno['id']; ?>"></label> </div> <input type="text" id="v_recebido" value="<?php echo $rows_aluno['v_recebido']; ?><?php echo $rows_aluno['v_receb_parc']; ?>" onblur="sub()" > <div class="form-row"> <div class="form-group col-md-6"> <label for="validationCustomUsername">Valor Parcial:</label> <div class="input-group"> <div class="input-group-prepend"> <span class="input-group-text" id="inputGroupPrepend">R$</span> </div> <input name="v_dev_parc" type="text" class="form-control" id="v_devolvido" placeholder="Digite o Valor" aria-describedby="inputGroupPrepend" onblur="sub()"> </div> </div> <input name="id_user" type="hidden" value="<?php echo $rows_aluno['id_user']; ?>"> <input name="id_prof" type="hidden" value="<?php echo $rows_aluno['id_prof']; ?>"> <input name="status" type="hidden" value="Devolvido"> <input name="mes" type="hidden" value="<?php echo $rows_aluno['mes']; ?>"> <input name="v_recebido" type="text" id="resultadoDev"> </div>  
    • By Hyroshima
      Boa noite pessoal, não sei se meu problema está relacionado com a categoria mas não achei outro local melhor ;/
      Eu fiz algumas buscas mas talvez posso estar procurando errado por quê não achei nada que respondesse minha dúvida.
      Eu queria saber se é possível enviar um comando de teclado sem teclado pelo ssh, resumindo eu queria por exemplo executar o comando de teclado Ctrl+B e logo depois a tecla o via terminal, tipo o comando pyautogui.hotkey('ctrl','f5') do python, ou nesse caso eu teria que usar o python para executar esses comandos?
       
      desde já obrigado pela atenção.
    • By Marcos Vilela Alves
      Bom dia. Iniciei em Python há algumas semanas.  não tive problemas até o momento.
       
      Estou desenvolvendo um projeto Python desktop utilizando qtDesigner e Pyqt5. 
      O conflito que tive não encontrei solução.
       
      Tenho um login, que funciona e abre a "tela principal".
      a tela principal tem vários menus. Meu problema agora aparece.
      Eu criei uma tela para gerenciar permissões, porem quando eu clico para abir a tela, ela abre, porém bloqueada.
       
      eu só consigo mexer nela, depois que fecho a principal. 
      Nao encontrei na internet nenhuma referência.
       
      Segue os códigos.
      Tela Principal
      import sys from principal import Ui_principal from PyQt5 import QtCore, uic from PyQt5.QtWidgets import QMainWindow, QApplication from loginAuth import * from permissoes import Ui_Permissoes class form_principal(QMainWindow,Ui_principal): def __init__(self, parent=None): super().__init__(parent) super().setupUi(self) self.mnuSair.triggered.connect(self.Sair) self.mnuPermissoesAcesso.triggered.connect(self.abrePermissoes) def abrePermissoes(self): from form_permissoes import form_permissoes self.per = form_permissoes() self.per.setWindowFlags(QtCore.Qt.WindowStaysOnTopHint) # AlwaysOnTop self.per.show() self.per.setEnabled(True) # tentativa de forcar o habilitar ##Form permissoes import sys from principal import Ui_principal from PyQt5 import QtCore, uic from PyQt5.QtWidgets import QFrame, QMainWindow, QApplication, QDialog from loginAuth import * from fpermissoes import Ui_Frame class form_permissoes (QFrame, Ui_Frame): def __init__(self, parent=None): super().__init__(parent) super().setupUi(self)  
      o arquivo que contem os componentes do formulario é o abaixo, que foi criado pelo QtDesiner e convertido usando o commando pyuic5
      from PyQt5 import QtCore, QtGui, QtWidgets class Ui_Frame(object): def setupUi(self, Frame): Frame.setObjectName("Frame") Frame.resize(619, 300) self.groupBox = QtWidgets.QGroupBox(Frame) self.groupBox.setGeometry(QtCore.QRect(10, 10, 591, 261)) self.groupBox.setObjectName("groupBox") self.treeWidget = QtWidgets.QTreeWidget(self.groupBox) self.treeWidget.setGeometry(QtCore.QRect(10, 20, 571, 231)) self.treeWidget.setObjectName("treeWidget") item_0 = QtWidgets.QTreeWidgetItem(self.treeWidget) item_1 = QtWidgets.QTreeWidgetItem(item_0) item_2 = QtWidgets.QTreeWidgetItem(item_1) item_3 = QtWidgets.QTreeWidgetItem(item_2) item_3 = QtWidgets.QTreeWidgetItem(item_2) self.retranslateUi(Frame) QtCore.QMetaObject.connectSlotsByName(Frame) def retranslateUi(self, Frame): _translate = QtCore.QCoreApplication.translate Frame.setWindowTitle(_translate("Frame", "Permissões")) self.groupBox.setTitle(_translate("Frame", "Menus")) self.treeWidget.headerItem().setText(0, _translate("Frame", "Menus")) __sortingEnabled = self.treeWidget.isSortingEnabled() self.treeWidget.setSortingEnabled(False) self.treeWidget.topLevelItem(0).setText(0, _translate("Frame", "Arquivo")) self.treeWidget.topLevelItem(0).child(0).setText(0, _translate("Frame", "Cadastro")) self.treeWidget.topLevelItem(0).child(0).child(0).setText(0, _translate("Frame", "Solos")) self.treeWidget.topLevelItem(0).child(0).child(0).child(0).setText(0, _translate("Frame", "PH")) self.treeWidget.topLevelItem(0).child(0).child(0).child(1).setText(0, _translate("Frame", "M.O")) self.treeWidget.setSortingEnabled(__sortingEnabled)  
      Como eu disse, a tela abre, mas como se estivesse bloqueada.

       
       
       
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.