Ir para o conteúdo

Publicidade

 Estatísticas do Fórum

  • 0 Usuários ativos

    0 membro(s), 0 visitante(s) e 0 membros anônimo(s)

Cursos Online iMasters
Foto:

algoritmo - visualg

  • Por favor, faça o login para responder
11 respostas neste tópico

#1 valdir calixto

valdir calixto
  • Membros
  • 134 posts

Postado 12 abril 2007 - 17:10

Um cinema possui capacidade de 100 lugares e está sempre com ocupação total. Certo dia, cada espectador respondeu a um questionário, no qual constava:

• sua idade;
• sua opinião em relação ao filme, segundo as seguintes notas:

Nota Significado
A Ótimo
B Bom
C Regular
D Ruim
E Péssimo

Elabore um algoritmo que, lendo estes dados, calcule e imprima:

• a quantidade de respostas ótimo;
• a média de idade das pessoas que responderam ruim;
• a percentagem de respostas péssimo e a maior idade que utilizou esta opção
  • 0

#2 Vergil

Vergil

    Hammer smashed face

  • Membros
  • 756 posts

Postado 13 abril 2007 - 09:46

Eu não lembro como se calcula a porcentagem, então fica pra você fazer. :thumbsup:

Segue o código:

algoritmo "semnome"
// Função :
// Autor : Vergil
// Data : 13/04/2007
// Seção de Declarações 
var
   idade, contar, somaidade, respostasA, respostasD, maioridade : inteiro
   nota : caracter
   media : real
inicio
	  respostasA <- 0
	  respostasD <- 0
	  somaidade <- 0
	  maioridade <- 0

	  para contar de 1 ate 10 faca
		   // Recebe os valores do usuário
		   escreva("Digite a idade do ", contar, " espectador: ")
		   leia(idade)
		   escreva("Digite a nota do ", contar, " espectador: ")
		   leia(nota)
		   
		   // Pegar a quantidade de pessoas que responderam "ótimo"
		   se nota = "a" entao
			  respostasA <- respostasA + 1
		   senao se nota = "d" entao // Pegar a quantidade de pessoas que responderam "ruim"
			  respostasD <- respostasD + 1
			  somaidade <- somaidade + idade
			  
			  // Pegar a maior idade
			  se idade > maioridade entao
				 maioridade <- idade
			  fimse
		   fimse
	  fimpara

	  // Média de idades de pessoas que responderam "d"
	  media <- somaidade / respostasD
	  
	  escreva("Quantidade de pessoas que avaliaram o filme como otimo: ", respostasA)
	  escreva("Media de idades das pessoas que responderam 'ruim': ", media)
	  escreva("A maior idade de quem respondeu 'ruim': ", maioridade)
fimalgoritmo

:rolleyes:
  • 0

#3 valdir calixto

valdir calixto
  • Membros
  • 134 posts

Postado 13 abril 2007 - 15:08

Eu não lembro como se calcula a porcentagem, então fica pra você fazer. :thumbsup:

Segue o código:

algoritmo "semnome"
// Função :
// Autor : Vergil
// Data : 13/04/2007
// Seção de Declarações 
var
   idade, contar, somaidade, respostasA, respostasD, maioridade : inteiro
   nota : caracter
   media : real
inicio
	  respostasA <- 0
	  respostasD <- 0
	  somaidade <- 0
	  maioridade <- 0

	  para contar de 1 ate 10 faca
		   // Recebe os valores do usuário
		   escreva("Digite a idade do ", contar, " espectador: ")
		   leia(idade)
		   escreva("Digite a nota do ", contar, " espectador: ")
		   leia(nota)
		   
		   // Pegar a quantidade de pessoas que responderam "ótimo"
		   se nota = "a" entao
			  respostasA <- respostasA + 1
		   senao se nota = "d" entao // Pegar a quantidade de pessoas que responderam "ruim"
			  respostasD <- respostasD + 1
			  somaidade <- somaidade + idade
			  
			  // Pegar a maior idade
			  se idade > maioridade entao
				 maioridade <- idade
			  fimse
		   fimse
	  fimpara

	  // Média de idades de pessoas que responderam "d"
	  media <- somaidade / respostasD
	  
	  escreva("Quantidade de pessoas que avaliaram o filme como otimo: ", respostasA)
	  escreva("Media de idades das pessoas que responderam 'ruim': ", media)
	  escreva("A maior idade de quem respondeu 'ruim': ", maioridade)
fimalgoritmo

:rolleyes:


Obrigado, amigo!!!!! Sua ajuda foi muito importante

Valeu
  • 0

#4 gabrielmenezes

gabrielmenezes
  • Membros
  • 2 posts

Postado 11 junho 2010 - 14:45

Me respondam em viasualg esse algoritmo!

3. Faça um algoritmo que armazene em um vetor de caracteres todas as vogais, da seguinte forma:

//atribuindo valores ao vetvogais
vetvogais[1] <- "a"
vetvogais[2] <- "e"
vetvogais[3] <- "i"
vetvogais[4] <- "o"
vetvogais[5] <- "u"

Posteriormente este algoritmo deve exibir na tela as vogais da seguinte forma:

a
ae
aei
aeio
aeiou
  • 0

#5 JhOnE RoSsInI

JhOnE RoSsInI
  • Membros
  • 72 posts

Postado 12 junho 2010 - 00:57

Me respondam em viasualg esse algoritmo!

3. Faça um algoritmo que armazene em um vetor de caracteres todas as vogais, da seguinte forma:

//atribuindo valores ao vetvogais
vetvogais[1] <- "a"
vetvogais[2] <- "e"
vetvogais[3] <- "i"
vetvogais[4] <- "o"
vetvogais[5] <- "u"

Posteriormente este algoritmo deve exibir na tela as vogais da seguinte forma:

a
ae
aei
aeio
aeiou

nao sei se tem outra maneira de fazer ta ai uma
algoritmo "semnome"
// Função :
// Autor :
// Data : 12/6/2010
// Seção de Declarações 
var
letra:vetor[1..5] de caracter
inicio
// Seção de Comandos
letra[1] <- "a"
letra[2] <- "e"
letra[3] <- "i"
letra[4] <- "o"
letra[5] <- "u"
escreval("",letra[1])
escreval("",letra[1], "",letra[2])
escreval("",letra[1], "",letra[2], "",letra[3])
escreval("",letra[1], "",letra[2], "",letra[3], "",letra[4])
escreval("",letra[1], "",letra[2], "",letra[3], "",letra[4], "",letra[5])
fimalgoritmo

Editado por quitZAUMMM, 14 junho 2010 - 14:31 .
Inclusão da tag [code]

  • 0

#6 gabrielmenezes

gabrielmenezes
  • Membros
  • 2 posts

Postado 13 junho 2010 - 14:54

Vou deixar aqui mais 3 exercícios em visualg galera!

4.Um programador de computador insere as notas de 11 alunos em um vetor de números reais.
Faça um programa que indique para o professor dessa disciplina qual é a nota mediana da turma. A nota mediana é a nota de um aluno que possui 5 notas menores a ela e a mais 5 notas maiores a ela.
OBS.: Considere que não existe a possibilidade de duas notas serem iguais.

5.Construa um programa em Visual para calcular a média de valores PARES e ÍMPARES, de 50 números que serão digitados pelo usuário. Ao final o algoritmo deve mostrar estas duas médias. Esses dados devem ser armazenados em um vetor. Além disso, devem ser impressos os valores PARES maiores que a média PAR, bem como os valores ÍMPARES menor que a média ÍMPAR.

6.Faça um programa que recebe do usuário dos inteiros que representam um intervalo inteiro fechado. Depois, calcule qual o maior número primo desse intervalo. Se não houver número primo no intervalo informado, o programa deve exibir 0 (zero).
OBS.: Considere a quantidade máxima de números entre o intervalo igual a 100.
  • 0

#7 Matheus Brito

Matheus Brito

    Estudando...

  • Membros
  • 3.503 posts

Postado 13 junho 2010 - 17:35

Pessoal tem que responder as dúvidas e os algoritmos, de uma forma que estimule o pensamento, das pessoas que requisitam as respostas e não responder os algoritmos.
Abs
  • 0

#8 quitZAUMMM

quitZAUMMM

    YES, WE CAN

  • Moderadores
  • 3.923 posts

Postado 14 junho 2010 - 14:32

beleza deixa os exercicios ai kk

[]s
  • 0

#9 JhOnE RoSsInI

JhOnE RoSsInI
  • Membros
  • 72 posts

Postado 15 junho 2010 - 17:35

5.Construa um programa em Visual para calcular a média de valores PARES e ÍMPARES, de 50 números que serão digitados pelo usuário. Ao final o algoritmo deve mostrar estas duas médias. Esses dados devem ser armazenados em um vetor. Além disso, devem ser impressos os valores PARES maiores que a média PAR, bem como os valores ÍMPARES menor que a média ÍMPAR.

ta ai meio pronta feito no vidualg beleza
algoritmo "media numero par e impar"
// Função :
// Autor :JhOnE RoSsInI
// Data : 15/6/2010
// Seção de Declarações 
var
i:inteiro  //contador obrigatório ser do tipo inteiro
media_par,media_impar,impar_soma,par_soma:real //cálculo
num,par,impar:inteiro //obrigado a ser inteiro variavel da exeibição
inicio
// Seção de Comandos
para i de 1 ate 50 faca
    escreva("Informe uma número :") //pede para o usuário informar um número
    leia(num)
    se(num mod 2 = 0)entao  //verifica se é par ou impar
       par_soma <- num + par  //soma o número par
       escreval("Par",num) //exibe o número digitado par
       senao
       impar_soma <- num + impar_soma  //soma o número impar
       escreval("Impar",num) //exibe o número digitado impar
    fimse
fimpara
media_par <- par_soma / i  //calcula a média dos números par
media_impar <- impar_soma / i  //calcula a média dos números impar
escreval("A média dos numeros pares é :",media_par)
escreva("A média dos números impar é :",media_impar)
fimalgoritmo

Editado por quitZAUMMM, 16 junho 2010 - 10:24 .
Inclusão da tag [code]

  • 0

#10 JhOnE RoSsInI

JhOnE RoSsInI
  • Membros
  • 72 posts

Postado 31 agosto 2010 - 01:17

algoritmo "media numero par e impar"

// Função :

// Autor :JhOnE RoSsInI

// Data : 15/6/2010

// Seção de Declarações

var

i:inteiro  //contador obrigatório ser do tipo inteiro

media_par,media_impar,impar_soma,par_soma:real //cálculo

num,par,impar:inteiro //obrigado a ser inteiro variavel da exeibição

inicio

// Seção de Comandos

para i de 1 ate 10 faca

    escreva("Informe uma número :") //pede para o usuário informar um número

    leia(num)

    se(num mod 2 = 0)entao  //verifica se é par ou impar

       par_soma <- num + par  //soma o número par

       escreval("Par",num) //exibe o número digitado par

       senao

       impar_soma <- num + impar_soma  //soma o número impar

       escreval("Impar",num) //exibe o número digitado impar

    fimse

fimpara

media_par <- par_soma / i  //calcula a média dos números par

media_impar <- impar_soma / i  //calcula a média dos números impar

se(media_par >= par_soma) entao

   escreva("A media do número par é mairo do que a soma")

   senao

   escreva("A soma dos numeros pares é maior que a media")

fimse

se(media_impar >= impar_soma) entao

   escreval("A média é maior do que a soma dos números impares")

   escreval("")

   senao

   escreva("A soma dos numeros impar e maior do que a média")

   escreval("")

fimse

escreval("A média dos numeros pares é :",media_par)

escreval("A média dos números impar é :",media_impar)

fimalgoritmo

  • 0

#11 Rapa

Rapa
  • Membros
  • 1 posts

Postado 15 novembro 2011 - 10:37

Alguem poderia me ajudar nestes dois casos nao comsigo resolve-los precisa ser no visual g

A - Crie um algoritmo que receba um número inteiro diferente de zero, e calcule o
fatorial deste número. (Fatorial de um número é igual ao produto dos números
1 ao número desejado - inclusive. Ex: 3! (fatorial de 3 é igual a: 1x2x3 = 6)

B - Escreva um algoritmo que repita a soma dos números recebidos até que o
total seja maior que cem.
  • 0

#12 quitZAUMMM

quitZAUMMM

    YES, WE CAN

  • Moderadores
  • 3.923 posts

Postado 17 novembro 2011 - 15:54

hummmm
  • 0




Publicidade

/ins>