Ir para o conteúdo

Publicidade

 Estatísticas do Fórum

  • 0 Usuários ativos

    0 membro(s), 0 visitante(s) e 0 membros anônimo(s)

Cursos Online iMasters
Foto:

Mega Sena Visualg

  • Por favor, faça o login para responder
1 resposta neste tópico

#1 Tales S.C

Tales S.C
  • Membros
  • 1 posts

Postado 23 novembro 2011 - 17:15

estou fazer um algoritmo da mega sena, gerei seis numeros e mostrei na tela os 6 numeros sem repetição, agora eu gostaria de colocar na ordem crescente. Alguem me ajuda a aplicar o Método Bolha?? Não estou Conseguindo, Obrigado.

var
Concorda: Caractere
i,j,x,n,r,o: inteiro
valor: vetor[1..6] de inteiro
funcao NumAle(inter: inteiro; Cn: logico; Cm: logico): inteiro
inicio
r <- int(rand*inter)
se (Cm) então
r <- r + 1
fimse
se (Cn) então
r <- (r - int(inter/2))
fimse
retorne r
fimfuncao
inicio
i <- 1
repita

escreval (" 1 - Sortear números ")
escreval (" 2 - Mostrar números sorteados ")
escreval (" 3 - Verificar aposta ")
escreval (" 9 - Encerrar programa ")
escreva ("Digite a opção desejada: ")
leia (n)
escreval ()
Se (n = 1) então
Escreval(" Sorteiro Realizado ")
Escreval("--------------------")
Escreva("Quer limpar a tela?, Sim ou Não: ")
Leia(Concorda)
Se Concorda = "Sim" então
Limpatela
Senao
Fimse

Para i de 1 ate 6 faca
valor[i] <- NumAle(60, falso, verdadeiro), ",")
x <- i-1
Fimpara
i <- 1
Para i de 1 ate 6 faca
Se valor[i] > valor[i+1] então
valor[i] <- NumAle(60, falso, verdadeiro), ",")
valor[i] <- o
o <- valor[i]
Fimse
Fimpara
senao
Se (n=2)então
para j de 1 ate 1 faca
escreval (j, "º Sorteio ")
para i de 1 ate 6 faca
escreva (valor[i], ",")
fimpara
fimpara
fimse
fimse

ate n=9
Escreval("Obrigado por visitar nosso sistema!")
fimalgoritmo

Editado por quitZAUMMM, 30 novembro 2011 - 17:04 .
Inclusão da tag [code]

  • 0

#2 quitZAUMMM

quitZAUMMM

    YES, WE CAN

  • Moderadores
  • 3.923 posts

Postado 30 novembro 2011 - 17:06

Por favor idente seu código.

http://profandreagar...ry/2o-ciclo/ed/

[]s
  • 0




Publicidade

/ins>