Jump to content

SergioCavalcante

Members
  • Content count

    8
  • Joined

  • Last visited

Community Reputation

0 Comum

About SergioCavalcante

  1. SergioCavalcante

    Relacionamento de tabelas

    Estou Perdido ..... tenho as seguintes tabelas Usuario(id,nome)Veiculos(id,modelo)Cor(id,cor)Placa(id,placa) ou seja na barra de menu da minha aplicação posso cadastrar cada item dividualmente submenus usuario, veiculo, cor e assim por diante...... cadastrei um Usuario ID =1 JOSE DA SILVA, que esta ultizando o Veiculo ID=2 CELTA de Cor ID=6 VERDE de Placa ID= 10 HXB-3223 mas vamos supor que o mesmo Usuario saia com o Veiculo ID=2 CELTA de Cor ID =3 AZUL de Placa ID=4 HXX-0122 com faço para ter controle dessas informações . tenho que criar outra tabela que campos deve conter ? como faço para recuperar estas informações ? como vou saber quais carros este usuário saiu?
  2. SergioCavalcante

    Campo Data erro

    Banco Firebird sistema feito em Delphi Solicitei a um programador que fizesse um programa para cadastro de cliente ate ai blz. no windows xp o programa funciona perfeitamente quando mudei de sistema operacional para w7,w8 percebi que alguns campos do tipo data estão sendo editado erroneamente se por exemplo eu digitar 08/12/1985 no w7,w8 aparece algo do tipo 8\2\5 ele tenta preencher de traz para frente a data engolindo alguns caracteres, já no windows xp preenche os campos perfeitamente .Sera que o erro esta no BD ..alguém tem alguma ideia.
  3. SergioCavalcante

    Algoritmos (visualg)

    var nome : literal horas, depen : inteiro vh, vd,sal_bruto, inss, ir, salario_liq: real inicio Escreval("FICHA DO FUNCIONÁRIO") Escreval("") Escreval("_____________________________________") Escreval("") Escreval("INFORME O NOME DO FUNCIONARIO") leia(nome) Escreval("Digite o números de horas trabalhadas.:") leia(horas) Escreval("Digite a Qtde de dependentes.:") leia(depen) vh <- horas*20.00 vd <- depen*40.00 sal_bruto <- vh+vd inss <- (sal_bruto *8.5)/100 ir <- (sal_bruto*0.5)/100 salario_liq <- sal_bruto - inss - ir Escreval("Funcionário .:",nome) Escreval("Salário bruto.:",sal_bruto) Escreval("Desconto IR .:",ir) Escreval("Salario liquido.:",salario_liq) fimalgoritmo var i,num_inicial, num_final, num_pares, num_impares:inteiro inicio num_pares <-0 num_impares<-0 Escreva ("Digite o número inicial: ") leia(num_inicial) Escreva ("Digite o número final que seja maior que o numero inicial ") leia(num_final) enquanto (num_final >= num_inicial) faca se( num_inicial mod 2=0)entao num_pares<-num_pares+1 senao num_impares <-num_impares+1 fimse num_inicial <- num_inicial +1 fimenquanto Escreval("Qtde de números pares = ",num_pares) Escreval("Qtde de números impares = ",num_impares) Fimalgoritmo var i,j,aux:inteiro A:vetor[1..15]de inteiro inicio Para i de 1 ate 15 faca escreval("O valor Original de A : ",i,"º posicão") leia(A) fimpara Para j de 1 ate 14 faca Para i de 1 ate 14 faca Se A < A[i+1] entao Aux <-A A <- A[i+1] A[i+1]<- aux fimse fimpara fimpara escreval() escreval() Para i de 1 ate 15 faca escreval("O valor atualizado de A[",i,"] =",A) Fimpara Fimalgoritmo NÃO ADIANTA COPIAR E COLAR SE NÃO ENTENDER O CÓDIGO.....OS COMENTARIOS FICA POR SUA CONTA
  4. SergioCavalcante

    Esperava encontrar então (VisuAlg)

    inicio // Seção de Comandos escreval("Digite o salário do funcionário:") leia(sal) se (sal <=100)entao Nsal <-(sal*0.15+sal) fimse se (sal >700 )e(sal<=1000) entao Nsal <-(sal*0.10+sal) fimse se (sal > 1000) entao Nsal <-(sal*0.05+sal) fimse escreval("O novo salário do funcionário é de:R$", Nsal) fimalgoritmo
  5. var nome,cpf:caracter v1:vetor[1..2]de caracter salario,i:inteiro inicio para i<-1 ate 1 faca Escreva("Informe o nome: ") leia(v1[1]) Escreva("Informe o cpf: ") leia(v1[2]) Escreva("Informe o Salario: ") leia(salario) se(salario<=200)entao Escreval("O usuario: ",v1[1], " cpf :",v1[2]," salario R$:",salario," esta insento") senao Escreva("O usuario: ",v1[1], " cpf : ",v1[2]," salario R$:",salario," não esta insento") fimse fimpara V se isso te dar uma luz.....
  6. SergioCavalcante

    Visualg

    salarioBase <-1000 orcamentoProjeto <- 4000 se(orcamentoProjeto > 10000) e (orcamentoProjeto < 20000) entao comissao <-orcamentoProjeto*0.10 fimse se (orcamentoProjeto > 20000)entao comissao <- orcamentoProjeto*0.10 fimse INNS <- salarioBase * 0.08 se (salarioBase > 12000 e salarioBase < 2700) entao IRRF <- salarioBase * 0.11 fimse se(salario > 2700)entao IRRF <- salarioBase * 0.275 fimse salarioLiquido <-(salarioBase + Comissao ) – (INSS + IRRF) entenda a logica .......... nada de copiar e colar ainda falta pedir para o usuario informar o valor dos salario e orcamento do projeto.........
  7. SergioCavalcante

    Visualg Cálculo Imposto de Renda

    se (salarioB < 1787.77)ou(salarioB = 1787.77) entao escreval("Isento de Imposto de Renda") senao se (salarioB >= 1787.78)e(salarioB <= 2679.29) entao imposto<- salarioB*0.075-134.08.................................. agora e só continuar Bons Estudos
  8. SergioCavalcante

    Cálculo de combustível

    Não da para resolver ,pelo motivo de não saber o valor da passagem e o consumo litro por quilometro
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.