Jump to content

Svinnicius

Members
  • Content count

    1
  • Joined

  • Last visited

Everything posted by Svinnicius

  1. Ao sair de um procedimento e entrar em outro, ta apresentando erro quando tento finalizar o programa. Var // Seção de Declarações das variáveis nome: vetor [1..3] de caractere telef: vetor [1..3] de caractere ema: vetor [1..3] de caractere codigo,codigo_contato,codigo_contato_cheio, menu_apagar,opc, opc1: inteiro cont, menu_mostrar,op: inteiro procedimento principal() Inicio // Seção de Comandos, procedimento, funções, operadores, etc... repita escreval ("") escreval ("=== AGENDA TELEFÔNICA ===") escreval ("") escreval ("1. Inserir novo contato") escreval ("2. Apagar contato") escreval ("3. Mostrar todos os contatos") escreval ("4. Sair") escreva ("Digite opcao: ") leia (codigo) limpatela ate (codigo=1) ou (codigo=2) ou (codigo=3) ou (codigo=4) escolha (codigo) caso 1 contato() caso 2 apagar() caso 3 mostrar() caso 4 interrompa fimescolha fimprocedimento //---------------------- NOVO CONTATO ---------------------- procedimento contato() inicio para cont de 1 ate 3 faca limpatela escreval("== INSERIR NOVO CONTATO ==") escreva ("Nome: ") leia (nome[cont]) escreva ("Telefone: ") leia (telef[cont]) escreva ("E-mail: ") leia (ema[cont]) escreval("") escreval("Usuario cadrastrado com sucesso") repita escreval("") escreval("1.Insira novo contato") escreval("2.Voltar ao menu") escreval("") escreva("Digite opção: ") leia(codigo_contato) escolha (codigo_contato) caso 1 escreva("") caso 2 interrompa limpatela principal() outrocaso escreval("") escreval("Opção invalida") escreval("") escreval("Pressione ENTER para voltar") leia(op) limpatela fimescolha ate codigo_contato = 1 fimpara limpatela escreval("") escreval("Lista de contato cheia") repita escreval("") escreval("1.Voltar ao menu") escreval("2.Sair") escreval("") escreval("Digite opção") leia(codigo_contato_cheio) escolha (codigo_contato_cheio) caso 1 limpatela principal() caso 2 interrompa outrocaso escreval("") escreval("Opção invalida") escreval("") escreval("Pressione ENTER para voltar") leia(op) limpatela fimescolha ate codigo_contato_cheio = 1 fimprocedimento //------------------------ Apagar contato------------------------------------ procedimento apagar() inicio limpatela escreval("== APAGAR CONTATO ==") Escreval("") escreva ("Qual contato você quer apagar? ") Escreval("") para cont de 1 ate 3 faca Escreval(cont,". ",nome[cont]) fimpara Escreval("") Escreva("Digite opção:") Leia(opc) se opc >0 entao se opc <4 entao nome[opc]<-"" telef[opc]<-"" ema[opc]<-"" Escreval("") Escreval("Contato Apagado com sucesso") repita escreval("") escreval("1.Apagar outro contato") escreval("2.Voltar ao menu") escreval("3.Sair") escreva("Digite opção:") leia(menu_apagar) Escolha(menu_apagar) caso 1 limpatela apagar() caso 2 limpatela principal() caso3 interrompa outrocaso escreval("") escreval("Opção invalida") escreval("") escreval("Pressione ENTER para voltar") leia(op) senao apagar() fimse fimse fimse fimescolha ate menu_apagar = 3 fimprocedimento //-------------------------- Mostrar todos os contatos --------------------- procedimento mostrar() inicio limpatela escreval("== LISTA DE CONTATOS ==") Escreval("") para cont de 1 ate 3 faca Escreval(cont,". ",nome[cont]) fimpara Escreval("") Escreva("Digite opção:") Leia(opc1) se opc1 >0 entao se opc1 <4 entao limpatela Escreval("Nome: ",nome[opc1]) Escreval("Telefone: ",telef[opc1]) Escreval("E-mail: ",ema[opc1]) repita escreval("") escreval("1.Mostrar outro contato") escreval("2.Voltar ao menu") escreval("") escreva("Digite opção:") Leia(menu_mostrar) Escolha(menu_mostrar) caso 1 limpatela mostrar() caso 2 limpatela principal() outrocaso escreval("") escreval("Opção invalida") escreval("") escreval("Pressione ENTER para voltar") leia(op) senao mostrar() fimse fimse fimescolha limpatela ate menu_mostrar = 1 fimprocedimento inicio // Seção de Comandos principal() Fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.