Jump to content

Archived

This topic is now archived and is closed to further replies.

Fabyo

Zend Framework

Recommended Posts

Grande Fabyo,

Cara baixei o sistema e fui usar e está dando o seguinte erro:

 

Warning: require_once(Zend/Loader.php) [function.require-once]: failed to open stream: No such file or directory in C:\Arquivos de programas\Apache Software Foundation\Apache2.2\htdocs\sites\Zend_Login_Plugin\index.php on line 23

Fatal error: require_once() [function.require]: Failed opening required 'Zend/Loader.php' (include_path='.;library\;application\controllers\plugins\;application\models\;.;C:\php5\pear') in C:\Arquivos de programas\Apache Software Foundation\Apache2.2\htdocs\sites\Zend_Login_Plugin\index.php on line 23

Realmente não existe este diretorio

Share this post


Link to post
Share on other sites

Fabyo, não sei como te passar o resultado do firebug... =/

 

nunca o utilizei..

 

se me der uma dica estou disposto a te ajudar! =D

 

Abraço.

 

Att,

 

Leandro Barral []'..

Share this post


Link to post
Share on other sites

Opa Fabyo,

Cara agora baixei o zend coloquei no lugar certo, porém redireciona para /login e diz que este diretorio realmente não existe, lá nos arquivos realmente não tem.

Share this post


Link to post
Share on other sites

Qual erro está dando Rasp??

 

Seguinte.. você vai baixar o zend pelo endereço que o fabyo passou..

 

Dai você pega a pasta "Zend" que está dentro do zip e joga no diretório "library" que tem no zip que o Fabyo upou..

 

Agora é só executar o BASE.SQL que está na raiz do que o Fabyo upou, fazendo isso você terá as tabelas necessárias..

Vá na pasta includes que está na raiz e modifique os dados do arquivo config_db.pho para os de sua conexão.

 

Agora crie um usuario com senha (a senha utilizando função md5) e já era..

 

Att,

 

Espero ter ajudado.

 

Leandro Barral []'..

Share this post


Link to post
Share on other sites

Falae Leandro,

Pô cara fiz esses procedimentos todos e quando eu acesso o end, ele redireciona para /login e dá pag não encontrada, tô estranhando isso

Share this post


Link to post
Share on other sites

Verifique a url e veja se esta certo

 

e sobre o diretorio, se tiver usando linux lembre-se que ele é sensivel a letras maiusculas e minusculas, entao se tiver incluindo um Loader.php e o seu tiver loader.php ele vai dizer que o arquivo nao existe.

Share this post


Link to post
Share on other sites

Opa Fabyo, tudo bem?

Então... não alterei absolutamente NADA, simplismente acesso a pag e sou direcionado para /login e me aparece Not found, estou usando Windows

Share this post


Link to post
Share on other sites

Entao mas como fica sua url ?

 

e outra coisa você ta usando apache?, se sim ta habilitado o ModRewrite?

Share this post


Link to post
Share on other sites

Tira uma screen da estrutura de suas pastas..

 

Tem alguma coisa errada ae.. =)

 

Att,

 

Leandro Barral []'..

Share this post


Link to post
Share on other sites

Fala fabyo, está habilitado sim tanto que uso em um projeto... também acho estranho...

 

Segue abaixo o print da estrutura de pastas:

 

Imagem Postada

Share this post


Link to post
Share on other sites

Dentro da library como está?

 

está assim:

 

library/Zend/"arquivos-e-pastas-do-zend" ??

 

E quando retorna página não encontrada como fica a url??

 

Att,

 

Leandro Barral[]'..

Share this post


Link to post
Share on other sites

Opa galera!

Pensei em uma coisa hoje... mais não sei se é possível... eu estou utilizando a versão minimal do zend... será este o problema?

Vlw!!

abs

Share this post


Link to post
Share on other sites

você tentou usar a versão completa aquela famosa de ~13mb??

 

faz o teste e manda o resultado..

 

Att,

 

Leandro Barral []'..

Share this post


Link to post
Share on other sites

Fala Leandro.

Cara agora está apresentando este erro:

 

Fatal error: Uncaught exception 'Zend_Loader_PluginLoader_Exception' with message 'Plugin by name DocType was not found in the registry.' in /home/logmania/public_html/zend_login/Zend/Loader/PluginLoader.php:370 Stack trace: #0 /home/logmania/public_html/zend_login/Zend/View/Abstract.php(1114): Zend_Loader_PluginLoader->load('DocType') #1 /home/logmania/public_html/zend_login/Zend/View/Abstract.php(545): Zend_View_Abstract->_getPlugin('helper', 'DocType') #2 /home/logmania/public_html/zend_login/Zend/View/Abstract.php(312): Zend_View_Abstract->getHelper('DocType') #3 [internal function]: Zend_View_Abstract->__call('DocType', Array) #4 /home/logmania/public_html/zend_login/application/views/scripts/layout.phtml(1): Zend_View->DocType('XHTML1_STRICT') #5 /home/logmania/public_html/zend_login/Zend/View.php(107): include('/home/logmania/...') #6 /home/logmania/public_html/zend_login/Zend/View/Abstract.php(787): Zend_View->_run('application/vie...') #7 /home/logmania/public_html/zend_login/Zend/Layout.php(785): Zend_View_Abstr in /home/logmania/public_html/zend_login/Zend/Loader/PluginLoader.php on line 370

 

e mesmo mudando tanto para a full quanto minimal, está apresentando o mesmo... ao q entendi está dando erro de plugin

Share this post


Link to post
Share on other sites

Nao é erro de programaçao nem plugin, pode ser do proprio Zend.

 

deve ser algum arquivo com nome sensitivo que o linux nao conseguiu carregar por exemplo DocType é diferente de doctype

 

se a classe ta chamando por Doc Type, ele vai procurar o arquivo DocType, dai se o arquvo ta com nome minusculo o linux nao vai achar ele

 

como eu uso Windows, nao vi esse problema, mas com certeza é isso ai

 

erro "Plugin by name DocType was not found" ali ele ta falando que nao achou esse arquivo, procure por esse arquivo na pasta zend e renomeie ele desse jeito que pede a classe

 

 

OBS: fui conferir e é isso mesmo veja o nome do arquivo na pasta library\Zend\View\Helper\

 

Doctype.php

Share this post


Link to post
Share on other sites

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.