Jump to content
guinevere_gwen

Diversos exercicios - Algoritmos de iniciante

Recommended Posts

Pessoal, tirei nota baixa e não to sabendo bem como fazer esses algoritmos, q tem q ser entregues até a segunda feira q vem.. por favor, se alguém puder me dar uma ajuda, agradeceria muito em ajudar com alguns favores em troca... abaixo segue a lista: http://forum.imasters.com.br/public/style_emoticons/default/upset.gif :blink: http://forum.imasters.com.br/public/style_emoticons/default/thumbsup.gif

 

 

1.Um número é, por definição, primo se ele não tem divisores, exceto 1 e ele próprio. Prepare um algoritmo para ler um número inteiro positivo e determinar se ele é ou não um número primo.

 

2.Escreva um algoritmo que leia 10 números informados pelo usuário e, depois, informe o menor, número, o maior número, a soma dos números informados e a média aritmética dos números informados.

 

3.Desenvolva um algoritmo que leia um número inteiro positivo N e imprima a tabuada de multiplicar correspondente. Por exemplo, para n = 6, devemos obter: 1 X 6 = 6, 2 X 6 = 12,..., 10 X 6 = 60).

(Observação: Solucionar a questão utilizando uma das estruturas de repetição)

 

4.Escreva um algoritmo que solicita um número inteiro positivo ao usuário e imprima a soma dos N primeiros números pares maiores do que zero (Por exemplo, se for informado N = 4, o algoritmo deve imprimir o valor 20, pois 2 + 4 + 6 + 8 = 20).

 

5.Um palíndromo é uma seqüência de caracteres que é lida da esquerda para a direita ou da direita para a esquerda. Por exemplo, cada um dos seguintes inteiros de 5 dígitos é um palíndromo: 12321, 55555, 45554 e 11611. Escreva um aplicativo que leia um inteiro de 5 dígitos e determine se ele é ou não um palíndromo. Se o número não for de 5 dígitos, exiba uma mensagem de erro e permita que o usuário insira um novo valor.

(Dica: É possível resolver a questão utilizando somente os operadores %, / e as estruturas enquanto e se).

 

6.Escreva um algoritmo que solicita ao usuário para digitar um número inteiro positivo, e mostre-o por extenso. Este número deverá variar entre 1 e 10. Se o usuário introduzir um número que não pertença a este intervalo, mostre a frase “número inválido”.

(Dica: Utilizar a estrutura de seleção escolha)

 

7.Considere um caixa automático com apenas um repositório com capacidade para armazenar 1000 notas de 10 reais. Elabore um algoritmo para ler um valor e fornecer a quantidade de notas correspondente a esse valor. O seu algoritmo deve manter a quantidade de notas no repositório atualizada. Caso o valor lido não possa ser fornecido por falta de notas, o algoritmo deve imprimir uma mensagem indicando o fato. O algoritmo também deve imprimir uma mensagem se o valor não for múltiplo de 10. Após o tratamento do valor lido, com a impressão da mensagem ou o fornecimento das notas correspondentes, o procedimento deve ser repetido. O algoritmo deve parar quando um valor lido for negativo.

 

8.Desenvolva um algoritmo que leia um número inteiro positivo N e imprima os N primeiros números da Série de Fibonacci, assim como a soma desses N primeiros números. A Série de Fibonacci é dada pela seguinte sequência de números inteiros: 1, 3, 7, 15, 31, 63, 127...

(Dica: Utilizar a estrutura de repetição enquanto e o operador de potenciação)

Share this post


Link to post
Share on other sites

Pesquise aqui no forum mesmo, grande parte desses exercicios tem resolvidos aqui.

Os que você consegui axar, você tenta entender e faz, os que nao consegui vai pedindo ajuda individal de cada um, que assim fica mais facil, lógico tentando fazer tb.

Abs

Share this post


Link to post
Share on other sites

já fechei um tópico, pedi para ler as regras e outro tópico falando "ajuda", + td bem.. dessa vz vo soh editar..

 

---

Título Editado:

 

ALGORITMOS - alguem pode me ajudar, por favor?, Iniciante http://forum.imasters.com.br/public/style_emoticons/default/seta.gif Diversos exercicios - Algoritmos de iniciante

 

---

 

Faço as palavras do kikuse as minhas ;D

 

[]s

Share this post


Link to post
Share on other sites

tudo bem, vamos ao q interessa..

jah "rabisco" algum pra gente começar?

 

[]s

Share this post


Link to post
Share on other sites

cara vou te ajudar pq eu tb tive dificuldade em algoritmos.. aos poucos eu vou postando

 

uma dica: use o programa visualg pra testar os algortimos

http://www.baixaki.com.br/download/visualg.htm

 

o exercicio 2

 

algoritmo "semnome"

var
numero: vetor [1..10] de inteiro
i, maior, menor, soma: inteiro
media: real

inicio
// incluindo os numeros
Para i de 1 ate 10 faca
   Escreva ("Digite o", i, " numero: ")
   Leia (numero[i])
   limpatela
Fimpara

// maior numero
// vamos assumir que o primeiro numero digitado é o maior
// comeca do 2 justamente pq eu ja assumi que o 1 e o maior
maior <- numero[1]
para i de 2 ate 10 faca
   se numero[i]>maior entao
	  maior <- numero [i]
   fimse
fimpara

// menor numero
// agora vamos assumir que o primeiro numero digitado é o menor
// mesmo esquema
menor <- numero[1]
para i de 2 ate 10 faca
   se numero[i]<menor entao
	  menor <- numero [i]
   fimse
fimpara

//soma e media
soma <- 0
para i de 1 ate 10 faca
   soma <- soma + numero[i]
fimpara
media <- soma/10

//apresentacao dos valores
Escreval ("o maior valor e: ", maior)
Escreval ("o menor valor e: ", menor)
Escreval ("a soma dos valores e: ", soma)
Escreval ("a media dos valores e: ", media)

fimalgoritmo

Share this post


Link to post
Share on other sites

o 3

 

algoritmo "semnome"
// Função :
// Autor :
// Data : 14/5/2009
// Seção de Declarações 
var
i,n: inteiro
inicio
// Seção de Comandos
Escreval ("digite o numero para obter a tabuada")
Leia (n)
Para i de 1 ate 10 faca
Escreval (i, " X", n, " =", i*n)
fimpara
fimalgoritmo

Share this post


Link to post
Share on other sites

4.Escreva um algoritmo que solicita um número inteiro positivo ao usuário e imprima a soma dos N primeiros números pares maiores do que zero (Por exemplo, se for informado N = 4, o algoritmo deve imprimir o valor 20, pois 2 + 4 + 6 + 8 = 20).

 

algoritmo:

// Função :
// Autor :RDS/Tobia
// Data : 1/8/2009
// Seção de Declarações 
var
n,c, soma: inteiro

inicio
      escreval("Digite um Número")
      leia(n)
      soma <- 0
      para  c de 0 ate n faca
           soma <- soma + (c * 2)
      
      fimpara
      escreva(" a soma é: ",soma)


fimalgoritmo
Edited by hargon
Adicionado BBCode [CODE]

Share this post


Link to post
Share on other sites

exercicio numero 4.

 

Em linguagem VB.NET

 

 

 

Dim num1, num2, contador As Integer

        num1 = CInt(TextBox1.Text)
        contador = 0
        num2 = 0

        While contador < num1
            contador = contador + 1
            num2 = num2 + 2
            MessageBox.Show(num2)
        End While
Edited by quitZAUMMM
Inclusão da tag [code]

Share this post


Link to post
Share on other sites

exercicio 1 e desculpe pela demora, vou tentar resolver todos

visualg -

1.Um número é, por definição, primo se ele não tem divisores, exceto 1 e ele próprio. Prepare um algoritmo para ler um número inteiro positivo e determinar se ele é ou não um número primo.

 

 

algoritmo "semnome"
// Função :
// Autor : Mrs8.o
// Data : 12/01/2010
// Seção de Declarações 
var
num,n4,cont,x:inteiro
inicio
enquanto n4 <> 1 faca
   escreva("Escreva um número inteiro Positivo  :")
   leia (num)
     se (num>0) entao //para garantir que ele é um número inteiro - restrição-
     n4 <- 1
        para cont de 2 ate num-1 faca     //vai de 2 até o numero menos 1 - ele contao tanto de vezes-
             se (num mod cont)=0 entao   //verifica se do 2 até o num não tem nenhum divisor ou divisão que de exata
                x <- x + 1   //quando alguma vez der exata a divisão, o x se tornará valendo 1, provando que não é primo
             fimse
        fimpara
         se (x<>0)entao   //pega o x e confirma
                  escreval("Ele não é um número primo")
                  senao
                  escreval("Ele é um número primo")
         fimse
         
     senao
     escreval
     escreval
     n4 <- 0
     fimse
fimenquanto
fimalgoritmo
Edited by quitZAUMMM
Inclusão da tag [code]

Share this post


Link to post
Share on other sites
//1.Um número é, por definição, primo se ele não tem divisores, exceto 1 e ele
//próprio. Prepare um algoritmo para ler um número inteiro positivo e
//determinar se ele é ou não um número primo.
algoritmo "primo"

var
num, cont, x, i:inteiro
inicio

enquanto i <> 1 faca
  escreva("Escreva um número inteiro Positivo  :")
  leia (num)
    se (num>0) entao
    i <- 1
       para cont de 2 ate num-1 faca
            se (num mod cont)=0 entao
               x <- x + 1
            fimse
       fimpara
            se (x<>0)entao
                 escreval("O ",num," não é um número primo")
                 senao
                 escreval("O ",num," é um número primo")
            fimse

    senao
    i <- 0
    fimse
fimenquanto
fimalgoritmo

//2.Escreva um algoritmo que leia 10 números informados pelo usuário e, depois,
//informe o menor, número, o maior número, a soma dos números informados e a
//média aritmética dos números informados.
algoritmo "maior, menor, soma, media"

var
numero: vetor [1..10] de inteiro
i, maior, menor, soma,cont: inteiro
media: real

inicio
cont <- 1
soma<- 0

Para i de 1 ate 10 faca
escreval
  Escreva ("Digite o", i, " numero: ")
  Leia (numero[i])
limpatela

         maior <- numero[1]

  se numero[i]>maior entao
     maior <- numero [i]
  fimse

              menor <- numero[1]

        se numero[i]<menor entao
           menor <- numero [i]
        fimse


soma <- soma + numero[i]
media <- soma/cont
cont <- cont + 1

escreval
Escreval ("o maior valor e: ", maior)
Escreval ("o menor valor e: ", menor)
Escreval ("a soma dos valores e: ", soma)
Escreval ("a media dos valores e: ", media)

fimpara

fimalgoritmo

//3.Desenvolva um algoritmo que leia um número inteiro positivo N e imprima a
//tabuada de multiplicar correspondente. Por exemplo, para n = 6, devemos
//obter: 1 X 6 = 6, 2 X 6 = 12,..., 10 X 6 = 60).
algoritmo "semnome"
var
i,n: inteiro
inicio

Escreval ("digite o numero para obter a tabuada")
Leia (n)

    Para i de 1 ate 10 faca
    Escreval (i, " X", n, " =", i*n)

fimpara

fimalgoritmo

//4.Escreva um algoritmo que solicita um número inteiro positivo ao usuário e
//imprima a soma dos N primeiros números pares maiores do que zero
//(Por exemplo, se for informado N = 4, o algoritmo deve imprimir o valor 20,
//pois 2 + 4 + 6 + 8 = 20).

algoritmo "soma dos primeiros n"

var
n,c, soma: inteiro

inicio
     escreval("Digite um Número")
     leia(n)
     soma <- 0

          para  c de 0 ate n faca
                 soma <- soma + (c * 2)

          fimpara

escreva(" a soma é: ",soma)

fimalgoritmo

algoritmo "Palindromo"

var
palavra1: caractere
Resp: caractere
h: logico
i, j:inteiro

inicio
repita
limpatela
escreva("Digite uma palavra: ")
leia(Palavra1)
i <- 1
j <- compr(Palavra1)
h <- verdadeiro

   enquanto (i<j)  faca
      escreval(copia(palavra1,i,1))
      escreval(copia(palavra1,j,1))
      se copia(palavra1,i,1)=copia(palavra1,j,1) entao
         h<-verdadeiro
      senao
         h<-falso
      fimse
      j<-j-1
      i<-i+1
   fimenquanto

escreval

se h=verdadeiro entao
  escreval("A palavra informada eh um palindromo.")
senao
  escreval("A palavra informada nao eh um palindromo.")
fimse
escreval

   escreva("Continuar (*/n): ")
   leia(Resp)
ate Resp = "N"

fimalgoritmo

//6.Escreva um algoritmo que solicita ao usuário para digitar um número inteiro
//positivo, e mostre-o por extenso. Este número deverá variar entre 1 e 10. Se
//o usuário introduzir um número que não pertença a este intervalo, mostre a
//frase "número inválido".
//(Dica: Utilizar a estrutura de seleção escolha)

algoritmo "valor por estenso"
var num: vetor [1..10] de caractere
  a:caracter
 i: inteiro
inicio
repita
escreval("digite um numero inteiro entre 1 e 10: ")
leia(i)

num[1] <- "um"
num[2] <- "dois"
num[3] <- "três"
num[4] <- "quatro"
num[5] <- "cinco"
num[6] <- "seis"
num[7] <- "sete"
num[8] <- "oito"
num[9] <- "nove"
num[10]<- "dez"

se (i >0) e (i < 11) entao
escreval (" o numero ",i," por estenso é: ",num[i])
senao
escreval (" o numero ",i," não corresponde ao valor entre 1 e 10")
fimse
escreval
escreval( "para uma no pesquisa digite s ou n")
leia(a)
limpatela
ate  a="n"
fimalgoritmo

//7.Considere um caixa automático com apenas um repositório com capacidade para
//armazenar 1000 notas de 10 reais. Elabore um algoritmo para ler um valor e
//fornecer a quantidade de notas correspondente a esse valor. O seu algoritmo
//deve manter a quantidade de notas no repositório atualizada. Caso o valor
//lido não possa ser fornecido por falta de notas, o algoritmo deve imprimir
//uma mensagem indicando o fato. O algoritmo também deve imprimir uma mensagem
//se o valor não for múltiplo de 10. Após o tratamento do valor lido, com a
//impressão da mensagem ou o fornecimento das notas correspondentes, o
//procedimento deve ser repetido. O algoritmo deve parar quando um valor lido
//for negativo.
algoritmo "caixa eletronico"

var nt,ret,i: inteiro
tn:real
j:logico
cont:caracter
inicio

tn<-0
nt<- 10000
i<-10

repita
  repita

     escreval("ATENÇÃ!!! este terminal possui apenas notas de $10")
     escreval
     escreval("para cancelar aperte o zero ")
     escreval
     escreval("quanto deseja retirar : ")
     leia (ret)

          se ret mod i <> 0 entao
          j<- falso
          limpatela
          escreval("ATENÇÃO VALOR INCORRETO")
          timer 3000
          timer 0
          fimse
          limpatela
               se ret mod i = 0 entao
               j<- verdadeiro
               fimse
                    se ret > nt entao
                       j<- falso
                           limpatela
                           escreval("terminal com dinheiro insuficiênte")
                           timer 3000
                           timer 0
                           fimse
                           limpatela
  ate j = (verdadeiro) ou (ret = 0)
escreval("$",ret," corresponde à",ret/i," ceduala(s) de $10")
escreval
escreva("deseja realizar outra operação? s ou ")
escreval("n")
leia (cont)
limpatela
nt<- nt - ret
                    se ret > nt entao
                       cont<-"n"
                           limpatela
                           escreval("terminal com dinheiro insuficiênte")
                           timer 3000
                           timer 0
                           fimse
                           limpatela
ate (cont = "n")
escreval("operação encerrada")
escreval
escreval("OBRIGADO TENHA UM BOM DIA")

fimalgoritmo

//8- Desenvolva um algoritmo que leia um número inteiro positivo N e imprima os
// N primeiros números da Série de Fibonacci, assim como a soma desses N
//primeiros números. A Série de Fibonacci é dada pela seguinte sequência de
//números inteiros: 1, 3, 7, 15, 31, 63, 127...
//(Dica: Utilizar a estrutura de repetição enquanto e o operador de potenciação)

algoritmo "Fibonacci"

var num,i,j:inteiro
a:caracter

inicio
repita
limpatela
      escreval("ate qua valor gostaria de ver a seguenci de Fibonacci?")
      leia(num)
      j<- 0
      i<- 1
               enquanto (i = num)ou (i<num)  faca
               i<- i+ j
                   se i <= num entao
                      escreva(i," ")
                      j<- i + 1
                   fimse
               fimenquanto
escreval
escreval
escreval("para uma nova consulta digite s ou n")
leia(a)
ate a= "n"
fimalgoritmo

Edited by quitZAUMMM
Inclusão da tag [code]

Share this post


Link to post
Share on other sites

a maioria dos loops tem uma variável contadora..

de + uma olhada no fórum amigo.

 

[]s

Share this post


Link to post
Share on other sites

Aqui vai uma dica deste algoritmo em C#

 

4.Escreva um algoritmo que solicita um número inteiro positivo ao usuário e

imprima a soma dos N primeiros números pares maiores do que zero

(Por exemplo, se for informado N = 4, o algoritmo deve imprimir o valor 20,

pois 2 + 4 + 6 + 8 = 20).

 

Cria um form (windows form application)

Defina um campo de entrada (textbox1)

Defina um Botão Calcular

Defina um campo de soma (textbox2)

 

private void button1_Click(object sender, EventArgs e)

{

int num1 = 0;

int num2 = 0;

num1 = Convert.ToInt16(textBox1.Text);

int soma = 0;

 

for (int a=0; a < num1; a++)

{

num2 = num2 + 2;

soma = soma + num2;

}

textBox2.Text = Convert.ToString(soma);

}

 

Espero que sirva e seja útil!

Abraços!

Bruno

Edited by ABruno

Share this post


Link to post
Share on other sites

Exercício 6

algoritmo "semnome"

// Função :Escreva um algoritmo que solicita ao usuário para digitar um número inteiro positivo, e mostre-o por extenso.

//Este número deverá variar entre 1 e 10.

//Se o usuário introduzir um número que não pertença a este intervalo, mostre a frase “número inválido”

// Autor : isauhn

// Data : 21/04/2012

// Seção de Declarações

var

x: inteiro

inicio

// Seção de Comandos

escreva ("Digite um número inteiro positivo:")

leia (x)

escolha x

caso 2, 3, 4, 5, 6, 7, 8, 9

escreval (x)

outrocaso

escreval ("número inválido")

fimescolha

fimalgoritmo

Edited by isauhn

Share this post


Link to post
Share on other sites
algoritmo "NumeroPrimo"
// Soma dos 10 primeiros números primos
// Autor: Al Cruz
// 28/10/2014
var
    N,S: Inteiro
inicio
    S <- 0
    Para N de 1 ate 20 Faca
       Se(N % 2 <> 0) entao
          S <- S + N
          Escreval(N," é primo")
       FimSe
    FimPara
          Escreva("Soma dos Números Primos: ",S)
fimalgoritmo

Faça um programa que imprima a soma de [/size]10 primeiros números primos.[/size]

algoritmo "NumeroPrimo"

// Soma dos 10 primeiro números primos

// Autor: Al Cruz

// 28/10/2014

var

N,S: Inteiro

inicio

S <- 0

Para N de 1 ate 20 Faca

Se(N % 2 <> 0) entao

S <- S + N

Escreval(N," é primo")

FimSe

FimPara

Escreva("Soma dos Números Primos: ",S)

fimalgoritmo

Share this post


Link to post
Share on other sites

var

x, y:inteiro

 

inicio

 

escreval(o primeiro numero)

leia(x)

escreval(o segundo numero)

leia(y)

escreva(a soma dos numeros é ,x+y)

 

finalgoritmo

Share this post


Link to post
Share on other sites

Olá, pessoal , alguem pode me ajudar com essa questão , pois não tô conseguindo fazer os comandos ... Será que é possivel fazer o que a questão pede??

 

---- Receber do usuário o número de linhas e colunas de uma matriz de inteiros e preenchê-la de acordo com os valores informados pelo usuário. Ao final exibir a soma dos elementos inseridos  na matriz.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.