Jump to content

Archived

This topic is now archived and is closed to further replies.

snowstormdelivery

Preciso de ajuda para interpretar exercício de vetores

Recommended Posts

Segundo minha cognição, o exercício pede para ler dois vetores distintos, então somar cada elemento correspondente e, apresentá-los num terceiro vetor. O problema é que o exemplo do enunciado não faz jus, ao que acabei de falar. Confiram:

 

"Faça uma subrotina que receba dois vetores V1(100) e V2(100) em que cada posição contem um dígito

e retorne V3(101) com a soma dos números nos vetores.
Ex: V1 = 0 0 0 3 2 1
V2 = 0 0 4 7 3 2
-----------------------

V3 = 0 0 5 0 5 3"

 

Vocês podem reparar que o exemplo não mostra as somas (V3) corretamente, então pode ser algo diferente do que eu compreendi!
Será que li certo, ou é pra fazer outra coisa?

Share this post


Link to post
Share on other sites

Cara eu acho que pode ser um erro de impressão ou de enunciado. Pelo que eu entendi é necessário somar as posições correspondentes. Sugiro perguntar ao seu orientador.

Share this post


Link to post
Share on other sites

Cara eu acho que pode ser um erro de impressão ou de enunciado. Pelo que eu entendi é necessário somar as posições correspondentes. Sugiro perguntar ao seu orientador.

Você notou que o vetor V possui 101 elementos? Mais que o necessário!

Não tenho orientador e o autor da apostila não responde a e-mails, então vou fazer da forma que acho correto.

Eu só precisava disso, obrigado!

Share this post


Link to post
Share on other sites

  • Similar Content

    • By TATIANE DEOTI
      PRECISO RESPONDER ATRAVÉS DO VISUALG MAS NÃO ESTOU CONSEGUINDO FORMULAR
       
      Uma loja por atacado vende caixas com 30 unidades de cada produto. Faça um algoritmo no Visualg que leia o valor pago por um cliente,  o valor do troco recebido e o nome do produto adquirido. Em seguida, calcule e mostre o valor que foi pago por cada unidade do produto, no seguinte formato: "o produto __ custa R$ __ por unidade".
    • By Pavolin9
      Bom dia, estou desenvolvendo um sistema bem simples de estoque onde os itens serao armazenados em uma matriz segue codigo:
          package main;          import java.io.Console;     import java.util.Arrays;     import java.util.Scanner;          public class IncluirItem{         public static void main(String[] args) {             String[][] itens = new String[2][5];             String[] campos = new String[7];             int opcao = 0;             int remover;             int verificar = 0;             int adcionar = 0;             int tamanho = 2;                          Scanner sc = new Scanner(System.in);                          campos [1] = "Nome";             campos [2] = "Codigo de barras";             campos [3] = "quantidade";             campos [4] = "validade";             campos [5] = "data de entrada";                          do {                 System.out.println("\n\n### Sistema de estoque - simplificado ###");                 System.out.println("=========================================");                 System.out.println("      |     1 - Adcionar itens   |");                 System.out.println("      |     2 - Excluir itens    |");                 System.out.println("      |     3 - Mostrar itens    |");                 System.out.println("      |     0 - Sair             |");                 System.out.println("=========================================\n");                                  System.out.println("Escolha uma opcao: ");                 opcao = sc.nextInt();                 System.out.print("\n");                                  switch (opcao) {                 case 1:                     System.out.println("Cadastro de itens: ");                     //Adciona itens                      for (int i = 0; i <2; i++) {                         System.out.println("Adcionar item? ");                         System.out.println("1 para sim \n2 para nao: ");                         adcionar = sc.nextInt();                         if (adcionar == 1) {                             System.out.printf("%d. item \n", (i+1));                             verificar = verificar + 1;                             for (int j=0; j < 5; j++) {                                     System.out.printf("%s ", campos[j+1]);                                 System.out.printf("= ", i,(j+1));                                 itens[i][j] = sc.next();                                                              }                             System.out.printf("\n");                         }                         else {                             break;                         }                     }                                              break;                 case 2:                     //Remove itens                     System.out.println("Exclusao de itens: ");                     if(verificar > 0) {                         for (int i = 0; i <2; i++) {                                 System.out.printf("%d. item \n", (i+1));                             System.out.printf("ID do produto= 00%d \n", (i+1));                             System.out.printf("\n");                         }                     }                     else {                         System.out.println("Nenhum item listado!");                     }                     System.out.println("\nEscolha o numero do item a ser removido: \n");                     remover = sc.nextInt();                     for (int i = 0; i <2; i++) {                         if(remover == 2) {                         itens[i] = itens[i-1];                         }                     }                     break;                 case 3:                     //Mostra itens                     if(verificar > 0) {                                                      for (int i = 0; i <2; i++) {                                     if (verificar == 2) {                                 System.out.printf("%d. item \n", (i+1));                                 System.out.printf("ID do produto= 00%d \n", (i+1));                                 for (int j=0; j < 5; j++) {                                         System.out.printf("%s ", campos[j+1]);                                     System.out.printf("= %s \n", itens [i][j]);                                 }                                 System.out.printf("\n");                             }                             else {                                         itens = Arrays.copyOf(itens, tamanho - 1);                                         verificar = 0;                                         System.out.printf("%d. item \n", (i+1));                                         System.out.printf("ID do produto= 00%d \n", (i+1));                                         for (int j=0; j < 5; j++) {                                                 System.out.printf("%s ", campos[j+1]);                                             System.out.printf("= %s \n", itens [i][j]);                                         }                                         System.out.printf("\n");                                         break;                                 }                         }                     }                     else {                         System.out.println("Nenhum item listado!");                     }                                          break;                 default:                     System.out.println("Opção Inválida!");                     break;                 }             } while(opcao != 0);         }     }  
      Minha duvida é a seguinte, eu quero excluir uma posicao da matriz, exemplo: registrei dois itens, na coluna um e coluna dois da matriz e gostaria de remover a coluna um da lista, como realizo essa função, e outra coisa, eu gostaria de quando eu inserisse pela segunda vez algum item a matriz começasse na proxima possicao vazia, atualmente se eu pedir para inserir um novo item a matriz começa da primeira posicao e assim apaga os elementos ja inseridos.
       
    • By g.dmatos
      Preciso desenvolver um algoritmo no Visualg, da função y=3x+8, onde, a partir da informação de um valor para a variável independente x, o sistema automaticamente informe o valor da variável dependente y.
       
      porém quando vou executar da erro no código:
      var x, y: real inicio escreval("Digite o valor do coeficiente x") leia(x) Escreval ("O valor da conta é igual a:" + y) Leia (y) y=(3.x)+8 fimdoalgoritmo  
    • By TEC2587
      Quando eu excuto o algoritmo, a primeira condição comporta-se bem, mas apartir da segunda aparece o erro:
       
      Esperava-se encontrar ENTAO na linha  "se((med=<8.9) e (med>=8))entao"
      Esperava-se encontrar ENTAO na linha  "escreval("Seu rendimento foi muito bom"
       
      Algoritmo "semnome"
       
       
      Var
         med: real
      Inicio
         escreval("-------------------")
         escreval(" RENDIMENTO ESCOLAR")
         escreval("--------------------")
         escreval("Qual é a sua média: ")
         leia(med)
         se ((med=10) ou (med>=9))entao
            escreval ("Seu rendimento foi excelente")
         senao
            se ((med=<8.9) e (med>=8))entao
               escreval("Seu rendimento foi muito bom")
            senao
               se ((med= 7.9) e (med>=7))entao
                  escreval("Seu rendimento foi bom")
               senao
                  se ((med=6.9) e (med>=6))entao
                     escreval("Seu rendimento foi regular")
                  senao
                     se ((med=5.9) e (med>=5))entao
                        escreval("Seu rendimento foi insuficiente")
                     senao
                        escreval("Seu rendimento foi ruim")
                     fimse
                  fimse
               fimse
            fimse
         fimse
      Fimalgoritmo
    • By vanessalopes
      Olá Gente me ajudam a resolver esses exercícios? Vamos lá   ( TODOS ESSES PROGRAMAS A ESTRUTURA DE REPETIÇÃO E ENQUANTO E SE TAMBÉM OBRIGADA)
       
      1 - Imprima Os Números Primos Compreendidos entre 1 e 100 e faça um algoritmo para resolver esse problema.
       
      Eu Montei o Algoritmo dessa forma, ele roda mais o resultado não tá exato no Visual G, se puder me ajudar com essa questão 
       
      var p,n:inteiro
      inicio
       
      leia (n) 
      p<- 1
      enquanto p<=100 faca
      se p mod = 0 entao
      escreva (" Esse Numero é Primo",p)
      senao
      escreva (" Esse numero não é Primo")
      fimse
      fimenquanto
      fimalgoritmo
       
      2 - faça um algoritmo para que seja digitado a idade e diga se a pessoa e maior de idade ou não faça isso até que alguém digite 100 anos.
       
      estrutura de repetição enquanto faca/se entao
       
      3 -faça um algoritmo que imprima de 1 a 100 de forma decrescente 
       
      estrutura de repetição enquanto
      acrescentei o exemplo d<-d-1  mesmo assim não rodou
       
      4- construa um algoritmo que diga os divisores de 100 compreendidos de 1 a 20 
       
      bom, esse também eu fiz mais não conseguir roda 
       
       
      5 - DIVISOES DO TRIANGULO E DIZER SE O MESMO E ISOCELE, ESCALENO OU EQUILATERIO 
       
      LEIA (L1)
      LEIA (L2)
      LEIA (L3)
      ....
      (SE)
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.