Jump to content
Sign in to follow this  
marialuiza

Visualg função/subrotina

Recommended Posts

A prefeitura de uma cidade fez uma pesquisa entre os seus habitantes, coletando dados sobre o salário e número de filhos. Faça uma função que leia esses dados para um número não determinado de pessoas e retorne a média do salário da população, a média do número de filhos, o maior salário e o percentual de pessoas com salário até 350 reais.

O final do algoritmo tá dando erro, como faço para mudá-lo?
Var
// Seção de Declarações das variáveis
f: inteiro
oi,s: real
x, opcao: caracter
funcao prefeitura (var a,b: real): real
var
ms, mf, maiors, ps, contfilhos, contsalario, somasalario, contsalario350: real
inicio
contfilhos <- 0
contsalario <- 0
somasalario <-0
contsalario350 <- 0
maiors <- 0
enquanto s>=0 faca
se s>maiors entao
maiors <- s
fimse
somasalario <- somasalario + s
contsalario <- contsalario + 1
se s <= 350 entao
contsalario350 <- contsalario350 + 1
fimse
contfilhos <- contfilhos + f
fimenquanto
mf <- contfilhos/contsalario
ms <- somasalario/contsalario
ps <- (contsalario350/contsalario)*100
retorne maiors
retorne mf
retorne ms
retorne ps
fimfuncao
Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...
x <- "s"
enquanto x="s" faca
escreva ("Digite seu salário: ")
leia (s)
escreva ("Quantos filhos você tem? ")
leia (f)
escreva ("Digite SIM para ccadastrar e NÃO para sair")
leia(opcao)
se (opcao="não") entao
interrompa
senao
se (opcao="sim") entao
oi <- prefeitura(s,f)
fimse
fimse
fimenquanto
oi <- prefeitura(s,f)
oi
Fimalgoritmo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.