Jump to content
anderdl18

[VisualG]Esperava encontrar "entao" e "fimse" mesmo eles estando na linha do código

Recommended Posts

Bom pessoal, estou desenvolvendo um programa em VisualG para uma atividade da Faculdade, que apresente um menu de opções e que permita ao usuário escolher a opção desejada, receba os dados necessários para executar a operação e mostre o resultado. Verificar a possibilidade de opção inválida e não se preocupar com as restrições, como salário inválido. Porém ao executar o mesmo apresenta o erro de "Esperava encontrar entao" e "fimse".

algoritmo "semnome"

var
op: caracter
sal, nsal,: real
meses: inteiro
inicio
// Seção de Comandos
escreva ("Informe o salário R$: ")
leia (sal)
limpatela
   escreval("      MENU       ")
   escreval("1. Novo salário")
   escreval("2. Férias   ")
   escreval("3. Décimo Terceiro")
   escreval("4. Sair        ")
   escreval("                 ")
   escreva ("Informe a operação: ")
   leia (op)
   limpatela
   escolha op
   enquanto op <> 4 faca
   caso "1"
   escreva ("O salário do funcionário é R$:", sal, "reais.")
   se sal <= 350  entao
   escreva ("O novo salário será R$: ", sal*0.15, "reais")
   fimse
   se sal = 350 e <= 600 entao
   escreva ("O novo salário será R$: ", sal*0.10, "reais")
   fimse
   se sal > 600 entao
   escreva ("O novo salário será R$: ", sal*0.05, "reais")
   fimse
   caso "2"
   escreva ("O salário acrescido de férias será R$ :" (sal+(sal*0.3)))
   caso "3"
   escreva ("Informe os meses trabalhados")
   leia (meses)
   escreva ("O seu décimo terceiro será RS: " (sal+(sal*meses)/12))
   caso "4"
   escreva ("Encerrar execução")
   outrocaso
   ("Opção inexistente")
   
	fimescolha
	
	fimenquanto

fimalgoritmo

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By g.dmatos
      Preciso desenvolver um algoritmo no Visualg, da função y=3x+8, onde, a partir da informação de um valor para a variável independente x, o sistema automaticamente informe o valor da variável dependente y.
       
      porém quando vou executar da erro no código:
      var x, y: real inicio escreval("Digite o valor do coeficiente x") leia(x) Escreval ("O valor da conta é igual a:" + y) Leia (y) y=(3.x)+8 fimdoalgoritmo  
    • By TEC2587
      Quando eu excuto o algoritmo, a primeira condição comporta-se bem, mas apartir da segunda aparece o erro:
       
      Esperava-se encontrar ENTAO na linha  "se((med=<8.9) e (med>=8))entao"
      Esperava-se encontrar ENTAO na linha  "escreval("Seu rendimento foi muito bom"
       
      Algoritmo "semnome"
       
       
      Var
         med: real
      Inicio
         escreval("-------------------")
         escreval(" RENDIMENTO ESCOLAR")
         escreval("--------------------")
         escreval("Qual é a sua média: ")
         leia(med)
         se ((med=10) ou (med>=9))entao
            escreval ("Seu rendimento foi excelente")
         senao
            se ((med=<8.9) e (med>=8))entao
               escreval("Seu rendimento foi muito bom")
            senao
               se ((med= 7.9) e (med>=7))entao
                  escreval("Seu rendimento foi bom")
               senao
                  se ((med=6.9) e (med>=6))entao
                     escreval("Seu rendimento foi regular")
                  senao
                     se ((med=5.9) e (med>=5))entao
                        escreval("Seu rendimento foi insuficiente")
                     senao
                        escreval("Seu rendimento foi ruim")
                     fimse
                  fimse
               fimse
            fimse
         fimse
      Fimalgoritmo
    • By vanessalopes
      Olá Gente me ajudam a resolver esses exercícios? Vamos lá   ( TODOS ESSES PROGRAMAS A ESTRUTURA DE REPETIÇÃO E ENQUANTO E SE TAMBÉM OBRIGADA)
       
      1 - Imprima Os Números Primos Compreendidos entre 1 e 100 e faça um algoritmo para resolver esse problema.
       
      Eu Montei o Algoritmo dessa forma, ele roda mais o resultado não tá exato no Visual G, se puder me ajudar com essa questão 
       
      var p,n:inteiro
      inicio
       
      leia (n) 
      p<- 1
      enquanto p<=100 faca
      se p mod = 0 entao
      escreva (" Esse Numero é Primo",p)
      senao
      escreva (" Esse numero não é Primo")
      fimse
      fimenquanto
      fimalgoritmo
       
      2 - faça um algoritmo para que seja digitado a idade e diga se a pessoa e maior de idade ou não faça isso até que alguém digite 100 anos.
       
      estrutura de repetição enquanto faca/se entao
       
      3 -faça um algoritmo que imprima de 1 a 100 de forma decrescente 
       
      estrutura de repetição enquanto
      acrescentei o exemplo d<-d-1  mesmo assim não rodou
       
      4- construa um algoritmo que diga os divisores de 100 compreendidos de 1 a 20 
       
      bom, esse também eu fiz mais não conseguir roda 
       
       
      5 - DIVISOES DO TRIANGULO E DIZER SE O MESMO E ISOCELE, ESCALENO OU EQUILATERIO 
       
      LEIA (L1)
      LEIA (L2)
      LEIA (L3)
      ....
      (SE)
    • By lemao_code()
      Bom dia Galera, não sei se este é a div certa para a postagem (div sacou?)
      Mas vamos lá,
      A uns 2meses to estudando linguagens de programação, comecei pela Logica de Programação com o professor Guanabara,Agora estou em Python e HTML5 CSS e Java.
      Python estou no que o professor chama de Mundo 2, aprendendo if, elif, else, já sei operadores aritméticos etc.
      HTML5 está mais no inicio, to aprendendo a trabalha com o css para dar estilo na pagina.(Também sei Banco de Dados no MySQL)
      Mas vamos ao assunto, to procurando colegas que estejam na parecida situação como eu, para realmente estudarmos juntos.
      Certa vez o professor falou que isso ajudaria e muito, e concordo, alguém para ajudar, e alguem para você ajudar, é um crescimento e tanto, então convido-os quem tiver interesse
      duas cabeças pensam mais que 1. (ou não se a outra cabeça for de um gênio!Jobs,BIl,Einsten,Hawking esses cara kk)
      Geralmente, estudos das 4h manhã ate as 6hrs da manhã, depois a noite das 19 até a hora que os olhos sangrarem!
       
      Pode mandar msg aqui no meu perfil, estou online!
      Obrigado!
    • By P4870
      Sou estudante do 1º Ano do curso técnico em Informática do IFSP, e preciso de ajuda para fazer esse Algoritmo usando o visuAlg.
       
      01) Levando em consideração o início dos sistemas de informatização as informações eram armazenadas em arquivo do tipo texto. Analisando internamente estes arquivos pode-se notar que nada mais são do que matrizes, pois cada coluna representava um campo e cada linha uma tupla.
       
      Partindo desta informação construa uma matriz para armazenar o RA, CPF e um código para 40 alunos (no CPF digitar somente os números) e uma matriz que guardará 4 notas de 40 alunos e seus respectivos códigos, criando assim um tipo de relacionamento entre as duas matrizes. O primeiro CPF da matriz 1 representa o aluno que possui as 4 notas da primeira posição da segunda matriz. Após o preenchimento de todos os dados das 2 matrizes você deverá perguntar qual o tipo de consulta deverá ser realizada (1-RA, 2-CPF e 3-Código) se for escolhido a opção 1 deve ser solicitado o RA e pesquisar o mesmo na matriz e mostrar o RA, as 4 notas e a média das 4 notas do aluno, se a opção for 2 você deverá solicitar o CPF e também mostrar o CPF, as 4 notas e a média das 4 notas do aluno e se a opção for 3 você deverá solicitar o CÓDIGO e também mostrar o Código, as 4 notas e a média das 4 notas do aluno. Em ambas as consultas deve ser mostrado a situação do aluno (Aprovado quando a média for no mínimo 6; Recuperação quando a média for no mínimo 4 e não chegar a 6; e Reprovado se a média for inferior a 4).
       
      Ao mostrar cada resultado o sistema deve pedir se o usuário deseja fazer uma nova pesquisa.
       
      Caso deseje deve digitar S(SIM) para continuar ou N(NÃO) para finalizar.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.