Jump to content
BiancaVale

Elemento com maior número de repetições em uma lista python

Recommended Posts

Tenho um input em que o usuário pode inserir nomes de animais:

lista = []
animais = input('Nome do animal: ')
lista.append(animais)

Como faço para obter dessa lista os elementos que mais se repetem?

lista = ['gato', 'cobra', 'gato', 'coruja']

Saída:

gato

Porém, preciso contar essas ocorrências sem utilizar as funções disponíveis para listas como count, set, e etc.

Já busquei em vários fóruns alguma ajuda, pelo menos uma ideia de como começar o código, mas não achei nada que pudesse me ajudar.

Share this post


Link to post
Share on other sites

A única forma que consigo pensar em fazer isso sem usar as funções "comuns", é a seguinte:

 

lista = ['gato', 'cobra', 'gato', 'coruja', 'gato', 'gato', 'cobra']
quantidade_ocorrencias = 0
item_com_maior_ocorrencia = ''
dicionario_items = {}

# adiciona a quantidade de ocorrencias de cada item na lista
for item in lista:
    # se item não tiver no dicionario, adiciona
    if item not in dicionario_items:
        dicionario_items[item] = 0
    # se item já tiver no dicionario, incrementa
    dicionario_items[item] += 1

# pega o elemento com maior ocorrência
for item in dicionario_items:
    # se ocorrência for maior que a anterior, atualiza
    if dicionario_items[item] > quantidade_ocorrencias:
        quantidade_ocorrencias = dicionario_items[item]
        item_com_maior_ocorrencia = item

print(f'O item com maior ocorrência é {item_com_maior_ocorrencia} '
      f'com {quantidade_ocorrencias} ocorrências.')

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By TheLord23
      ESTOU COMEÇANDO AGORA NA PROGRAMAÇÃO COM VISUALG E TERIA QUE COLOCAR ESTE CODIGO EM UM LAÇO DE REPETIÇÃO.
      POREM NÃO ESTOU CONSEGUINDO PODERIAM ME AJUDAR ?
       
      SÓ PENSANDO QUE O USUÁRIO IRA DIGITAR O TAMANHO DO VETOR, APOS ISSO CADA OPÇÃO QUE ELE ESCOLHER E ELA SER EXECUTADA DE FORMA CORRETA ELE VOLTARA PARA O MEUNU PRINCIPAL DAS OPÇÕES ATE QUE ELE SELECIONE A OPÇÃO "F"
       
      POREM TENTEI ESCREVELO USANDO ENQUANTO MAS ACABOU QUE EU NÃO CONSIGO PREVINIR OS ERROS DO USUÁRIO QUANDO ELE COLOCA AS INFORMAÇÕES
       
      TIPO:
      -ARMAZENAR UM NÚMERO NO VETOR E ESSE NÚMERO NÃO SER SOBRESCREVIDO ATE QUE O PROGRAMA SEJA ENCERRADO
      -SE ELE DIGITAR PRA BUSCAR OU INSERIR O NÚMERO ZERO O PROGRAMA INFORMAR QUE O VALOR É INVÁLIDO
       
      TENTEI USAR PROCEDIMENTOS E FUNÇÕES MAS OS ERROS CONTINUARAM.
       
       
       
      Algoritmo "DESAFIO"
      Var
         AUX,CONTADOR,BUSCAR:INTEIRO
         POSICAO,AUX_TEMP:INTEIRO
         OPCAO:CARACTERE
         RESULT_BUSCA: LOGICO
         SOMA_VET:REAL
         NUMERO:VETOR[1..500]DE INTEIRO
      Inicio
         ESCREVAL("*********************************")
         ESCREVAL("* CADASTRO DE VETORES - DESAFIO *")
         ESCREVAL("*********************************")
         ESCREVA("DIGITE O TAMANHO DO VETOR A SER CADASTRADO: ")
         LEIA(AUX)
         NUMERO[AUX] <- AUX
         ESCREVAL("A - Cadastrar um novo número;")
         ESCREVAL("B - Buscar um número")
         ESCREVAL("C - Excluir um número;")
         ESCREVAL("D - Listar os números cadastrados;")
         ESCREVAL("E - Exibir a soma dos números do vetor;")
         ESCREVAL("F - Sair do sistema.")
         LEIA(OPCAO)
         OPCAO <- MAIUSC(OPCAO)
         ESCOLHA OPCAO
         CASO "A"
            PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA
               ESCREVA("DIGITE O VALOR QUE SERÁ ARMAZENADO NA",CONTADOR,"ª POSIÇÃO DO VETOR: ")
               LEIA(NUMERO[CONTADOR])
            FIMPARA
         CASO "B"
            ESCREVA("QUAL NÚMERO DESEJA ENCONTRAR: ")
            LEIA(BUSCAR)
            PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA
               SE NUMERO[CONTADOR] = BUSCAR ENTAO
                  RESULT_BUSCA <- VERDADEIRO
                  POSICAO <- CONTADOR
               FIMSE
            FIMPARA
            PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA
               ESCREVAL(NUMERO[CONTADOR])
            FIMPARA
            ESCREVAL("")
            ESCREVAL("---------")
            SE RESULT_BUSCA = VERDADEIRO ENTAO
               ESCREVAL("O NÚMERO",BUSCAR,"FOI ENCONTRADO E ESTA NA POSIÇÃO",POSICAO)
            SENAO
               ESCREVAL("O NÚMERO NÃO FOI ENCONTRADO !")
            FIMSE
         CASO "C"
            escreval("QUAL NÚMERO DESEJA EXCLUIR DO VETOR: ")
            leia(BUSCAR)
            SE NUMERO[CONTADOR] = BUSCAR ENTAO
               NUMERO[CONTADOR] <- 0
               ESCREVAL("O NÚMERO",BUSCAR,"NA POSIÇÃO",POSICAO,"DO VETOR FOI EXCLUIDO !")
            FIMSE
            PARA CONTADOR DE 1 ATE NUMERO[AUX]
               PARA AUX DE CONTADOR + 1 ATE AUX FACA
                  SE NUMERO[AUX] > NUMERO[CONTADOR]
                     AUX_TEMP <- NUMERO[AUX]
                     NUMERO[AUX] <- NUMERO[CONTADOR]
                     NUMERO[CONTADOR] <- AUX_TEMP
                  FIMPARA
               FIMPARA
               ESCREVA("VALROES DO VETOR: ")
               PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA
                  ESCREVAL(NUMERO[CONTADOR])
               FIMPARA
            CASO "D"
               ESCREVA("VALORES DO VETOR: ")
               PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA
                  ESCREVAL(NUMERO[CONTADOR])
               FIMPARA
            CASO "E"
               PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA
                  SOMA_VET <- SOMA_VET + NUMERO[CONTADOR]]
               FIMPARA
               ESCREVAL("")
               ESCREVA("A SOMA DO VETOR É:",SOMA_VET)
               
            CASO "F"
               ESCREVAL("ENCERRANDO SISTEMA...")
            OUTROCASO
               ESCREVAL("OPÇÃO INVÁLIDA !")
            FIMESCOLHA
      Fimalgoritmo
    • By Juliana dos Santos
      Oi gente, 
       
      Eu tenho uma tabela no banco de dados do snowflake que é atualizada por um flat file que é atualizado a cada quinze dias; Sempre que os dados são atualizados nesse flat file ele sobrescreve as informações anteriores e assim não temos histórico dos dados que estavam no banco antes da ultima atualização, isso esta causando uma dor de cabeça por que sempre que ocorre algum erro não temos como voltar para o resultado anterior e o flat file tem que ser refeito por algum analista.
       
      As configurações do banco de dados foram feitas em Sql, enquanto o esquema que rodam para jogar as informações do flat file para a tabela do banco esta em python.
       
      Eu acabei de chegar a essa área e herdei essa criança e tenho pensado em como resolve-lo e criar uma nova tabela que não sobrescreva mas sim empilhe as informações, porem existe uma grande pegadinha nesse processo, esse flat file é atualizado muitas vezes até que ele chegue a sua "versão final" que é utilizada para o fechamento, esse fechamento que não acontece sempre no mesmo dia. Para que o histórico seja confiável ele não pode empilhar os dados toda vez que atualizarmos, apenas quando realmente for fechado.
       
      Vocês conseguem me ajudar? O que devo fazer? Criar um fluxo com algum trigger? mudar a forma que o flat file é alimentado?
       
      Me ajudem a enxergar algum caminho para resolver o que foi criado antes da minha chegada
       
      Desde já agradeço,
      Um beijo e um queijo.
       
      Ju
    • By Hyroshima
      Boa noite pessoal, não sei se meu problema está relacionado com a categoria mas não achei outro local melhor ;/
      Eu fiz algumas buscas mas talvez posso estar procurando errado por quê não achei nada que respondesse minha dúvida.
      Eu queria saber se é possível enviar um comando de teclado sem teclado pelo ssh, resumindo eu queria por exemplo executar o comando de teclado Ctrl+B e logo depois a tecla o via terminal, tipo o comando pyautogui.hotkey('ctrl','f5') do python, ou nesse caso eu teria que usar o python para executar esses comandos?
       
      desde já obrigado pela atenção.
    • By Marcos Vilela Alves
      Bom dia. Iniciei em Python há algumas semanas.  não tive problemas até o momento.
       
      Estou desenvolvendo um projeto Python desktop utilizando qtDesigner e Pyqt5. 
      O conflito que tive não encontrei solução.
       
      Tenho um login, que funciona e abre a "tela principal".
      a tela principal tem vários menus. Meu problema agora aparece.
      Eu criei uma tela para gerenciar permissões, porem quando eu clico para abir a tela, ela abre, porém bloqueada.
       
      eu só consigo mexer nela, depois que fecho a principal. 
      Nao encontrei na internet nenhuma referência.
       
      Segue os códigos.
      Tela Principal
      import sys from principal import Ui_principal from PyQt5 import QtCore, uic from PyQt5.QtWidgets import QMainWindow, QApplication from loginAuth import * from permissoes import Ui_Permissoes class form_principal(QMainWindow,Ui_principal): def __init__(self, parent=None): super().__init__(parent) super().setupUi(self) self.mnuSair.triggered.connect(self.Sair) self.mnuPermissoesAcesso.triggered.connect(self.abrePermissoes) def abrePermissoes(self): from form_permissoes import form_permissoes self.per = form_permissoes() self.per.setWindowFlags(QtCore.Qt.WindowStaysOnTopHint) # AlwaysOnTop self.per.show() self.per.setEnabled(True) # tentativa de forcar o habilitar ##Form permissoes import sys from principal import Ui_principal from PyQt5 import QtCore, uic from PyQt5.QtWidgets import QFrame, QMainWindow, QApplication, QDialog from loginAuth import * from fpermissoes import Ui_Frame class form_permissoes (QFrame, Ui_Frame): def __init__(self, parent=None): super().__init__(parent) super().setupUi(self)  
      o arquivo que contem os componentes do formulario é o abaixo, que foi criado pelo QtDesiner e convertido usando o commando pyuic5
      from PyQt5 import QtCore, QtGui, QtWidgets class Ui_Frame(object): def setupUi(self, Frame): Frame.setObjectName("Frame") Frame.resize(619, 300) self.groupBox = QtWidgets.QGroupBox(Frame) self.groupBox.setGeometry(QtCore.QRect(10, 10, 591, 261)) self.groupBox.setObjectName("groupBox") self.treeWidget = QtWidgets.QTreeWidget(self.groupBox) self.treeWidget.setGeometry(QtCore.QRect(10, 20, 571, 231)) self.treeWidget.setObjectName("treeWidget") item_0 = QtWidgets.QTreeWidgetItem(self.treeWidget) item_1 = QtWidgets.QTreeWidgetItem(item_0) item_2 = QtWidgets.QTreeWidgetItem(item_1) item_3 = QtWidgets.QTreeWidgetItem(item_2) item_3 = QtWidgets.QTreeWidgetItem(item_2) self.retranslateUi(Frame) QtCore.QMetaObject.connectSlotsByName(Frame) def retranslateUi(self, Frame): _translate = QtCore.QCoreApplication.translate Frame.setWindowTitle(_translate("Frame", "Permissões")) self.groupBox.setTitle(_translate("Frame", "Menus")) self.treeWidget.headerItem().setText(0, _translate("Frame", "Menus")) __sortingEnabled = self.treeWidget.isSortingEnabled() self.treeWidget.setSortingEnabled(False) self.treeWidget.topLevelItem(0).setText(0, _translate("Frame", "Arquivo")) self.treeWidget.topLevelItem(0).child(0).setText(0, _translate("Frame", "Cadastro")) self.treeWidget.topLevelItem(0).child(0).child(0).setText(0, _translate("Frame", "Solos")) self.treeWidget.topLevelItem(0).child(0).child(0).child(0).setText(0, _translate("Frame", "PH")) self.treeWidget.topLevelItem(0).child(0).child(0).child(1).setText(0, _translate("Frame", "M.O")) self.treeWidget.setSortingEnabled(__sortingEnabled)  
      Como eu disse, a tela abre, mas como se estivesse bloqueada.

       
       
       
    • By CarolW
      Já peço desculpas antecipadamente se o post for genérico ou não atender os objetivos do fórum, mas gostaria de dicas para quem está iniciando em ciência de dados e Python. Desde cursos, canais, dicas de IDE e ate mesmo outras coisas que sejam importantes estudar além do Python. Muito obrigada
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.