Jump to content
Sign in to follow this  
KenzuS

[Resolvido] Lista de Exercícios VisuAlg

Recommended Posts

A muito tempo correm umas listas de exercícios de VisuAlg de estrutura de repetição, estou resolvendo ela, mas tem uns exercícios chatinhos, alguém por acaso já resolveu essa lista e poderia me ajudar?

 

Link da lista:

http://www.fag.edu.br/professores/ricardovicari/Sistemas/Lista%20III%20-%20Estrutura%20de%20Repeticao.pdf

 

Já resolvi os exercícios 1,2,3,4,5,7,8,9,15.

Share this post


Link to post
Share on other sites

"Sabe-se que esse caminhão carrega 25 caixas, com pesos diferentes." - Trecho da primeira questão.

Temos que criar uma variável para cada uma das 25 caixas diferentes?

 

Bem, consegui responder, e percebi que esses exercícios são daqueles que fazem agente se acostumar com as operações, fazendo-nos repetí-las várias vezes.

 

O resultado foi este, e rodou perfeitamente.

 

algoritmo "Peso Caminhão"
// este algoritmo é uma tarefa
// ele calculará o peso total de um caminhão
var pesototal, p1, p2, p3, p4, p5, p6, p7, p8, p9, p10, p11, p12, p13, p14, p15, p16, p17, p18, p19, p20, p21, p22, p23, p24, p25 : real
inicio
escreva ("Digite o peso de cada uma das 25 caixas em quilos (KG)")
leia (p1)
leia (p2)
leia (p3)
leia (p4)
leia (p5)
leia (p6)
leia (p7)
leia (p8)
leia (p9)
leia (p10)
leia (p11)
leia (p12)
leia (p13)
leia (p14)
leia (p15)
leia (p16)
leia (p17)
leia (p18)
leia (p19)
leia (p20)
leia (p21)
leia (p22)
leia (p23)
leia (p24)
leia (p25)
pesototal <- p1 + p2 + p3 + p4 + p5 + p6 + p7 + p8 + p9 + p10 + p11 + p12 + p13 + p14 + p15 + p16 + p17 + p18 + p19 + p20 + p21 + p22 + p23 + p24 + p25

escreva ("O peso total da carga é de", pesototal, " Kg.")
fimalgoritmo

Há mais alguma coisa em que eu possa melhorar?

 

Ok, aqui vou eu novamente, perdão pelo triplo post, mas eu realmente preciso de ajuda nisso.

 

Consegui resolver a segunda questão legal.

O único problema é que ela ficou de certa forma gigantesca, e eu não consigo formular uma maneira de diminuí-la.

 

Eis como ficou:

 

algoritmo "Preço Total e Quantidade Produtos"
// Função :
// Autor :
// Data : 01/07/2010
// Seção de Declarações 
var Q : inteiro
    PR1, PR2, PR3, PR4, PR5, PR6, PR7, PR8, PR9, PR10, PR11, PR12, PR13, PR14, PR15, PR16, PR17, PR18, PR19, PR20, PR21, PR22, PR23 : real
    PR24, PR25, PR26, PR27, PR28, PR29, PR30, PR31, PR32, PR33, PR34, PR35, PR36, PR37, PR38, PR39, PR40, PR41, PR42, PR43, PR44, PR45 : real
    precototal : real
inicio
// Seção de Comandos
Escreva ("Digite o preço e a quantidade de cada item.")
leia (PR1)
leia (Q)
PR1 <- PR1 * Q
leia (PR2)
leia (Q)
PR2 <- PR2 * Q
leia (PR3)
leia (Q)
PR3 <- PR3 * Q
leia (PR4)
leia (Q)
PR4 <- PR4 * Q
leia (PR5)
leia (Q)
PR5 <- PR5 * Q
leia (PR6)
leia (Q)
PR6 <- PR6 * Q
leia (PR7)
leia (Q)
PR7 <- PR7 * Q
leia (PR8)
leia (Q)
PR8 <- PR8 * Q
leia (PR9)
leia (Q)
PR9 <- PR9 * Q
leia (PR10)
leia (Q)
PR10 <- PR10 * Q
// 10 variáveis
leia (PR11)
leia (Q)
PR11 <- PR11 * Q
leia (PR12)
leia (Q)
PR12 <- PR12 * Q
leia (PR13)
leia (Q)
PR13 <- PR13 * Q
leia (PR14)
leia (Q)
PR14 <- PR14 * Q
leia (PR15)
leia (Q)
PR15 <- PR15 * Q
leia (PR16)
leia (Q)
PR16 <- PR16 * Q
leia (PR17)
leia (Q)
PR17 <- PR17 * Q
leia (PR18)
leia (Q)
PR18 <- PR18 * Q
leia (PR19)
leia (Q)
PR19 <- PR19 * Q
leia (PR20)
leia (Q)
PR20 <- PR20 * Q
// 20 variáveis
leia (PR21)
leia (Q)
PR21 <- PR21 * Q
leia (PR22)
leia (Q)
PR22 <- PR22 * Q
leia (PR23)
leia (Q)
PR23 <- PR23 * Q
leia (PR24)
leia (Q)
PR24 <- PR24 * Q
leia (PR25)
leia (Q)
PR25 <- PR25 * Q
leia (PR26)
leia (Q)
PR26 <- PR26 * Q
leia (PR27)
leia (Q)
PR27 <- PR27 * Q
leia (PR28)
leia (Q)
PR28 <- PR28 * Q
leia (PR29)
leia (Q)
PR29 <- PR29 * Q
leia (PR30)
leia (Q)
PR30 <- PR30 * Q
// 30 variáveis
leia (PR31)
leia (Q)
PR31 <- PR31 * Q
leia (PR32)
leia (Q)
PR32 <- PR32 * Q
leia (PR33)
leia (Q)
PR33 <- PR33 * Q
leia (PR34)
leia (Q)
PR34 <- PR34 * Q
leia (PR35)
leia (Q)
PR35 <- PR35 * Q
leia (PR36)
leia (Q)
PR36 <- PR36 * Q
leia (PR37)
leia (Q)
PR37 <- PR37 * Q
leia (PR38)
leia (Q)
PR38 <- PR38 * Q
leia (PR39)
leia (Q)
PR39 <- PR39 * Q
leia (PR40)
leia (Q)
PR40 <- PR40 * Q
// 40 variáveis
leia (PR41)
leia (Q)
PR41 <- PR41 * Q
leia (PR42)
leia (Q)
PR42 <- PR42 * Q
leia (PR43)
leia (Q)
PR43 <- PR43 * Q
leia (PR44)
leia (Q)
PR44 <- PR44 * Q
leia (PR45)
leia (Q)
PR45 <- PR45 * Q
// aqui entra o preço total
precototal <- PR1 + PR2 + PR3 + PR4 + PR5 + PR6 + PR7 + PR8 + PR9 + PR10 + PR11 + PR12 + PR13 + PR14 + PR15 + PR16 + PR17 + PR18 + PR19 + PR20 + PR21 + PR22 + PR23
precototal <- preçototal + PR24 + PR25 + PR26 + PR27 + PR28 + PR29 + PR30 + PR32 + PR32 + PR33 + PR34 + PR35 + PR36 + PR37 + PR38 + PR39 + PR40 + PR41 + PR42 + PR43 + PR44 + PR45
Escreva ("O total gasto pela empresa foi de:", "R$:", precototal)
fimalgoritmo

Share this post


Link to post
Share on other sites

Te aconselho a lê sobre vetores. Como o exercício 2 é bem pequeno, vou fazer utilizando vetor:

 

algoritmo "semnome"
// Função :
// Autor :  Rodrigo
// Data : 03/07/2010
// Seção de Declarações 
var
preco:vetor[1..45] de real
i,b:inteiro
total:real
inicio
// Seção de Comandos 
para i de 1 ate 45 passo 1 faca
escreval ("Entre com o preço número:",i)
leia (preco[i])
fimpara
para b de 1 ate 45 passo 1 faca
total <- total + preco[b]
fimpara
escreval ("TOTAL GASTO: ",total)
fimalgoritmo

O código fica bem mais legível e rápido de se fazer.

Share this post


Link to post
Share on other sites

esse é para somar o peso do caminhão mas com vetor

ele fica bem menor

algoritmo "Somar peso"
// Função :
// Autor :  JhOnE RoSsInI
// Data : 05/07/2010
// Seção de Declarações
var
Q_caixa:vetor[1..25] de real
cont:inteiro
total,peso:real
inicio
// Seção de Comandos
para cont de 1 ate 25 passo 1 faca
escreva("Informe o peso da caixa nº ",cont," : ")
leia (Q_caixa[cont])
total <- total + Q_caixa[cont]
fimpara
escreval ("Peso Total : ",total)
fimalgoritmo
Edited by quitZAUMMM
Inclusão da tag [code]

Share this post


Link to post
Share on other sites

"Sabe-se que esse caminhão carrega 25 caixas, com pesos diferentes." - Trecho da primeira questão.

Temos que criar uma variável para cada uma das 25 caixas diferentes?

 

Bem, consegui responder, e percebi que esses exercícios são daqueles que fazem agente se acostumar com as operações, fazendo-nos repetí-las várias vezes.

 

O resultado foi este, e rodou perfeitamente.

 

algoritmo "Peso Caminhão"
// este algoritmo é uma tarefa
// ele calculará o peso total de um caminhão
var pesototal, p1, p2, p3, p4, p5, p6, p7, p8, p9, p10, p11, p12, p13, p14, p15, p16, p17, p18, p19, p20, p21, p22, p23, p24, p25 : real
inicio
escreva ("Digite o peso de cada uma das 25 caixas em quilos (KG)")
leia (p1)
leia (p2)
leia (p3)
leia (p4)
leia (p5)
leia (p6)
leia (p7)
leia (p8)
leia (p9)
leia (p10)
leia (p11)
leia (p12)
leia (p13)
leia (p14)
leia (p15)
leia (p16)
leia (p17)
leia (p18)
leia (p19)
leia (p20)
leia (p21)
leia (p22)
leia (p23)
leia (p24)
leia (p25)
pesototal <- p1 + p2 + p3 + p4 + p5 + p6 + p7 + p8 + p9 + p10 + p11 + p12 + p13 + p14 + p15 + p16 + p17 + p18 + p19 + p20 + p21 + p22 + p23 + p24 + p25

escreva ("O peso total da carga é de", pesototal, " Kg.")
fimalgoritmo
Há mais alguma coisa em que eu possa melhorar?

 

Ok, aqui vou eu novamente, perdão pelo triplo post, mas eu realmente preciso de ajuda nisso.

 

Consegui resolver a segunda questão legal.

O único problema é que ela ficou de certa forma gigantesca, e eu não consigo formular uma maneira de diminuí-la.

 

Eis como ficou:

 

algoritmo "Preço Total e Quantidade Produtos"
// Função :
// Autor :
// Data : 01/07/2010
// Seção de Declarações 
var Q : inteiro
    PR1, PR2, PR3, PR4, PR5, PR6, PR7, PR8, PR9, PR10, PR11, PR12, PR13, PR14, PR15, PR16, PR17, PR18, PR19, PR20, PR21, PR22, PR23 : real
    PR24, PR25, PR26, PR27, PR28, PR29, PR30, PR31, PR32, PR33, PR34, PR35, PR36, PR37, PR38, PR39, PR40, PR41, PR42, PR43, PR44, PR45 : real
    precototal : real
inicio
// Seção de Comandos
Escreva ("Digite o preço e a quantidade de cada item.")
leia (PR1)
leia (Q)
PR1 <- PR1 * Q
leia (PR2)
leia (Q)
PR2 <- PR2 * Q
leia (PR3)
leia (Q)
PR3 <- PR3 * Q
leia (PR4)
leia (Q)
PR4 <- PR4 * Q
leia (PR5)
leia (Q)
PR5 <- PR5 * Q
leia (PR6)
leia (Q)
PR6 <- PR6 * Q
leia (PR7)
leia (Q)
PR7 <- PR7 * Q
leia (PR8)
leia (Q)
PR8 <- PR8 * Q
leia (PR9)
leia (Q)
PR9 <- PR9 * Q
leia (PR10)
leia (Q)
PR10 <- PR10 * Q
// 10 variáveis
leia (PR11)
leia (Q)
PR11 <- PR11 * Q
leia (PR12)
leia (Q)
PR12 <- PR12 * Q
leia (PR13)
leia (Q)
PR13 <- PR13 * Q
leia (PR14)
leia (Q)
PR14 <- PR14 * Q
leia (PR15)
leia (Q)
PR15 <- PR15 * Q
leia (PR16)
leia (Q)
PR16 <- PR16 * Q
leia (PR17)
leia (Q)
PR17 <- PR17 * Q
leia (PR18)
leia (Q)
PR18 <- PR18 * Q
leia (PR19)
leia (Q)
PR19 <- PR19 * Q
leia (PR20)
leia (Q)
PR20 <- PR20 * Q
// 20 variáveis
leia (PR21)
leia (Q)
PR21 <- PR21 * Q
leia (PR22)
leia (Q)
PR22 <- PR22 * Q
leia (PR23)
leia (Q)
PR23 <- PR23 * Q
leia (PR24)
leia (Q)
PR24 <- PR24 * Q
leia (PR25)
leia (Q)
PR25 <- PR25 * Q
leia (PR26)
leia (Q)
PR26 <- PR26 * Q
leia (PR27)
leia (Q)
PR27 <- PR27 * Q
leia (PR28)
leia (Q)
PR28 <- PR28 * Q
leia (PR29)
leia (Q)
PR29 <- PR29 * Q
leia (PR30)
leia (Q)
PR30 <- PR30 * Q
// 30 variáveis
leia (PR31)
leia (Q)
PR31 <- PR31 * Q
leia (PR32)
leia (Q)
PR32 <- PR32 * Q
leia (PR33)
leia (Q)
PR33 <- PR33 * Q
leia (PR34)
leia (Q)
PR34 <- PR34 * Q
leia (PR35)
leia (Q)
PR35 <- PR35 * Q
leia (PR36)
leia (Q)
PR36 <- PR36 * Q
leia (PR37)
leia (Q)
PR37 <- PR37 * Q
leia (PR38)
leia (Q)
PR38 <- PR38 * Q
leia (PR39)
leia (Q)
PR39 <- PR39 * Q
leia (PR40)
leia (Q)
PR40 <- PR40 * Q
// 40 variáveis
leia (PR41)
leia (Q)
PR41 <- PR41 * Q
leia (PR42)
leia (Q)
PR42 <- PR42 * Q
leia (PR43)
leia (Q)
PR43 <- PR43 * Q
leia (PR44)
leia (Q)
PR44 <- PR44 * Q
leia (PR45)
leia (Q)
PR45 <- PR45 * Q
// aqui entra o preço total
precototal <- PR1 + PR2 + PR3 + PR4 + PR5 + PR6 + PR7 + PR8 + PR9 + PR10 + PR11 + PR12 + PR13 + PR14 + PR15 + PR16 + PR17 + PR18 + PR19 + PR20 + PR21 + PR22 + PR23
precototal <- preçototal + PR24 + PR25 + PR26 + PR27 + PR28 + PR29 + PR30 + PR32 + PR32 + PR33 + PR34 + PR35 + PR36 + PR37 + PR38 + PR39 + PR40 + PR41 + PR42 + PR43 + PR44 + PR45
Escreva ("O total gasto pela empresa foi de:", "R$:", precototal)
fimalgoritmo

Esse algoritmo também estaria certo assim?

algoritmo "PESOS"
var
PESO,A,SOMA:INTEIRO
inicio
A := 1
REPITA
ESCREVAL("DIGITE O PESO", A)
LEIA(PESO)
A := A + 1
SOMA <- SOMA + PESO
ESCREVAL("PESO INDIVIDUAL",PESO)
ESCREVAL("SOMA DOS PESOS", SOMA)
ESCREVAL("---------------------------------------------------------------------")
ATE A = 26
fimalgoritmo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.