Jump to content
cefet

[Resolvido] visuALG

Recommended Posts

BEM PRIMEIRAMENTE É UM PRAZER FAZER PARTE DESTE FÓRUM,E QUERO PARABENIZAR OS DONOS E MEMBROS DO MESMO PELO ÓTIMO TRABALHO E AJUDA REALIZADOS AQUI.

 

Bom a minha dúvida é sobre um algoritimo que tenho que realizar no visuALG e espero que vcs possam me ajudar.A sua sintaxe é a seguinte:

 

Faça um programa que lê 4 valores I,A,B e C onde I é um número inteiro e positivo e A,B e C são quaisquer valores reais.O programa deve escrever os valores lidos e:

*se I=1,escrever os três valores A,B e C em ordem crescente;

*se I=2,escrever os três valores A,B e C em ordem decrescente;

*se I=3,escrever os três valores A,B e C de forma que o maior valor fique entre os outros dois;

*se I não for um dos três valores acima,dar uma mensagem indicando isto.

Edited by Mário Monteiro
Retirada a palavra "AJUDA" do Titulo ou Descrição

Share this post


Link to post
Share on other sites

Qual a dúvida? você somente postou o enunciado do seu dever e ninguém aqui irá fazer pra você.

bem manoi esse é o problema eu não sei nem por onde comessar todas as vezes que eu tento fazer "I" adquirir os três valores sempre da errado

 

Qual a dúvida? você somente postou o enunciado do seu dever e ninguém aqui irá fazer pra você.

bem mano esse é o problema eu não sei nem por onde comessar todas as vezes que eu tento fazer "I" adquirir os três valores sempre da errado

Não é questão de fazer só me ajudem pelo menos a colocar os números em ordem decrescente

Share this post


Link to post
Share on other sites

Bem muito obrigado demorei quase um dia mais consegui resolver as 2 primeiras partes dele.

E a minha dúvida é "*se I=3,escrever os três valores A,B e C de forma que o maior valor fique entre os outros dois;"

Como devo fazer essa etapa ou pelo menos me deem uma dica.só falta essa parte.Não custa nada :joia:

 

enquanto aguardo alguem de bom grado responder.

vou tentando fazer aqui.

só da uma ideia ai galera :lol:

Share this post


Link to post
Share on other sites

Como você faria isso com papel e caneta?

 

Vamos lá. queremos exibir o valor maior no meio, certo?

 

você deve ter criado 3 variáveis: A,B E C; Então crie mais uma chamada Maior,Primeiro e Terceiro!

 

Então vamos lá:

 

SE (A > B) ou (A > C) ENTAO
Primeiro = B 
Maior = A
Terceiro = C

FIMSE

SE (B > A) ou (B > C) ENTAO

Primeiro = A 
Maior = B
Terceiro = C

FIMSE

SE (C > A) ou (C > B) ENTAO
 Primeiro = A 
Maior = C
Terceiro = B

FIMSE

 

E na hora de exibir você fará:

 

Escreval(Primeiro,Maior,Terceiro)

 

 

Enfim eu fiz esse algoritmo somente com base na terceira parte do seu problema. Você deverá adaptar essa lógica ao seu algoritmo atual e se enquadrando ao seu problema!

 

Poste o seu código atual para que possamos analisar e passar a você alguma possível melhoria ou correção.

 

Abcx,

 

LCS

Share this post


Link to post
Share on other sites

BEM EU ATÉ CONSEGUI TERMINAR TESTEI OS VALORES SÓ NÃO SEI SE ESTÁ TUDO CERTO :clap:

ENTÃO SE ALGUEM POD DAR UMA OLHADA E VER SE HÁ ALGUM ERRO SERIA DE MUITO BOM GRADO ;)

MAIS MESMO ASSIM QUERO AGRADECER A AJUDA,E TAMBEM QUERO PEDIR DESCULPAS SE PASSEI A IMPRESSÃO DE UM "VAGABUNDO"

QUERENDO QUE VCS FIZESSEM MEU EXERCÍCIO,FOI PQ FOI A MINHA PRIMEIRA VEZ E EU NÃO SABIA COMO FUNCIONAVA DIREITO

:joia:

 


algoritmo "desafio q sacrificio"
// Função :algoritimo cheio de função ai q o Amaro pediu pra fazer do livro
// Autor :  "Moisés"
// Data : 08/05/2011
// Seção de Declarações 
var
i : inteiro
a,b,c : real
inicio
// Seção de Comandos
escreval ("algoritimo para ler 4 valores")
escreval ("voce pode apenas colocar 3 valores válidos numericos : 1,2 e 3")
escreval ("digite um número")
se (i = 1) entao
escreval ("digite um numero")
leia (a)
escreval ("digite o segundo numero")
leia (B)
escreval ("digite o terceiro numero")
leia (c)
se (a > B) e (b > c) entao
escreval ("essa é a ordem crescente dos numeros citados : ",c,b,a)
fimse
fimse
se (a > c) e (c > B) entao
escreval ("essa é a ordem crescente dos numeros citados : ",b,c,a)
fimse
se (b > a ) e (a > c)  entao
escreval ("essa é a ordem crescente dos numeros citados : ",c,a,B)
fimse
se (b > c) e (c > a) entao
escreval ("essa é a ordem crescente dos numeros citados : ",a,c,B)
fimse
se (c > a) e (a > B) entao
escreval ("essa é a ordem crescente dos numeros citados : ",b,a,c)
fimse
se (c > B) e (b > a) entao
escreval ("essa é a ordem crescente dos numeros citados : ",a,b,c)
fimse
se (i = 2) entao
escreval ("digite um numero")
leia (a)
escreval ("digite o segundo numero")
leia (B)
escreval ("digite o terceiro numero")
leia (c)
fimse
se (a > B) e (b > c) entao
escreval ("Essa é a ordem Decrescente dos números citados : ",a,b,c)
fimse
se (a > c) e (c > B) entao
escreval ("Essa é a ordem Decrescente dos números citados : ",a,c,B)
fimse
se (b > a ) e (a > c)  entao
escreval ("essa é a ordem Decrescente dos números citados : ",b,a,c)
fimse
se (b > c) e (c > a) entao
escreval ("Essa é a ordem Decrescente dos números citados : ",b,c,a)
fimse
se (c > a) e (a > B) entao
escreval ("Essa é a ordem Decrescente dos números citados : ",c,a,B)
fimse
se (c > B) e (b > a) entao
escreval ("Essa é a ordem Decrescente dos números citados : ",c,b,a)
fimse
se (i = 3) entao
escreval ("Digite o primeiro número")
leia (a)
escreval ("Digite o segundo número")
leia (B)
escreval ("Digite o terceiro número")
leia (c)
fimse
se (a > B) e (b > c) entao
escreval ("Ordem em que o maior número citado fica no meio dos outros valores: ",b,a,c)
fimse
se (a > c) e (c > B) entao
escreval ("Ordem em que o maior número citado fica no meio dos outros valores: ",c,a,B)
fimse
se (b > a ) e (a > c)  entao
escreval ("Ordem em que o maior número fica no meio dos outros valores: ",a,b,c)
fimse
se (b > c) e (c > a) entao
escreval ("Ordem em que o maior número fica no meio dos outros valores: ",c,b,a)
fimse
se (c > a) e (a > B) entao
escreval ("Ordem em que o maior número fica no meio dos outros valores: ",a,c,B)
fimse
se (c > B) e (b > a) entao
escreval ("Ordem em que o maior número fica no meio dos outros valores: ",b,c,a)
fimse
se (i > 3) entao
escreval ("Este valor não é nenhuma das opções epecíficadas acima : são elas 1,2 e 3")
fimse
fimalgoritmo //BEM ESSA É A MELHOR PARTE DO ALGORITIMO PRINCIPALMENTE QUANDO ELE DA CERTO

Edited by quitZAUMMM
Inclusão da tag [code]

Share this post


Link to post
Share on other sites

Bom eu não é questão de pensarmos que a pessoa é ou não vagabundo. O fato é que por experiência própria estamos acostumados com usuários sangue-sugas. são aqueles que se registraram ontem, tem um ou dois posts tem seu problema resolvido e nunca mais voltam.nem pra dizer se funcionou ou não.

 

Ai tem uns caras que nem eu. que não suportam essa atitude e metem logo o pau,são usuários xiitas mesmo..kkk e tem outros que nem nosso moderador, o Quitzaum que são mais educados e levam na esportiva.. kk

 

Por isso pedimos aos novos integrantes dessa maravilhosa ferramenta de conhecimento que é o imasters que postem alguma coisinha, somente para mostrar que estão se esforçando neh, pois todo esforço gera um resultado, não importa se correto ou incorreto, mas pelo menos com esse resultado temos como auxiliar a pessoa de uma melhor forma.

 

 

 

Vamos ao seu tópico.

 

Aparentemente esta tudo certo, mas para ter certeza somente testando mesmo, para isso peço que bote o seu código dentro da tag code, assim não aparecem os malditos smilys no meio do código...

 

E também, por favor, não escreva em caixa alta(Caps look ligdo) porque é bem ruim ler assim.

 

Abcx,

 

LCS

Share this post


Link to post
Share on other sites

Evite postar em caixa alta, isso poderá te gerar punições.

 

[]s

Share this post


Link to post
Share on other sites

...

 

Evite postar em caixa alta, isso poderá te gerar punições.

 

[]s

Sim,sim foi mal :joia:

E quanto ao fato de ir embora,e nunca mais voltar,da qui eu não saio da qui ninguém me tira rssrs :P

Share this post


Link to post
Share on other sites

Moisés, você é mt sangue-suga mesmo! kkk

Quero ver o Amaro põe uma dessas na prova, aí ninguem vai saber fazer.. pq TODOS, sem excessão, copiaram da net ou de algumas pessoas que fizeram, NÉ. kk

 

Mas nessa questão aí, que eu também fiz desse jeito e é bem cansativa, por sinal, você esqueceu de ler o valor de i.

 

Coloque assim:

Escreval("Operações:")

Escreval("I=1 -> Ordem crescente, I=2 -> Ordem decrescente, I=3 -> Maior número no meio")

Escreva("Entre com a operação I: ")

leia(i)

se i<1 ou i>3 entao

escreva("Operação Inválida!")

senao...

Aí você faz o resto dos comandos! rs

 

Abraços

André Vidal 2TEL

Share this post


Link to post
Share on other sites

Sei que já foi resolvido (acho que sim) mas estou começando a programar e tive certa dificuldade nesse algoritmo. Por isso resolvi compartilhar a resolução dele ao meu modo apenas para registro aos próximos que caírem nessa página por causa do mesmo algoritmo.

 

 

algoritmo "EXE_08"
// Função : Deixar um programador iniciante louco.
// Autor : Bruno Bitencourt Luiz
// Data : 09/05/2013
// Seção de Declarações
var
a,b,c,n1,n2,n3: real
i: inteiro
inicio
escreva ("Digite o valor de A: ")
leia (a)
escreva ("Digite o valor de B: ")
leia (b)
escreva ("Digite o valor de C: ")
leia ©
escreva ("Digite o valor de I: ")
leia (i)
se (a>b) e (a>c) entao
n1<- (a)
se b>c entao
n2<- b
n3<- c
senao
n2<- c
n3<- b
fimse
fimse
se (b>a) e (b>c) entao
n1<- (b)
se (a>c) entao
n2<- a
n3<- c
senao
n2<- c
n3<- a
fimse
fimse
se (c>b) e (c>a) entao
n1<- ©
se (a>b) entao
n2<- a
n3<- b
senao
n2<- b
n3<- a
fimse
fimse
se (i=1) entao
escreva (n3, n2, n1)
senao
se (i=2) entao
escreva (n1, n2, n3)
fimse
fimse
se (i=3) entao
escreva (n2, n1, n3)
fimse
fimalgoritmo

Share this post


Link to post
Share on other sites

Booa Tarde

Consegui resolver de uma um pouco diferente
Se puderem conferir pra ver se também é valido ficarei grato :)

algoritmo "Ordem de Valores"
var
   I: Inteiro
   A, B, C: Real

inicio
      Escreva ("Digite o Valor de I: ")
      Leia (I)
      Escreval
      Escreva ("Digite o Valor de A: ")
      Leia (A)
      Escreval
      Escreva ("Digite o Valor de B: ")
      Leia (B)
      Escreval
      Escreva ("Digite o valor de C: ")
      Leia (C)
      Escreval

//Para Ordem Crescente

      Se (I=1)entao
         se (A<B) e (A<C) e (B<C) entao
            escreval (A, B, C)
         Senao
              Se (A<C) e (A<B) e (C<B) entao
                 escreval (A, C, B)
              Senao
                   Se (B<A) e (B<C) e (A<C) entao
                      escreval (B, A, C)
                   Senao
                        Se (B<C) e (B<A) e (C<A) entao
                           escreval (B, C, A)
                        Senao
                             Se (C<A) e (C<B) e (A<B) entao
                                escreval (C, A, B)
                             Senao
                                  Se (C<B) e (C<A) e (B<A) entao
                                     Escreval (C, B, A)
                                  FimSe
                             FimSe
                        FimSe
                   FimSe
              FimSe
         
         FimSe
      
      FimSe

//Para Ordem Decrescente

       Se (I=2)entao
         se (A>B) e (A>C) e (B>C) entao
            escreval (A, B, C)
         Senao
              Se (A>C) e (A>B) e (C>B) entao
                 escreval (A, C, B)
              Senao
                   Se (B>A) e (B>C) e (A>C) entao
                      escreval (B, A, C)
                   Senao
                        Se (B>C) e (B>A) e (C>A) entao
                           escreval (B, C, A)
                        Senao
                             Se (C>A) e (C>B) e (A>B) entao
                                escreval (C, A, B)
                             Senao
                                  Se (C>B) e (C>A) e (B>A) entao
                                     Escreval (C, B, A)
                                  FimSe
                             FimSe
                        FimSe
                   FimSe
              FimSe

         FimSe

      FimSe
      
// Ordem com o Maior no Meio

   Se (I=3)entao
         se (A<B) e (A<C) e (B<C) entao
            escreval (A, C, B)
         Senao
              Se (A<C) e (A<B) e (C<B) entao
                 escreval (A, B, C)
              Senao
                   Se (B<A) e (B<C) e (A<C) entao
                      escreval (B, C, A)
                   Senao
                        Se (B<C) e (B<A) e (C<A) entao
                           escreval (B, A, C)
                        Senao
                             Se (C<A) e (C<B) e (A<B) entao
                                escreval (C, B, A)
                             Senao
                                  Se (C<B) e (C<A) e (B<A) entao
                                     Escreval (C, A, B)
                                  FimSe
                             FimSe
                        FimSe
                   FimSe
              FimSe

         FimSe

      FimSe
      Se (I<>1) e (I<>2) e (I<>3) entao
         Escreva ("I deve ser um valor igual a 1, 2 ou 3")
      FimSe
fimalgoritmo

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.