Jump to content
Svinnicius

[VISUALG] Erro para encerrar a execução do algoritmo

Recommended Posts

Ao sair de um procedimento e entrar em outro, ta apresentando erro quando tento finalizar o programa.

 

Var
// Seção de Declarações das variáveis 
nome: vetor [1..3]  de caractere
telef: vetor [1..3]  de caractere
ema: vetor [1..3]  de caractere
codigo,codigo_contato,codigo_contato_cheio, menu_apagar,opc, opc1: inteiro
cont, menu_mostrar,op: inteiro
procedimento principal()

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
repita
escreval ("")
escreval ("=== AGENDA TELEFÔNICA ===")
escreval ("")
escreval ("1. Inserir novo contato")
escreval ("2. Apagar contato")
escreval ("3. Mostrar todos os contatos")
escreval ("4. Sair")
escreva ("Digite opcao: ")
leia (codigo)
limpatela
ate (codigo=1) ou (codigo=2) ou (codigo=3) ou (codigo=4)
escolha (codigo)

caso 1
   contato()
caso 2
   apagar()
caso 3
   mostrar()
caso 4
   interrompa
fimescolha
fimprocedimento
//---------------------- NOVO CONTATO ----------------------
procedimento contato()
inicio
para cont de 1 ate 3 faca
limpatela
escreval("== INSERIR NOVO CONTATO ==")
      escreva ("Nome: ")
      leia (nome[cont])
      escreva ("Telefone: ")
      leia (telef[cont])
      escreva ("E-mail: ")
      leia (ema[cont])
      escreval("")
      escreval("Usuario cadrastrado com sucesso")
      repita
      escreval("")
      escreval("1.Insira novo contato")
      escreval("2.Voltar ao menu")
      escreval("")
      escreva("Digite opção: ")
      leia(codigo_contato)
escolha (codigo_contato)
caso 1
escreva("")
caso 2
   interrompa
   limpatela
   principal()
outrocaso
escreval("")
escreval("Opção invalida")
escreval("")
escreval("Pressione ENTER para voltar")
leia(op)
limpatela
fimescolha
ate codigo_contato = 1
fimpara
limpatela
          escreval("")
          escreval("Lista de contato cheia")
          repita
          escreval("")
          escreval("1.Voltar ao menu")
          escreval("2.Sair")
          escreval("")
          escreval("Digite opção")
          leia(codigo_contato_cheio)
    escolha (codigo_contato_cheio)
          caso 1
          limpatela
          principal()
          caso 2
          interrompa
          outrocaso
escreval("")
escreval("Opção invalida")
escreval("")
escreval("Pressione ENTER para voltar")
leia(op)
limpatela
fimescolha
ate codigo_contato_cheio = 1
fimprocedimento


//------------------------ Apagar contato------------------------------------
procedimento apagar()
inicio
limpatela
escreval("== APAGAR CONTATO ==")
Escreval("")
escreva ("Qual contato você quer apagar? ")
Escreval("")
para cont de 1 ate 3 faca
Escreval(cont,". ",nome[cont])
fimpara
Escreval("")
Escreva("Digite opção:")
Leia(opc)
se opc >0 entao
   se opc <4 entao
nome[opc]<-""
telef[opc]<-""
ema[opc]<-""
Escreval("")
Escreval("Contato Apagado com sucesso")
repita
escreval("")
escreval("1.Apagar outro contato")
escreval("2.Voltar ao menu")
escreval("3.Sair")
escreva("Digite opção:")
leia(menu_apagar)
Escolha(menu_apagar)
caso 1
limpatela
apagar()
caso 2
limpatela
principal()
caso3
interrompa

outrocaso
escreval("")
escreval("Opção invalida")
escreval("")
escreval("Pressione ENTER para voltar")
leia(op)
senao
apagar()
fimse
fimse
fimse
fimescolha
ate menu_apagar = 3
fimprocedimento

//-------------------------- Mostrar todos os contatos ---------------------
procedimento mostrar()
inicio
limpatela
escreval("== LISTA DE CONTATOS ==")
Escreval("")
para cont de 1 ate 3 faca
Escreval(cont,". ",nome[cont])
fimpara
Escreval("")
Escreva("Digite opção:")
Leia(opc1)
se opc1 >0 entao
   se opc1 <4 entao
limpatela
Escreval("Nome: ",nome[opc1])
Escreval("Telefone: ",telef[opc1])
Escreval("E-mail: ",ema[opc1])
repita
escreval("")
escreval("1.Mostrar outro contato")
escreval("2.Voltar ao menu")
escreval("")
escreva("Digite opção:")
Leia(menu_mostrar)
Escolha(menu_mostrar)
caso 1
limpatela
mostrar()
caso 2
limpatela
principal()
outrocaso
escreval("")
escreval("Opção invalida")
escreval("")
escreval("Pressione ENTER para voltar")
leia(op)
senao
mostrar()
fimse
fimse
fimescolha
limpatela
ate menu_mostrar = 1
fimprocedimento
inicio
// Seção de Comandos
  principal()

Fimalgoritmo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Lucaahenr
      Boa tarde pessoal!

      Tenho que fazer um programa em C# que realize o calculo de uma equação de 2° Grau, porem é necessário realizar algumas verificações utilizando IF,  Else e estou tendo dificuldade em realizar estas verificações, gostaria de saber se está correto o que eu fiz ou se tem algum outro modo, segue questão em anexo.

      Muito Obrigado!

      using System; namespace equacaoSegundoGrau { class equacacao { static void Main(string[] args) { double a, b, c, delta; Console.WriteLine("Informe o coeficiente A"); a = double.Parse(Console.ReadLine()); Console.WriteLine("Informe o coeficiente B"); b = double.Parse(Console.ReadLine()); Console.WriteLine("Informe o coeficiente C"); c = double.Parse(Console.ReadLine()); // mesma coisa que a de baixo delta = (b * b) - 4 * a * c; delta = Math.Pow(b, c) - 4 * a * c; if ((a == 0) && (b == 0) && (c != 0)) { Console.WriteLine("Coeficientes informados incorretamente."); } else if ((a == 0) && (b != 0)) { Console.WriteLine("Essa é uma equação de primeiro grau e deverá ser informado o valor da raiz real da equação."); } else if (delta < 0) { Console.WriteLine("Esta equação não possui raízes reais"); } else if (delta == 0) { Console.WriteLine("Esta equação possui duas raízes reais iguais e informar o valor das raízes da equação." + delta); } else if (delta > 0) { Console.WriteLine("Esta equação possui duas raízes reais diferentes."); Console.WriteLine("O valor desta equação é " + delta); } } } }
       
    • By Motta
      Empresa disponibiliza algoritmo do Google em português gratuitamente
    • By Motta
      Novo algoritmo afina capacidade de previsão em sistemas caóticos
    • By Motta
      Toshiba afirma ter criado algoritmo mais rápido que supercomputadores
       
      Notícia sem a fonte original , não achei nada no site da Toshiba,
    • By soaresgusta
      Boa tarde, exercício pede a seguinte questão:

      Faça um programa que leia um valor x qualquer e calcule:
      Y = ( x+1)+(x+2)+(x+3)+(x+4)+(x+5)+...(x+100).

      Eu não estou conseguindo criar uma função Y na linguagem que some de 1 a 100.

      #include <stdio.h>
      #include <stdlib.h>

      int main ()
      {
      int Y=0, x, i=1;

      for (i=1;i<=100;i++);
      {
      Y= (x+i);
      printf("Digite um numero inteiro qualquer: \n");
      scanf ("%d", x);

      printf("Y = %d \n", Y);
      i++;

      }
      return (0);
      }

      Pela lógica, i varia de 1 a 100, mas quando eu executo o programa ele não soma. Alguém pode me ajudar?
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.