Jump to content
Sign in to follow this  
carlozz

Dificuldade com variável

Recommended Posts

Estou no começo de um curso de Ti e meu professor passou um exercício em visualg estou com dificuldades apenas para fazer o item b ) da lista de coisas que o programa deve fazer.

 

O Exercicio foi o seguinte:

 

wt9lat.jpg

 

Meu programa está funcionando rendondinho só não consegui pensar em nada para o item b ) por isso decidi pedir ajuda a vocês que tem muito mais experiência no assunto.

algoritmo "Exercicio 1"

var
   S, med_anterior, media, maiorS, Perc : real

   cont : inteiro
inicio
      maiorS:=0
      med_anterior:=0
      media:=0
      repita
      escreva ("Digite o valor do salário:")
      leia (S)
      se s<>0 entao
      cont:=cont+1
      med_anterior:=med_anterior+S
      fimse
      se (S<=1.000) entao
      S:=S+(S*2/10)
      fimse
      se (S>1.000) e (S<=2.000) entao
      S:=S+(S/10)
      fimse
      se (S>2.000) entao
      S:=S+(S/20)
      fimse
      se S>maiorS entao
      maiorS:=S
      fimse
      media:=media+S
      ate S=0
      perc:=media/med_anterior-1.0
      escreval ("A folha sálarial da empresa antes do reajuste era igual a R$ ", med_anterior)
      escreval ("A folha sálarial da empresa após os reajustes é igual a R$ ", media)
      escreval ("O percentual de aumento sobre a folha salarial foi de :", perc*100:2:2,"%")
      escreval ("O maior salário é R$ ", maiorS)
      escreval ("A média sálarial antes dos reajuste era igual a R$ ", med_anterior/cont)
      escreval ("A média sálarial após o reajusta é igual a R$ ", media/cont)
fimalgoritmo

Share this post


Link to post
Share on other sites

Eu não entendi muito bem o que os blocos de 18 à 26 estão fazendo, mas acredito que estejam calculando o novo salário. Primeiro, se o objetivo daquelas formulas sejam calcular a porcentagem, está sendo feito errado:

Você digitou:

se (S>1.000) e (S<=2.000) entao
      S:=S+(S/10)
      fimse

Mas na verdade é diferente. Veja abaixo a formula na matemática e no algoritmo para fazer os cálculos:

 

Matemática: percentual = 5 / 100 (Que resulta em: 0,05)
Algorítimo: percentual <- (porcentagem / 100)

Agora, uma formula básica de formula para calcular o salário atual:

Matemática: percentual do salário = salário atual * porcentagem calculada
Algorítimo: percentualsalario <- (salarioatual * percentual)

E, para calcular o novo salário já aplicado o aumento:

Matemática: salário novo = salário atual + percentagem do salário calculada
Algorítimo: salarionovo <- (salarioatual + salariopercentual)

Ou seja, se o funcionário tem um salário de 1.000,00 reais, e receberá um aumento de 20%, logo 20% de 1.000,00 reais é 200,00 reais, então será aumentado 200,00 reais, e o novo salário será de 1.200,00 reais.

 

Então, você terá que tirar os blocos de código que estão "calculando o salário" e aplicar essas formulas. Veja abaixo a resolução correta do bloco de 18 à 20.

Antes:

se (S<=1.000) entao
      S:=S+(S*2/10)
      fimse

Depois:

Se s <= 1.000 entao
        sn <- s*20/100
        sn <- ns+s

Observações: A variável "sn" deve ser criada (ou com outra denominação) para que possa armazenar a quantidade que deverá ser somada ao salário. Eu continuei mantendo a variável "s" como a que carrega o salário "velho". O 20 que está sendo dividido por 100, corresponde a quantidade em porcentagem que será adicionado, como consta na formula.

 

É isso aí, agora basta você aplicar em tudo como eu já havia dito anteriormente e alterar as informações dependendo do valor do salário. Espero ter ajudado, preparei uma reposta bem elaborada para que você consiga entender. Abraços e bons estudos.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Marcones Borges
      Olá, bom dia, estou tendo dificuldade em uma filtragem, quando passo o parâmetro para o select em forma de variável ele não exibe resultados.
       
      Segue o código:

              $usuario='gerente';         function montaSelect()         {         $sql = "SELECT * FROM membros WHERE user='".$usuario."' ";                 $query = mysql_query( $sql );                 if( mysql_num_rows( $query ) > 0 )                 {                         while( $dados = mysql_fetch_assoc( $query ) )                         {                                 $opt .= '<option value="'.$dados['nome'].'">'.$dados['nome'].'</option>';                         }                 }                 else                         $opt = '<option value="0">Nenhum Membro cadastrado</option>';                 return $opt;         }


      Quando substituo a variável pelo nome usuário gerente, ele lista normal, mais na variável não da certo. já tentei user='{$usuario}'  , user='$usuario' , user=$usuario}, nenhuma forma funciona...

      Alguém pode me ajudar..
       
    • By Andréia Bürck
      Gostaria de saber se há como fazer o seguinte, em JAVA ou qualquer outra linguagem: personalizar um áudio. Ou seja, tenho um áudio, e em lugares chaves desse áudio, depois dele pronto, um programa inserir nesses pontos-chave, por exemplo, nomes. Eu falo o nome, e o programa insere nos pontos pré-determinados.
    • By flipmartinz13
      Alguém pode me ajudar nessa questão de C++? não estou conseguindo construir o algorítmo corretamente.

      5.92)    Faça um algoritmo que leia a matrícula, nome, sexo e três notas dos alunos de uma escola e obtenha os seguintes resultados:
      a) A matrícula da aluna que obteve a maior média.
      b) A matrícula do aluno que obteve a menor média.
      c) O percentual de mulheres na turma.
      d) Quantos alunos foram aprovados, independente do sexo.
      e) O percentual de alunas aprovadas.
      Obs.: o flag é uma matrícula igual a 0 (zero).
    • By g.dmatos
      Preciso desenvolver um algoritmo no Visualg, da função y=3x+8, onde, a partir da informação de um valor para a variável independente x, o sistema automaticamente informe o valor da variável dependente y.
       
      porém quando vou executar da erro no código:
      var x, y: real inicio escreval("Digite o valor do coeficiente x") leia(x) Escreval ("O valor da conta é igual a:" + y) Leia (y) y=(3.x)+8 fimdoalgoritmo  
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.