Jump to content
  • -1
CRIS20

VISUALG: Faça um algoritmo que cadastre 5 bois com a seguinte informação:

Question

Criar um algoritmo que cadastre 5 bois com as informações seguintes:

ID

MATRICULA NO SISTEMA

REGRA: ANO

VIGENTE+valoraleatorio

(exemplo: 2017208)

PESO DO BOI

RAÇA DO BOI

NOME DO DONO/FAZENDA

 

Após o cadastro faça o algoritmo analisar e informar

O BOI MAIS GORDO

O BOI MAIS MAGRO

*se houver dois no mesmo peso mostrar os dois*

MÉDIA DOS PESOS DO BOIS CADASTRADOS

 

Alguém pode me ajudar como se faz????

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
44 minutos atrás, itlpps disse:

O que você já fez?

var

nome_dono,raca,situacao: caracter
peso,media: real
ID,N,: inteiro
NUM:inteiro

inicio
// Seção de Comandos

escreva("Digite a Quantidade de Bois que deseja Cadastrar: ")
leia(N)

para ID de 1 ate N faca


 NUM  <-  RandI(100)


   escreva("Raça do Boi: ")
   leia(raca)
   escreva("Nome do Propietario: ")
   leia(nome_dono)
   escreva("peso do Boi: ")
   leia(peso)
   
   escreval("ID |Matricula | raca do boi | propietario |     peso |")
   escreval(ID,"      ",NUM,"     ",raca,"         ",nome_dono,"      ",peso)
   escreval("-----------------------------------------")

            fimpara

fimalgoritmo
 

Share this post


Link to post
Share on other sites
  • 0

Certo.

 

Para calcular a média, é a soma de todos os pesos dividido pelo número de bois.

   - Crie uma variável pesoTotal iniciada com valor 0, e quando o cara digitar o peso, vá somando nela;

pesoTotal = pesoTotal + peso 

Depois é só dividir...

 

Achar o mais pesado e o mais leve

  - Inicie boigordo com 0 e boimagro com 9999999  quando for digitado o peso, verifique se ele é mais pesado ou mais leve.

if(peso > boigordo)
	boigordo = peso
if(peso < boimagro)
  	boimagro = peso

 

Share this post


Link to post
Share on other sites
  • -1
22 horas atrás, itlpps disse:

O que você já fez?

ID,peso_boi,boigordo,boimagro: inteiro
matricula,media,totalpeso: real
raca_boi,dono,fazenda: caracter

inicio
// Seção de Comandos 

escreval("                           BEM-VINDO AS FAZENDINHAS!!                           ")
escreval
escreval


para ID de 1 ate 5 faca

escreva("Raça do Boi: ")
leia(raca_boi)
escreva("Nome do Dono do Boi: ")
leia(dono)
escreva("Nome da fazendo que o Boi pertence: ")
leia(fazenda)
escreva("Peso do Boi: ")
leia(peso_boi)

matricula<-


escreval("ID | Matricula | Peso do Boi | Raça do Boi | Dono do Boi | Fazendo do Boi |")
escreval(ID,"      ",matricula,"        ",peso_boi,"             ",raca_boi,"             ",dono,"            ",fazenda)
escreval("---------------------------------------------------------------------------")

fimpara


media<- ()/5
escreval("Média dos pesos: ",media)

escreval("Boi mais gordo: ",boigordo)

escreval("Boi mais magro: ",boimagro)


fimalgoritmo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Andréia Bürck
      Gostaria de saber se há como fazer o seguinte, em JAVA ou qualquer outra linguagem: personalizar um áudio. Ou seja, tenho um áudio, e em lugares chaves desse áudio, depois dele pronto, um programa inserir nesses pontos-chave, por exemplo, nomes. Eu falo o nome, e o programa insere nos pontos pré-determinados.
    • By flipmartinz13
      Alguém pode me ajudar nessa questão de C++? não estou conseguindo construir o algorítmo corretamente.

      5.92)    Faça um algoritmo que leia a matrícula, nome, sexo e três notas dos alunos de uma escola e obtenha os seguintes resultados:
      a) A matrícula da aluna que obteve a maior média.
      b) A matrícula do aluno que obteve a menor média.
      c) O percentual de mulheres na turma.
      d) Quantos alunos foram aprovados, independente do sexo.
      e) O percentual de alunas aprovadas.
      Obs.: o flag é uma matrícula igual a 0 (zero).
    • By g.dmatos
      Preciso desenvolver um algoritmo no Visualg, da função y=3x+8, onde, a partir da informação de um valor para a variável independente x, o sistema automaticamente informe o valor da variável dependente y.
       
      porém quando vou executar da erro no código:
      var x, y: real inicio escreval("Digite o valor do coeficiente x") leia(x) Escreval ("O valor da conta é igual a:" + y) Leia (y) y=(3.x)+8 fimdoalgoritmo  
    • By TEC2587
      Quando eu excuto o algoritmo, a primeira condição comporta-se bem, mas apartir da segunda aparece o erro:
       
      Esperava-se encontrar ENTAO na linha  "se((med=<8.9) e (med>=8))entao"
      Esperava-se encontrar ENTAO na linha  "escreval("Seu rendimento foi muito bom"
       
      Algoritmo "semnome"
       
       
      Var
         med: real
      Inicio
         escreval("-------------------")
         escreval(" RENDIMENTO ESCOLAR")
         escreval("--------------------")
         escreval("Qual é a sua média: ")
         leia(med)
         se ((med=10) ou (med>=9))entao
            escreval ("Seu rendimento foi excelente")
         senao
            se ((med=<8.9) e (med>=8))entao
               escreval("Seu rendimento foi muito bom")
            senao
               se ((med= 7.9) e (med>=7))entao
                  escreval("Seu rendimento foi bom")
               senao
                  se ((med=6.9) e (med>=6))entao
                     escreval("Seu rendimento foi regular")
                  senao
                     se ((med=5.9) e (med>=5))entao
                        escreval("Seu rendimento foi insuficiente")
                     senao
                        escreval("Seu rendimento foi ruim")
                     fimse
                  fimse
               fimse
            fimse
         fimse
      Fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.