Jump to content
  • -1
CRIS20

VISUALG: Faça um algoritmo que cadastre 5 bois com a seguinte informação:

Question

Criar um algoritmo que cadastre 5 bois com as informações seguintes:

ID

MATRICULA NO SISTEMA

REGRA: ANO

VIGENTE+valoraleatorio

(exemplo: 2017208)

PESO DO BOI

RAÇA DO BOI

NOME DO DONO/FAZENDA

 

Após o cadastro faça o algoritmo analisar e informar

O BOI MAIS GORDO

O BOI MAIS MAGRO

*se houver dois no mesmo peso mostrar os dois*

MÉDIA DOS PESOS DO BOIS CADASTRADOS

 

Alguém pode me ajudar como se faz????

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
44 minutos atrás, itlpps disse:

O que você já fez?

var

nome_dono,raca,situacao: caracter
peso,media: real
ID,N,: inteiro
NUM:inteiro

inicio
// Seção de Comandos

escreva("Digite a Quantidade de Bois que deseja Cadastrar: ")
leia(N)

para ID de 1 ate N faca


 NUM  <-  RandI(100)


   escreva("Raça do Boi: ")
   leia(raca)
   escreva("Nome do Propietario: ")
   leia(nome_dono)
   escreva("peso do Boi: ")
   leia(peso)
   
   escreval("ID |Matricula | raca do boi | propietario |     peso |")
   escreval(ID,"      ",NUM,"     ",raca,"         ",nome_dono,"      ",peso)
   escreval("-----------------------------------------")

            fimpara

fimalgoritmo
 

Share this post


Link to post
Share on other sites
  • 0

Certo.

 

Para calcular a média, é a soma de todos os pesos dividido pelo número de bois.

   - Crie uma variável pesoTotal iniciada com valor 0, e quando o cara digitar o peso, vá somando nela;

pesoTotal = pesoTotal + peso 

Depois é só dividir...

 

Achar o mais pesado e o mais leve

  - Inicie boigordo com 0 e boimagro com 9999999  quando for digitado o peso, verifique se ele é mais pesado ou mais leve.

if(peso > boigordo)
	boigordo = peso
if(peso < boimagro)
  	boimagro = peso

 

Share this post


Link to post
Share on other sites
  • -1
22 horas atrás, itlpps disse:

O que você já fez?

ID,peso_boi,boigordo,boimagro: inteiro
matricula,media,totalpeso: real
raca_boi,dono,fazenda: caracter

inicio
// Seção de Comandos 

escreval("                           BEM-VINDO AS FAZENDINHAS!!                           ")
escreval
escreval


para ID de 1 ate 5 faca

escreva("Raça do Boi: ")
leia(raca_boi)
escreva("Nome do Dono do Boi: ")
leia(dono)
escreva("Nome da fazendo que o Boi pertence: ")
leia(fazenda)
escreva("Peso do Boi: ")
leia(peso_boi)

matricula<-


escreval("ID | Matricula | Peso do Boi | Raça do Boi | Dono do Boi | Fazendo do Boi |")
escreval(ID,"      ",matricula,"        ",peso_boi,"             ",raca_boi,"             ",dono,"            ",fazenda)
escreval("---------------------------------------------------------------------------")

fimpara


media<- ()/5
escreval("Média dos pesos: ",media)

escreval("Boi mais gordo: ",boigordo)

escreval("Boi mais magro: ",boimagro)


fimalgoritmo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By luadiego
      algoritmo "ESCOLHA DE NUMEROS PARES OU IMPARES UNSANDO A ESTRUTURA DE CONDICIONAMENTO ESCOLHA COM A ESTRUTURA DE REPETIÇÃO PARA"
      var
         V,MUN,VALORES:INTEIRO
      inicio
          ESCREVA("DIGITE O NUMERO DESEJADO :")
          LEIA(V)
          escreval("----------------------------")
          escreval("  [1] PARA PAR              ")
          escreval("  [2} para IMPAR            ")
          ESCREVAL("----------------------------")
          ESCREVAL("ESCOLHA UM DOS VALORES")
          LEIA(VALORES)
          ESCOLHA(VALORES)
          caso 1
          PARA MUN <- 0 ATE V FACA
           SE (MUN MOD 2 =0) ENTAO
            escreval(MUN)
           FIMSE
          MUN <- MUN +1
          FIMPARA
           caso 2
         PARA MUN <- 0 ATE V FACA
           SE (MUN MOD 2 =1) ENTAO
            escreval(MUN)
           FIMSE
          MUN <- MUN +1
          FIMPARA
         FIMESCOLHA
      fimalgoritmo
    • By luizcmoficial
      escreval("CPF COMPLETO: ",vet[1],vet[2],vet[3]," .",vet[4],vet[5],vet[6]," .",vet[7],vet[8],vet[9]," -",digitoum,digitodois)

      Gostaria de deixar os números um do lado do outro, porém sem esse espaçamento.
      Os números sempre ficam todos meio separados, desta maneira: 3 2 1 . 1 4 3 . 1 2 2 - 5 9
      Não conheço nenhum comando que consiga fazer isso, ou nem sei se existe algum jeito. 
    • By Lauts
      programa
      {
          inclua biblioteca Matematica
          
          funcao inicio()
          {
              inteiro hom=0, mul=0, rsim=0, rnao=0, rhsim=0, rmsim=0, n, t=4
              real psim, pnao
              caracter sexo, resp
              (n == t)
          {
              leia ("Informe o Sexo: ", sexo)
              leia ("Gostou do produto (S/N): ", resp)
              se (sexo =='1')
              {
                  hom = hom + 1
                  se (resp == '1')
              {
                  rmnao = rmnao + 1
              }
              }
              senao
              {
                  se (sexo == '2')
              {
                  mul = mul + 1
                  se (resp == '2')
              {
                  rhsim = rhsim + 1    
              }    
              }
              }
                  se (resp == '1')
              {
                  rsim = rsim +1            
              }
                  senao
              {
                  se (resp == '2')
              {
                  rnao = rnao +1
              }
              }
          n = n  + 1
          }
              psim = 100 * (rmsim / t)
              pnao = 100 * (rhnao / t)
          }
              escreva ("Quantidade de pessoas que responderam sim: ", rsim)
              escreva ("Quantidade de pessoas que responderam não: ", rnao)
              escreva ("Porcentagem de mulheres que responderam sim: ", psim)
              escreva ("Porcentagem de homens que responderam não: ", pnao)
      }
    • By Flaviaac
      Boa tarde galera!
       
      Estou tendo um problema esquisito aqui.
      Sou iniciante e não faço a mínima ideia do que pode ser.
       
       
      Veja só, no campo dropdown abaixo coloquei no "value" o ID, mas ele salva no banco como tipo STRING e não INT.
      <?php $sql = "SELECT id, sigla FROM local ORDER BY sigla ASC"; $result = $conn->query($sql); ?> . . . <select name="local" class="form-control"> <option selected>Selecione...</option> <?php while($row = $result->fetch_assoc()){ echo "<option value=".$row['id'].">".$row['sigla']."</option>"; } ?> </select> . . . Dei um var_dump() pra saber o que apareceria e ele mostra como STRING.
      <pre> <?php $sql = "SELECT id, sigla FROM local ORDER BY sigla ASC"; $result = $conn->query($sql); $row = $result->fetch_assoc(); var_dump($row['id']); ?> </pre> Resultado:
      string(1) "5"  
       
      Esse é o Banco de dados:
      Coloquei a coluna ID como INT.
      -- phpMyAdmin SQL Dump -- version 4.8.3 -- https://www.phpmyadmin.net/ SET SQL_MODE = "NO_AUTO_VALUE_ON_ZERO"; SET AUTOCOMMIT = 0; START TRANSACTION; SET time_zone = "+00:00"; /*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */; /*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */; /*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */; /*!40101 SET NAMES utf8mb4 */; -- -- Banco de dados: `arq` -- -- -------------------------------------------------------- -- -- Estrutura para tabela `local` -- CREATE TABLE `local` ( `id` int(11) NOT NULL, `SIGLA` mediumtext NOT NULL, `LOCAL` mediumtext NOT NULL, `TELEFONE` mediumtext NOT NULL ) ENGINE=InnoDB DEFAULT CHARSET=utf8; -- -- Fazendo dump de dados para tabela `local` -- INSERT INTO `local` (`id`, `SIGLA`, `LOCAL`, `TELEFONE`) VALUES (1, 'AAC', 'AAC', '2222-2222'), (2, 'DSV', 'DSV', '1111-1111'), (3, 'SCA', 'SCA', '3333-3333'); -- -- Índices de tabelas apagadas -- -- -- Índices de tabela `local` -- ALTER TABLE `local` ADD PRIMARY KEY (`id`); -- -- AUTO_INCREMENT de tabelas apagadas -- -- -- AUTO_INCREMENT de tabela `local` -- ALTER TABLE `local` MODIFY `id` int(11) NOT NULL AUTO_INCREMENT, AUTO_INCREMENT=6; COMMIT; /*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */; /*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */; /*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */; Obrigada pessoal!
       
    • By luizrufino
      Boa tarde pessoal, estou com dificuldade para 
      desenvolver as linhas de códigos de um problema.
       
      Escreva um algoritmo em potrugol que leia o NOME do responsável e o número de filhos matriculados em uma escolinha de futebol. com mensalidade de $120,00, imprimir o valor que o responsável vai pagar, baseando-se na seguinte tabele de descontos
       
      filhos matriculados        Desconto
       1                                             10%
       2 a 3                                       15%
      acima de  3                             20
       
      Se alguém puder me ajudar, pode ser somente a estrutura básica.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.