Ir para conteúdo
Whillis

Como ver a média de um vetor!?

Recommended Posts

Var
vetorA: vetor [1..10] de inteiro
VetorB: vetor [1..10] de inteiro
i:inteiro
num:inteiro
media:real
result:real

Inicio
i<-1
Para i de 1 ate 10 faca
 Leia(num)
 vetorA [i]<-num
 i<-i+1
Fimpara

escreval("")
escreval("calculando o dobro...")
escreval("")

para i de 1 ate 10 faca
timer (50)
VetorB[i] <- VetorA[i] * 2
escreva(VetorB[i])
fimpara

para i de 1 ate 10 faca
media <- VetorB[i] + VetorB[i]
result <- media/10
fimpara

Fimalgoritmo

Eu estou com problemas nessa ultima estrutura para, pois queria fazer a média do VetorB, porém não sei como.

agradeço desde ja

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

  • Conteúdo Similar

    • Por anderx
      Prezados, boa tarde.
       
      Eu estou fazendo um programa em C que o usuário digite uma sequencia de caracteres e imprima somente valores numéricos e também mostrar os seus respectivos valores correspondentes a tabela ASC. Eu utilizei dois vetores , um para receber os caracteres e um outro para copiar apenas os valores numéricos, mas eu não estou conseguindo transferir somente os valor numéricos para o outro vetor. Alguém tem alguma dica de como posso transferir somete os números ? O código abaixo: 
       
      #include <stdio.h>
      #include <string.h>
      int main () {
      char str1[30] ={0};
       int str2[30];
      int i=0;
      scanf ("%s",str1);
      for(i=0; i<strlen(str1);i++) {
        str1*=1;
      str2=str1;

      printf("%c : : %d\n",str2,str2);
      }
          return 0;
      }
       
    • Por Marcelobpc
      Boa tarde pessoal,
      estou tendo muita dificuldade para criar um algoritmo que eu entre com um numero de 0 a 100 e ele me informe quantos números pares tem no intervalo do numero que digitei até 0 e caso o numero digitado for maior que 100 ele solicite que seja digitado o numero de 0 a 100 novamente.
    • Por GilvanBM46
      Rapaziada estou meio adoentado é preciso entregar uma tarefa simples amanha a noite, Preciso fazer um algorítimo em visualg que calcule o tempo gasto de saída de casa é chegada ao trabalho é mostre as horas gastas os minutos gastos é os segundos gastos.
       
      Consegui fazer ate a metade mais não estou conseguindo processar o resto.
      Quem poder da um tombo te agradeço muito. 
      Fiz uma parte 
       
      Var
      he,hs,me,ms,hora:inteiro
       
      Inicio
      escreva ("Digite a hora de entrada: ")
      leia (he)
      escreva ("Digite os minutos de entrada: ")
      leia (me)
      escreva("Digite a hora de saida: ")
      leia (hs)
      escreva ("Digite os minutos de saida: ")
      leia(ms)
      hora:= hs-he
      escreva("Passou", hora , ":horas")
      Fimalgoritmo
    • Por guiilhermej
      Galera, to com um impasse em umas questões passadas na faculdade, eu realmente gosto de resolver meus exercícios, pois só assim sei que irei aprender, mas acontece que to meio perdido nessas questões, alguem me da um help por favor.

       
      6. Escreva um algoritmo que peça um número n ao usuário, e que gere um novo n de acordo
      com a seguinte regra:
      • se n é par, n = n / 2
      • se n é impar, n = 3 * n + 1
      • imprime n
      • O programa deve parar quando x tiver o valor igual a 1. Por exemplo, para n = 13, a saída
      será:
      40 -> 20 -> 10 -> 5 -> 16 -> 8 -> 4 -> 2 -> 1

      7. Fazer um algoritmo que leia um número que servira para controlar os primeiros números
      ímpares. Deverá ser impressa a soma desses números. Suponha que o número informado será
      maior que zero, caso não seja, informar o erro.
      Informe um número: 5
      1 3 5 7 9
      A soma dos 5 valores impares é: 25

      8. Fazer um algoritmo que leia os limites inferior e superior de um intervalo e o número cujos
      múltiplos se deseja que sejam impressos no intervalo aberto. Suponha que os dados digitados
      são para um intervalo crescente. Exemplo:
      Valor inicial: 5
      Valor final: 15
      Divisor: 3
      6 9 12 15
       
      9. Fazer um algoritmo que leia a quantidade de números que se deseja digitar para que
      possa ser impresso o maior e o menor número digitado. Não suponha que todos os
      números lidos serão positivos. Exemplo:
      Quantos números deseja digitar?
      5
      Informe um numero:3
      Informe um numero:-2
      Informe um numero:5
      Informe um numero:6
      Informe um numero:19
      O maior numero informado foi: 19
      O menor numero informado foi: -2
    • Por alecram28
      Boa tarde. Tenho o seguinte exercício para fazer em Java:
      Escreva um algoritmo para jogo lotérico. O usuário deve informar sua aposta através de 5 números inteiros no intervalo de 1 a 100. No servidor, os números da aposta devem ser armazenados em um vetor. O vetor da aposta não pode conter números repetidos. O algoritmo deve realizar o sorteio, gerando 5 números aleatoriamente no intervalo de 1 a 100. Os números sorteados também devem ser armazenados em um vetor. O vetor do sorteio não pode conter números repetidos. Se o usuário acertar menos de 3 números, ele ganha 0% da premiação. Se o usuário acertar 3 números, ele ganha 50% da premiação. Se o usuário acertar 4 números, ele ganha 75% da premiação. Se o usuário acertar os 5 números, ele ganha 100% da premiação. Na interface, o algoritmo deve
      informar:
      a. O valor da premiação.
      b. O vetor da aposta.
      c. O vetor do sorteio.
      d. O valor do prêmio recebido pelo usuário.
       
      Gostaria de ajuda para como posso verificar os valores iguais entre os vetores (verificar se a pessoa acertou algum numero)
      Obrigado!
       
       
       
       
       
       
       
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.