Jump to content
  • 0
Felipe_2k19

Programação no Visualg em Portugol

Question

Fala galera tudo beleza?

Então meu professor passou um "problema" e falou para criar um programa no Visualg usando Portugol, só que eu estou com alguns problemas principalmente na fórmula, alguém pode me ajudar?

Pergunta: Dado o preço do ingresso e a idade o programa devera informar o preço do ingresso com os seguintes descontos de acordo com a idade:

IDADE

0-5-15%

6-20-5%

21-40- 2%

acima de 40 - 30%

 

Se puderem me ajudar agradeço.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
2 horas atrás, navegantenarede disse:

O que você fez até agora? Compartilha o seu progresso para facilitar a ajuda.

Var:

Ingresso, idade:inteiro

Início

Escreval("Digite sua idade")

Leia (idade)

Escreva("Digite o valor do ingresso")

Leia (preço)

Se idade<5  ?

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By luadiego
      algoritmo "ESCOLHA DE NUMEROS PARES OU IMPARES UNSANDO A ESTRUTURA DE CONDICIONAMENTO ESCOLHA COM A ESTRUTURA DE REPETIÇÃO PARA"
      var
         V,MUN,VALORES:INTEIRO
      inicio
          ESCREVA("DIGITE O NUMERO DESEJADO :")
          LEIA(V)
          escreval("----------------------------")
          escreval("  [1] PARA PAR              ")
          escreval("  [2} para IMPAR            ")
          ESCREVAL("----------------------------")
          ESCREVAL("ESCOLHA UM DOS VALORES")
          LEIA(VALORES)
          ESCOLHA(VALORES)
          caso 1
          PARA MUN <- 0 ATE V FACA
           SE (MUN MOD 2 =0) ENTAO
            escreval(MUN)
           FIMSE
          MUN <- MUN +1
          FIMPARA
           caso 2
         PARA MUN <- 0 ATE V FACA
           SE (MUN MOD 2 =1) ENTAO
            escreval(MUN)
           FIMSE
          MUN <- MUN +1
          FIMPARA
         FIMESCOLHA
      fimalgoritmo
    • By luizcmoficial
      escreval("CPF COMPLETO: ",vet[1],vet[2],vet[3]," .",vet[4],vet[5],vet[6]," .",vet[7],vet[8],vet[9]," -",digitoum,digitodois)

      Gostaria de deixar os números um do lado do outro, porém sem esse espaçamento.
      Os números sempre ficam todos meio separados, desta maneira: 3 2 1 . 1 4 3 . 1 2 2 - 5 9
      Não conheço nenhum comando que consiga fazer isso, ou nem sei se existe algum jeito. 
    • By gbilibio
      Bom dia, preciso realizar uma atividade em portugol, aonde é feito a leitura de um número, identificando se o mesmo é primo, caso não seja primo, deve ser feita a decomposição em fatores primos, o algoritmo para de rodar quando for informado um número negativo. porém como posso realizar um laço ou condicional para fazer a fatoração ? Ainda não encontrei a forma adequada, se puderem ajudar por favor
       
      Segue o meu código:
       
      programa
      {
          
          funcao inicio()
          {
              inteiro n = 0, cont = 0
              inteiro d = 1
              inteiro fat
              inteiro div = 0
              inteiro comp = 0
              
              escreva("Informando se o número é composto ou primo e sua decomposição \n")

              enquanto(n >= 0){
              escreva("Informe um número natural: ")
              leia(n)
              se(n == 1){
                  escreva("O número não é primo nem composto! \n")
              }
              se(n % d == 0){
              
                  d = 2                
              }
              
              se(n == 0){
                  escreva("O número não é primo nem composto! \n")
              }
              senao
                  se(n % d == 0 e n % n == 0 e n != 2){
                      escreva("O número " ,n, " é composto! ")
                  
                      comp = n                            
                                                                                  
              }senao
                  se(n % n == 0 e n > 0 e n != 0 e n != 1){
                      
                  escreva("O número " ,n, " é primo! \n")
                  
                  }
              
                  
                  
              }                    
                                  
          }    
      }

       
       
    • By Lauts
      programa
      {
          inclua biblioteca Matematica
          
          funcao inicio()
          {
              inteiro hom=0, mul=0, rsim=0, rnao=0, rhsim=0, rmsim=0, n, t=4
              real psim, pnao
              caracter sexo, resp
              (n == t)
          {
              leia ("Informe o Sexo: ", sexo)
              leia ("Gostou do produto (S/N): ", resp)
              se (sexo =='1')
              {
                  hom = hom + 1
                  se (resp == '1')
              {
                  rmnao = rmnao + 1
              }
              }
              senao
              {
                  se (sexo == '2')
              {
                  mul = mul + 1
                  se (resp == '2')
              {
                  rhsim = rhsim + 1    
              }    
              }
              }
                  se (resp == '1')
              {
                  rsim = rsim +1            
              }
                  senao
              {
                  se (resp == '2')
              {
                  rnao = rnao +1
              }
              }
          n = n  + 1
          }
              psim = 100 * (rmsim / t)
              pnao = 100 * (rhnao / t)
          }
              escreva ("Quantidade de pessoas que responderam sim: ", rsim)
              escreva ("Quantidade de pessoas que responderam não: ", rnao)
              escreva ("Porcentagem de mulheres que responderam sim: ", psim)
              escreva ("Porcentagem de homens que responderam não: ", pnao)
      }
    • By luizrufino
      Boa tarde pessoal, estou com dificuldade para 
      desenvolver as linhas de códigos de um problema.
       
      Escreva um algoritmo em potrugol que leia o NOME do responsável e o número de filhos matriculados em uma escolinha de futebol. com mensalidade de $120,00, imprimir o valor que o responsável vai pagar, baseando-se na seguinte tabele de descontos
       
      filhos matriculados        Desconto
       1                                             10%
       2 a 3                                       15%
      acima de  3                             20
       
      Se alguém puder me ajudar, pode ser somente a estrutura básica.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.