Jump to content
  • 0
4ly

Visualg, olá gostaria de saber onde está o erro no meu algoritmo

Question

O exercício propunha fazer duas funções uma para multiplicação e outra para criar uma fatorial, porém devem ser feitas usando apenas operações de soma e subtração

bom fiz uma função para multiplicar e esta funcionando porém estou tentando utiliza-la para fazer a fatorial e o resultado sempre da zero ;-; podem me ajudar 

 

 

algoritmo "semnome"
var
a,b:inteiro

funcao multi(a:inteiro;b:inteiro):real
var aux:real
inicio
se a=0 entao
   retorne 0
senao
   aux <- 0
   enquanto b>0 faca
      aux <- aux+a
      b <- b-1
   fimenquanto
   retorne aux
fimse
fimfuncao

funcao fatorial(a:inteiro):real
var fat,res:real
inicio
enquanto fat > 0 faca
   fat<-a
   fat <- fat - 1
   res <- multi(fat,a)
fimenquanto
retorne res
fimfuncao

inicio
leia(a)
escreval(fatorial(a))
fimalgoritmo

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By lucascastoria
      Procuro um profissional para desenvolver um sistema de compra em phyton.
      Interessados, favor me contatar pois explicarei melhor.
      Obrigado
    • By daniele_c
      O professor em sala de aula, solicitou o seguinte trabalho de algoritmos 1:
      Escreva um algoritmo que utilize a biblioteca Util e gere uma cartela de BINGO com números aleatórios. Por exemplo, na coluna B temos números de 1-15, já na coluna I temos números de 16-30, etc. conforme imagem. No fim o algoritmo deve imprimir a cartela de bingo.
      Eu consegui gerar a tabela normalmente, mas eu não faço ideia de como não fazer com que em cada coluna, os números não se repitam. 
      Meu andamento abaixo:
       
      programa
      {
          inclua biblioteca Util --> u
          
          funcao inicio()
          {
              inteiro matriz[5][5], coluna, linha
              const inteiro tamanho=5
              para(linha=0; linha<tamanho; linha++){
                  para(coluna=0; coluna<tamanho; coluna++){
                  se(coluna==0){
                      matriz[linha][coluna]=u.sorteia(1,15)
                  }
                  se(coluna==1){
                      matriz[linha][coluna]=u.sorteia(16,30)
                  }
                  se(coluna==2){
                      matriz[linha][coluna]=u.sorteia(31,45)
                  }
                  se(coluna==3){
                      matriz[linha][coluna]=u.sorteia(46,60)
                  }
                  se(coluna==tamanho-1){
                      matriz[linha][coluna]=u.sorteia(61,75)
                  }
                  se (coluna==tamanho-1){
                      escreva(matriz[linha][coluna])
                  }
                  senao {
                      escreva(matriz[linha][coluna], ",")
                  }
                  }
                  escreva("\n")
          }
          }
      }
       
      E seguindo as questões, na nº2, ele pede o seguinte: Após, gerada uma cartela e impressa (parte 1) Adicione no algoritmo um código que faça automaticamente o sorteio de números aleatórios de 1 a 75. Após cada número sorteado, verificar se a cartela gerada fez um bingo de linha ou de coluna. Em seguida, deve-se imprimir o Bingo!
       
      sei gerar os 75 números tbm, mas, não sei como fazer para que faça as comparações e verificar se ocorreu o bingo. 
       
      Gostaria de algumas ideias, pliss
       
    • By dimoreira
      Boa noite programadores, estou a procura de um profissional que desenvolva um site simples, que tem apenas que me mostrar os resultados em tempo real da pagina de resultados da bet 365. Mas especificamente do futebol virtual. Vou mandar em anexo uma foto pra ter como base.   O modelo mais simples possivel é somente para acompanhar os resultados em tempo real sem ter q esta acessando o site da bet.


    • By Andréia Bürck
      Gostaria de saber se há como fazer o seguinte, em JAVA ou qualquer outra linguagem: personalizar um áudio. Ou seja, tenho um áudio, e em lugares chaves desse áudio, depois dele pronto, um programa inserir nesses pontos-chave, por exemplo, nomes. Eu falo o nome, e o programa insere nos pontos pré-determinados.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.