Jump to content
  • -1
CRIS20

VISUALG: Faça um algoritmo que cadastre 5 bois com a seguinte informação:

Question

Criar um algoritmo que cadastre 5 bois com as informações seguintes:

ID

MATRICULA NO SISTEMA

REGRA: ANO

VIGENTE+valoraleatorio

(exemplo: 2017208)

PESO DO BOI

RAÇA DO BOI

NOME DO DONO/FAZENDA

 

Após o cadastro faça o algoritmo analisar e informar

O BOI MAIS GORDO

O BOI MAIS MAGRO

*se houver dois no mesmo peso mostrar os dois*

MÉDIA DOS PESOS DO BOIS CADASTRADOS

 

Alguém pode me ajudar como se faz????

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
44 minutos atrás, itlpps disse:

O que você já fez?

var

nome_dono,raca,situacao: caracter
peso,media: real
ID,N,: inteiro
NUM:inteiro

inicio
// Seção de Comandos

escreva("Digite a Quantidade de Bois que deseja Cadastrar: ")
leia(N)

para ID de 1 ate N faca


 NUM  <-  RandI(100)


   escreva("Raça do Boi: ")
   leia(raca)
   escreva("Nome do Propietario: ")
   leia(nome_dono)
   escreva("peso do Boi: ")
   leia(peso)
   
   escreval("ID |Matricula | raca do boi | propietario |     peso |")
   escreval(ID,"      ",NUM,"     ",raca,"         ",nome_dono,"      ",peso)
   escreval("-----------------------------------------")

            fimpara

fimalgoritmo
 

Share this post


Link to post
Share on other sites
  • 0

Certo.

 

Para calcular a média, é a soma de todos os pesos dividido pelo número de bois.

   - Crie uma variável pesoTotal iniciada com valor 0, e quando o cara digitar o peso, vá somando nela;

pesoTotal = pesoTotal + peso 

Depois é só dividir...

 

Achar o mais pesado e o mais leve

  - Inicie boigordo com 0 e boimagro com 9999999  quando for digitado o peso, verifique se ele é mais pesado ou mais leve.

if(peso > boigordo)
	boigordo = peso
if(peso < boimagro)
  	boimagro = peso

 

Share this post


Link to post
Share on other sites
  • -1
22 horas atrás, itlpps disse:

O que você já fez?

ID,peso_boi,boigordo,boimagro: inteiro
matricula,media,totalpeso: real
raca_boi,dono,fazenda: caracter

inicio
// Seção de Comandos 

escreval("                           BEM-VINDO AS FAZENDINHAS!!                           ")
escreval
escreval


para ID de 1 ate 5 faca

escreva("Raça do Boi: ")
leia(raca_boi)
escreva("Nome do Dono do Boi: ")
leia(dono)
escreva("Nome da fazendo que o Boi pertence: ")
leia(fazenda)
escreva("Peso do Boi: ")
leia(peso_boi)

matricula<-


escreval("ID | Matricula | Peso do Boi | Raça do Boi | Dono do Boi | Fazendo do Boi |")
escreval(ID,"      ",matricula,"        ",peso_boi,"             ",raca_boi,"             ",dono,"            ",fazenda)
escreval("---------------------------------------------------------------------------")

fimpara


media<- ()/5
escreval("Média dos pesos: ",media)

escreval("Boi mais gordo: ",boigordo)

escreval("Boi mais magro: ",boimagro)


fimalgoritmo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By joao.felipe
      Pessoal, boa noite,
       
      estou tentando fazer um checkbox colorir multiplas celulas de uma tabela. Ao selecionar o checkbox e clicar no onclick botao(filtrar) ou somente selecionando o checkbox, eu preciso colorir a celula de verde através de alguma propriedade. Ex: <td ID="A1" color"green" ></td> da  
       
      <!DOCTYPE html>
      <html>
      <body>
      <script>
        function obterMarcados() 
        {
          var numeros = 0;
          var listaMarcados = document.getElementsByName("checkbox1");
          
          if (listaMarcados.length > 0)
          {
            for (loop = 0; loop < listaMarcados.length; loop++) 
            {   
              let item = listaMarcados[loop];
              console.log(item.checked)
              if (item.type == "checkbox" && item.checked) 
              {
                numeros++;
                alert(item.value);
                alert(listaMarcados.length);
              }
            } 
            if (numeros == 0)
            {
              alert("Nenhum CheckBox foi Marcado");
            }
            
          }
          else
          {
            alert("Nao existe nenhum CheckBox com esse nome(name)");
          }  
        }
      </script>
       
      <form>
        <table width="" border="1" cellspacing="10" cellpadding="4">
       
      <tr align="center"> <td>--</td> <td> -- <br></td> <td>A</td> <td>B</td> <td>C</td> <td>D</td> <td>E</td> <td>F</td> <td>G</td> <td>H</td> <td>I</td> <td>J</td> <td>K</td> <td>L</td> <td>M</td> <td>N</td> <td>O</td> <td>P</td> <td>Q</td> <td>R</td> <td>S</td> <td>T</td> <td>U</td> <td>V</td> <td>X</td> </tr>
       
      <tr align="center"> <td>--</td> <td> <input type="button" name="btn" value="Verificar Marcados" onclick="obterMarcados()">                                         <br></td> <td COLSPAN="12" align="center">RAIZES 8</td> <td COLSPAN="4" align="center">RAIZES 7</td> <td COLSPAN="2" align="center">RAIZES 6</td> <td td COLSPAN="3" align="center">VEREDAS 2</td> <td>CARANDÁ</td> <td>PALMAS</td>  </tr>  
       
      <tr align="center"> <td>--</td> <td> --                                                                                                                            <br></td> <td>1</td> <td>2</td> <td>3</td> <td>4</td> <td>5</td> <td>6</td> <td>7</td> <td>8</td> <td>9</td> <td>10</td> <td>11</td> <td>12</td> <td>1</td> <td>2</td> <td>3</td> <td>4</td> <td>1</td> <td>2</td> <td>1</td> <td>2</td> <td>3</td> <td>1</td> <td>1</td> </tr>  
       
        <tr align="center"> <td>01</td> <td align="left"> <input type="checkbox" id = "3DS Max"            name="checkbox1" value="3DS Max"           > 3DS Max            <br></td> <td bgcolor="green" id="A1">A1 </td> <td id="B1">B1</td> <td>C1</td> <td>D1</td> <td>E1</td> <td>F1</td> <td>G1</td> <td>H1</td> <td>I1</td> <td>J1</td> <td>K1</td> <td>L1</td> <td>M1</td> <td>N1</td> <td>O1</td> <td>P1</td> <td>Q1</td> <td>R1</td> <td>S1</td> <td>T1</td> <td>U1</td> <td>V1</td> <td>X1</td> </tr>  
       
        <tr align="center"> <td>02</td> <td align="left"> <input type="checkbox" id = "Adobe + Audacity"   name="checkbox1" value="Adobe + Audacity"  > Adobe + Audacity   <br></td> <td bgcolor="white" id="A2">A2 </td> <td>B2</td> <td>3</td> <td>4</td> <td>5</td> <td>6</td> <td>1</td> <td>2</td> <td>3</td> <td>4</td> <td>5</td> <td>6</td> <td>1</td> <td>2</td> <td>3</td> <td>4</td> <td>5</td> <td>6</td> <td>1</td> <td>2</td> <td>3</td> <td>4</td> <td>5</td> </tr>  
       
        <tr align="center"> <td>03</td> <td align="left"> <input type="checkbox" id = "Anaconda Python 5"  name="checkbox1" value="Anaconda Python 5" > Anaconda Python 5  <br></td> <td bgcolor="white" id="A3">A3 </td> <td>B3</td> <td>3</td> <td>4</td> <td>5</td> <td>6</td> <td>1</td> <td>2</td> <td>3</td> <td>4</td> <td>5</td> <td>6</td> <td>1</td> <td>2</td> <td>3</td> <td>4</td> <td>5</td> <td>6</td> <td>1</td> <td>2</td> <td>3</td> <td>4</td> <td>5</td> </tr>  
       
            </table>
          </form>
        </body>
      </html>
    • By marizita
      algoritmo "semnome"
      // Função :
      // Autor :
      // Data : 17/06/2019
      // Seção de Declarações 
      var
      i,j,aux:inteiro
      Matriz_A: vetor [1..3,1..3] de inteiro
      Matriz_B: vetor [1..3,1..3] de inteiro
      matriz_C: vetor [1..3,1..3] de inteiro

      inicio
      // Seção de Comandos 
      // VETOR A
      para i de 1 ate 3 faca
           para j de 1 ate 3 faca
            escreval ("matriz A: coluna:",i,"linha:",j)
            escreval ("informe o valor da posicao: [",i,"]: [",j,"]:")
            leia(matriz_A[i,j])
         fimpara
        fimpara
        limpatela

      //VETOR B
      para i de 1 ate 3 faca
         para j de 1 ate 3 faca
            escreval ("matriz B: coluna:",i,"linha:",j)
            escreval ("informe o valor da posicao: [",i,"]: [",j,"]:")
            leia(matriz_B[i,j])
         fimpara
         fimpara
        limpatela
        
        //VETOR C
        Para i de 1 ate 3 faca
              Para j de 1 ate 3 faca
                  matriz_C [i,j] <- ( matriz_A[i,1] * matriz_B[1,j] ) + (matriz_A[i,2] * matriz_B[2,j] ) + (matriz_A[i,3] * matriz_B[3,j] )
                  Escreval("matriz_C ",i , " x ",j , " : ", matriz_C [i,j])
              Fimpara
          Fimpara
    • By danielzamignani
      Bom dia galera!
      Então, eu fiz esse algoritimo para resolver um exercicio (Faça um Programa que leia três números e mostre-os em ordem decrescente). Ele esta funcional, tudo certinho(eu acho). O que eu realmente queria saber é se existe uma forma de eu simplificar ele utilizando apenas as estruturas condicionais ou se dessa forma que eu fiz já é o mais simples possivel ?
      Valeu pela atenção pessoal!!!
      Segue o codigo criado no visualg
       
      //Faça um Programa que leia três números e mostre-os em ordem decrescente algoritmo "ex009" var n1, n2, n3: inteiro inicio escreva("Primeiro numero: ") leia(n1) escreva("Segundo numero: ") leia(n2) escreva("Terceiro numero: ") leia(n3) se (n1<n2) e (n2<n3) entao escreva(n3,n2,n1) senao se (n1<n3) e (n3<n2) entao escreva(n2,n3,n1) senao se (n2<n1) e (n1<n3) entao escreva(n3,n1,n2) senao se (n2<n3) e (n3<n1) entao escreva(n1,n3,n2) senao se (n3<n1) e (n1<n2) entao escreva(n2,n1,n3) senao se (n3<n2) e (n2<n1) entao escreva(n1,n2,n3) fimse fimse fimse fimse fimse fimse fimalgoritmo  
    • By Motta
      A outra cara do algoritmo
    • By 4ly
      O exercício propunha fazer duas funções uma para multiplicação e outra para criar uma fatorial, porém devem ser feitas usando apenas operações de soma e subtração
      bom fiz uma função para multiplicar e esta funcionando porém estou tentando utiliza-la para fazer a fatorial e o resultado sempre da zero ;-; podem me ajudar 
       
       
      algoritmo "semnome" var a,b:inteiro funcao multi(a:inteiro;b:inteiro):real var aux:real inicio se a=0 entao retorne 0 senao aux <- 0 enquanto b>0 faca aux <- aux+a b <- b-1 fimenquanto retorne aux fimse fimfuncao funcao fatorial(a:inteiro):real var fat,res:real inicio enquanto fat > 0 faca fat<-a fat <- fat - 1 res <- multi(fat,a) fimenquanto retorne res fimfuncao inicio leia(a) escreval(fatorial(a)) fimalgoritmo  
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.