Ir para conteúdo
Dorian Neto

Deploy no Codeship com Deployer+Pem file (AWS)

Recommended Posts

Galera,

 

To tentando incluir o deploy automatizado no meu processo de build através do Codeship. Tenho um processo de deploy já configurado e rodando localmente perfeito com o Deployer, porém, ao passar essa responsabilidade pro Codeship, estou tendo alguns problemas na autenticação da chave PEM.

 

Alguém já passou por isso?

 

Desde já agradeço!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Dá um detalhe maior sobre o erro, poste algumas prints para podermos te ajudar melhor

Compartilhar este post


Link para o post
Compartilhar em outros sites

@KhaosDoctor obrigado pela resposta!

 

Segue a imagem do problema que estou tendo: 

Resolvi remover o pem file e autorizar o Codeship no meu servidor, mas mesmo assim esse erro continua :(

Compartilhar este post


Link para o post
Compartilhar em outros sites

Consegui resolver o problema com a dica desse link http://blog.idetailaid.co.uk/ssh-multiplex-control-sockets-not-connecting-error/

 

Vou fechar o tópico, porém, se alguém tiver tido o mesmo problema e quiser conversar sobre, reabre o tópico ou manda um direct ;)

 

Obrigado pela ajuda!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

  • Conteúdo Similar

    • Por JullySL
      Boa tarde!

      Tenho um projeto em asp net mvc 5 com banco de dado sql server 2012 hospedado no rds da Amazon acontece que:
      Quando rodo o projeto local através do localhost com a string de conexão conectada ao servidor rds sql server 2012 da aws o sistema funciona normalmente faz o login e senha td certinho, porém quando subo a aplicação para o servidor da amazon o sistema não funciona ele abre normalmente a tela para o usuário inserir o login e senha mas não apresenta nenhuma mensagem de erro.
       
      Alguém sabe me dizer se precisa fazer algum tipo de instalação ou configutação no servidor windows?[
       
      agradeço desde já
       
    • Por gustavomn
      Estou tentando fazer um deploy na nomer, com o hosting Plesk. Porém no momento de executar o bundle install, ocorre o seguinte erro:
       
      An error occurred while installing nio4r (2.3.1), and Bundler cannot continue.
      Make sure that `gem install nio4r -v '2.3.1'` succeeds before bundling.
      ERROR:rubymng:Command '['/opt/psa/admin/sbin/filemng', 'mangiarea', 'exec', '/var/www/vhosts/mangiarealimentos.com.br/httpdocs', '/bin/bash', '-l', '-c', 'bundle install --path vendor/bundle']' returned non-zero exit status 5.
       
      Alguém já passou por isso?
       
      Desde já, agradeço. 
    • Por JullySL
      Tinha um projeto em asp.net mvc4 hospedado na Amazon, funcionando, fiz a migração deste projeto para o mvc5, subi todas dll, porém quando executo o sistema no navegador está mostrando como pastas, não mostra a tela de login, quando volto o projeto em asp.net mvc4 funciona normalmente, acredito que não seja nenhum problema com o IIS, porém como não mostra erro não consigo encontrar o que tem de errado, alguém pode me ajudar por gentileza, estou a dias pesquisando na internet e não encontrei ainda uma solução, já reiniciei o pool de aplicação, já comparei os web.config e nada de funcionar, e o projeto continua funcionando local.

      Se alguém puder ajudar ficarei grata.

    • Por lhamatech
      A amazon aws disponibiliza o uso combinado da instância amazon ec2 + cpanel + whm, a minha dúvida é:
       
      Posso usar essa combinação para vender hospedagem e por para rodar diferentes domínios? Alguém faz isso? Quais vantagens e desvantagens eu teria?
    • Por JullySL
      Olá!

      Estou fazendo testes de hospedagem no ambiente da Amazon utilizando instancia EC2 de teste (gratuíta) Windows server 2012, meu site está no ar funcionando, já limpei cache já testei em outras máquinas e está funcionando, porém quando eu tento acesso o console apresenta erro, quando acesso o ambiente da amazon através do site, vou na opção EC2 instancia e está como se eu não tivessse nenhuma instancia ativa, já aconteceu isso com alguém? Alguém pode me ajudar por favor?
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.