Jump to content

Recommended Posts

algoritmo "ESCOLHA DE NUMEROS PARES OU IMPARES UNSANDO A ESTRUTURA DE CONDICIONAMENTO ESCOLHA COM A ESTRUTURA DE REPETIÇÃO PARA"
var
   V,MUN,VALORES:INTEIRO
inicio
    ESCREVA("DIGITE O NUMERO DESEJADO :")
    LEIA(V)
    escreval("----------------------------")
    escreval("  [1] PARA PAR              ")
    escreval("  [2} para IMPAR            ")
    ESCREVAL("----------------------------")
    ESCREVAL("ESCOLHA UM DOS VALORES")
    LEIA(VALORES)
    ESCOLHA(VALORES)
    caso 1
    PARA MUN <- 0 ATE V FACA
     SE (MUN MOD 2 =0) ENTAO
      escreval(MUN)
     FIMSE
    MUN <- MUN +1
    FIMPARA
     caso 2
   PARA MUN <- 0 ATE V FACA
     SE (MUN MOD 2 =1) ENTAO
      escreval(MUN)
     FIMSE
    MUN <- MUN +1
    FIMPARA
   FIMESCOLHA
fimalgoritmo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By xxceres
      Estou fazendo um algoritmo que solicita a posição (latitude e longitude) do usuário 1 e a posição do usuário 2. 
      Considerando a distância segura para o seu deslocamento, por exemplo, em 20 metros. Caso a distância segura 
      seja ultrapassada, dispare uma mensagem de alerta para o usuário.  


      Algoritmo "Calculo da Distancia"

       
      Var x1,x2,y1,y2, d: real Inicio escreval ("Digite no ponto A o valor de X1") leia (x1) escreval ("Digite no ponto A o valor de Y2") leia (y1) escreval ("Digite no ponto B o valor de X2") leia (x2) escreval ("Diite no ponto B o valor de Y2") leia (y2) d<- raizq(((x2-x1)^2)+((y2-y1)^2)) escreval("A distancia entre o ponto A e B no plano cartesiano é: ",d) Fimalgoritmo  
    • By Gabriel Buosi
      Faça um programa em PHP que o suário informe dois valor numéricos e o programa liste todo intervalo entre eles, por exemplo:
      Valores informados pelo usuário:
      1
      6
       
      Programa irá escrever:
      1
      2
      3
      4
      5
      6
       
      Você deverá usar Formulário, e repetição.
      Obrigado, preciso disso urgentemente.
    • By yasuo_mono_dedo
      VisualG
       
      Minha professora de lógica de programação passou alguns exercícios e preciso da ajuda de vocês
       
      O exercício que me acarretou dúvida extrema foi esse:
       
      Escreva um programa que leia um número qualquer e apresente-o somente
      se ele for menor que 100 ou entre 500 e 700
       
      O que me causou dúvida foi que eu ainda não aprendi a fazer isso :/
      Quem puder ajudar eu agradeceria <3
    • By luizcmoficial
      escreval("CPF COMPLETO: ",vet[1],vet[2],vet[3]," .",vet[4],vet[5],vet[6]," .",vet[7],vet[8],vet[9]," -",digitoum,digitodois)

      Gostaria de deixar os números um do lado do outro, porém sem esse espaçamento.
      Os números sempre ficam todos meio separados, desta maneira: 3 2 1 . 1 4 3 . 1 2 2 - 5 9
      Não conheço nenhum comando que consiga fazer isso, ou nem sei se existe algum jeito. 
    • By luizrufino
      Boa tarde pessoal, estou com dificuldade para 
      desenvolver as linhas de códigos de um problema.
       
      Escreva um algoritmo em potrugol que leia o NOME do responsável e o número de filhos matriculados em uma escolinha de futebol. com mensalidade de $120,00, imprimir o valor que o responsável vai pagar, baseando-se na seguinte tabele de descontos
       
      filhos matriculados        Desconto
       1                                             10%
       2 a 3                                       15%
      acima de  3                             20
       
      Se alguém puder me ajudar, pode ser somente a estrutura básica.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.