Jump to content
Patricia Carla

Algoritmo - Estrutura Enquanto

Recommended Posts

Estou tentando escrever um algoritmo que pede ao usuário inserir os números e no final exiba qual foi o número maior e o número menor.

Só que o número menor sempre é exibido 0.

algoritmo "SomadorNumerico"
// Função :
// Autor :
// Data : 12/04/2018
// Seção de Declarações
var
cont, N, S, maior, menor: Inteiro
inicio
cont <- 1
S <-0
Enquanto (cont <= 5) faca
   Escreva (" Digite o", cont, "o. valor: ")
   Leia (N)
   Se (N > maior) então
      maior <- N
   Senao
      Se (N < menor) então
         menor <- N
      FimSe
   FimSe
   S <- S + N
   cont <- cont + 1
FimEnquanto
EscrevaL ("----------------------------------------")
EscrevaL (" A soma de todos os valores é: ", S)
EscrevaL (" O maior valor digitado foi: ", maior)
EscrevaL (" O menor valor digitado foi: ", menor)
EscrevaL ("----------------------------------------")
fimalgoritmo

 

Alguém pode me ajudar?

 
  •  
  •  

Share this post


Link to post
Share on other sites

SEGUINTE. DEU PRA PERCEBER QUE VOCÊ ESTA ATRIBUINDO VALOR ZERO A SUA VARIALVEL S, ENTAO QUANDO você PEDE PRA IMPRIMIR ELE APARECE ZERO. TEM QUE ORGANIZAR MAIS O CÓDIGO E VER O QUE REALMENTE VOCÊ ESTA PRECISANDO, TEM VARIAVES QUE NAO ESTAÕA SENDO UTILIZADAS.

Share this post


Link to post
Share on other sites

algoritmo "THIAGOSILVA.DVL"
// Função : IMPRIMIR NUMEROS E MOSTRAR O MAIOR
// Autor :
// Data : 4/6/2018
// Seção de Declarações
var
VALOR1, VALOR2, VALOR3: INTEIRO
inicio
// Seção de Comandos
ESCREVAL("ESCREVA O PRIMEIRO NUMERO")
LEIA(VALOR1)

ESCREVAL("ESCREVA O SEGUNDO NUMERO")
LEIA(VALOR2)

ESCREVAL("ESCREVA O TERCEIRO NUMERO")
LEIA(VALOR3)

SE VALOR1 > VALOR2 ENTAO
   ESCREVAL(VALOR1, "MAIOR NUMERO")
FIMSE

SE VALOR1 > VALOR3 ENTAO
   ESCREVAL(VALOR1, "MAIOR NUMERO")
FIMSE

SENAO SE  VALOR2 > VALOR1 ENTAO
   ESCREVAL(VALOR2, "MAIOR NUMERO")
FIMSE

SENAO  VALOR2 > VALOR3 ENTAO
   ESCREVAL(VALOR2, "MAIOR NUMERO")
FIMSE

SENAO  VALOR3 > VALOR1 ENTAO
   ESCREVAL(VALOR3, "MAIOR NUMERO")
FIMSE

SENAO  VALOR3 > VALOR2 ENTAO
   ESCREVAL(VALOR3, "MAIOR NUMERO")
FIMSE

fimalgoritmo

 

SEGUE MAIS OU MENOS ESSA LÓGICA.  :tounge_wink:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Motta
      A outra cara do algoritmo
    • By 4ly
      O exercício propunha fazer duas funções uma para multiplicação e outra para criar uma fatorial, porém devem ser feitas usando apenas operações de soma e subtração
      bom fiz uma função para multiplicar e esta funcionando porém estou tentando utiliza-la para fazer a fatorial e o resultado sempre da zero ;-; podem me ajudar 
       
       
      algoritmo "semnome" var a,b:inteiro funcao multi(a:inteiro;b:inteiro):real var aux:real inicio se a=0 entao retorne 0 senao aux <- 0 enquanto b>0 faca aux <- aux+a b <- b-1 fimenquanto retorne aux fimse fimfuncao funcao fatorial(a:inteiro):real var fat,res:real inicio enquanto fat > 0 faca fat<-a fat <- fat - 1 res <- multi(fat,a) fimenquanto retorne res fimfuncao inicio leia(a) escreval(fatorial(a)) fimalgoritmo  
    • By Nasus
      Preciso fazer um programa de controle de comandas de um restaurante , envolvendo struct e arquivos, porém ñ sei por onde começar, alguém pode me ajudar?
       
      Estou fazendo da seguinte forma:
          struct produto{ int codigo_produto; char descrição[50]; double valor; }prod[4];   struct mesa{ int cod_mesa; char setor[30]; int codigo_garçom; }mes[3];   struct garçom{ int codigo_garçom; char nome[70]; }gar[;   struct consumo{ int cod_produto,cod_consumo; char data [10];     }
    • By Joao.2070
      Boa noite estou tento problemas para realizar o tópico  3 alguém poderia me ajudar ??
      Ser em algoritmo  
       

    • By Nelson_tempobono
      Alguém pode me orientar sobre como resolvo o algoritmo abaixo com estruturas de repetição
       
      Escrever um algoritmo que lê um número inteiro positivo e que escreve a soma de todos os números inteiros, desde 0 até o valor lido.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.