Ir para conteúdo
Patricia Carla

Algoritmo - Estrutura Enquanto

Recommended Posts

Estou tentando escrever um algoritmo que pede ao usuário inserir os números e no final exiba qual foi o número maior e o número menor.

Só que o número menor sempre é exibido 0.

algoritmo "SomadorNumerico"
// Função :
// Autor :
// Data : 12/04/2018
// Seção de Declarações
var
cont, N, S, maior, menor: Inteiro
inicio
cont <- 1
S <-0
Enquanto (cont <= 5) faca
   Escreva (" Digite o", cont, "o. valor: ")
   Leia (N)
   Se (N > maior) então
      maior <- N
   Senao
      Se (N < menor) então
         menor <- N
      FimSe
   FimSe
   S <- S + N
   cont <- cont + 1
FimEnquanto
EscrevaL ("----------------------------------------")
EscrevaL (" A soma de todos os valores é: ", S)
EscrevaL (" O maior valor digitado foi: ", maior)
EscrevaL (" O menor valor digitado foi: ", menor)
EscrevaL ("----------------------------------------")
fimalgoritmo

 

Alguém pode me ajudar?

 
  •  
  •  

Compartilhar este post


Link para o post
Compartilhar em outros sites

SEGUINTE. DEU PRA PERCEBER QUE VOCÊ ESTA ATRIBUINDO VALOR ZERO A SUA VARIALVEL S, ENTAO QUANDO você PEDE PRA IMPRIMIR ELE APARECE ZERO. TEM QUE ORGANIZAR MAIS O CÓDIGO E VER O QUE REALMENTE VOCÊ ESTA PRECISANDO, TEM VARIAVES QUE NAO ESTAÕA SENDO UTILIZADAS.

Compartilhar este post


Link para o post
Compartilhar em outros sites

algoritmo "THIAGOSILVA.DVL"
// Função : IMPRIMIR NUMEROS E MOSTRAR O MAIOR
// Autor :
// Data : 4/6/2018
// Seção de Declarações
var
VALOR1, VALOR2, VALOR3: INTEIRO
inicio
// Seção de Comandos
ESCREVAL("ESCREVA O PRIMEIRO NUMERO")
LEIA(VALOR1)

ESCREVAL("ESCREVA O SEGUNDO NUMERO")
LEIA(VALOR2)

ESCREVAL("ESCREVA O TERCEIRO NUMERO")
LEIA(VALOR3)

SE VALOR1 > VALOR2 ENTAO
   ESCREVAL(VALOR1, "MAIOR NUMERO")
FIMSE

SE VALOR1 > VALOR3 ENTAO
   ESCREVAL(VALOR1, "MAIOR NUMERO")
FIMSE

SENAO SE  VALOR2 > VALOR1 ENTAO
   ESCREVAL(VALOR2, "MAIOR NUMERO")
FIMSE

SENAO  VALOR2 > VALOR3 ENTAO
   ESCREVAL(VALOR2, "MAIOR NUMERO")
FIMSE

SENAO  VALOR3 > VALOR1 ENTAO
   ESCREVAL(VALOR3, "MAIOR NUMERO")
FIMSE

SENAO  VALOR3 > VALOR2 ENTAO
   ESCREVAL(VALOR3, "MAIOR NUMERO")
FIMSE

fimalgoritmo

 

SEGUE MAIS OU MENOS ESSA LÓGICA.  :tounge_wink:

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

  • Conteúdo Similar

    • Por lucas russo
      Boa noite ,pessoal não estou conseguindo resolver um exercício de algoritmo ,poderiam  me ajudar?
      Segue o exercício :
       
      Elabore um algoritmo que peça ao usuário que digite 1 numero maior que 500 retorne a soma dos fatoriais  de cada numero digitado compreendido  num inervá-lo de 2 números digitados .
    • Por Matheus.Borges
      como posso codficar um algoritmo que liste os números de 1 a 100 mas nos múltiplos de 3 substitua o número por Dia, nos múltiplos de 5 substitua por Mond e nos múltiplos de 3 e 5 substitua por DiaMond???
    • Por Gkings_88
      Boa noite!!
       
      Tenho um trabalho onde tenho que fazer o desenvolvimento de um algoritmo para uma bilheteria de um teatro e estou tendo uns problema com a consulta de assentos reservados, com a venda e o faturamento, por favor, poderiam me ajudar.
      Obs.: A variável de tipo e porque vou ter que inserir está parte para perguntar o tipo e para ter o preço diferente para cada tipo.
       
      Este é o código: 
       
      #include <stdio.h> #include <stdlib.h> int CAD[20][25]; int opcao,peca,t,m,g,sala; char data1[10]; char data2[10]; char data3[10]; char horario1[6]; char horario2[6]; char horario3[6]; char horario4[6]; char horario5[6]; char horario6[6]; char sala1[40]; char sala2[40]; char sala3[40]; int tipo; int inteiro=0; int meia=0; int gratis=0; int i; int j; void CadastrarPeca(){ printf("\nPeca 1: "); gets(sala1); printf("\nData: "); gets(data1); printf("\nHorario 1: "); gets(horario1); printf("\nHorario 2: "); gets(horario2); printf("\nPeca 2: "); gets(sala2); printf("\nData: "); gets(data2); printf("\nHorario 1: "); gets(horario3); printf("\nHorario 2: "); gets(horario4); printf("\nPeca 3: "); gets(sala3); printf("\nData: "); gets(data3); printf("\nHorario 1: "); gets(horario5); printf("\nHorario 2: "); gets(horario6); printf("\n\n"); printf("Pecas cadastradas com sucesso."); printf("\n\n"); } void ComprarIngresso(){ printf("Escolha a peca: \n\n"); printf("1 - %s\n", sala1); printf("2 - %s\n", sala2); printf("3 - %s\n\n", sala3); printf("Comando: "); scanf("%d", &peca); if(peca==1){ printf(""); } printf("\nFila: "); scanf("%d", &i); printf("\nAssento: "); scanf("%d", &j); printf("Qual tipo de ingresso: \n\n"); printf("1 - Inteira\n"); printf("2 - Meia\n"); printf("3 - Crianças carentes\n\n"); printf("Comando: "); scanf("%d", &tipo); switch(tipo){ case 1: inteiro + 1; break; case 2: meia + 1; break; case 3: gratis + 1; } if(CAD[i][j]==0){ CAD[i][j] = 1; printf("\n\nAssento reservado com sucesso!\n\n"); printf("\nIngresso: \n"); printf("Fileira: [%d] Assento: [%d]\n\n", i, j); }else{ printf("\nAssento ocupado!\n\n"); } } void CancelarIngresso(){ printf("\nFila: "); scanf("%d", &i); printf("\nAssento: "); scanf("%d", &j); if(CAD[i][j]==1){ CAD[i][j]=0; printf("\n\nReserva cancelada!\n\n"); }else{ printf("Nenhuma reserva para este assento."); } } void Faturar(){ } int main(void){ for(i = 0; i < 20; i++){ for(j = 0; j < 25; j++){ CAD[i][j]=0; } } do{ printf("_________________________________________________________"); printf("\n\n********** SEJA BEM-VINDO(A) AO TEATRO AURORA! **********\n\n"); printf("_________________________________________________________"); printf("\n\n"); printf("1 - Cadastrar Peca\n"); printf("2 - Comprar Ingressos\n"); printf("3 - Cancelar Ingresso\n"); printf("4 - Faturar\n"); printf("5 - Encerrar o Sistema\n"); printf("_________________________________________________________"); printf("\n\n"); printf("Comando: "); scanf("%d", &opcao); printf("\n\n"); switch(opcao){ case 1: CadastrarPeca(); break; case 2: ComprarIngresso(); break; case 3: CancelarIngresso(); break; case 4: break; } }while(opcao!=5); system("pause"); return 0; }  
    • Por alecram28
      Boa tarde. Tenho o seguinte exercício para fazer em Java:
      Escreva um algoritmo para jogo lotérico. O usuário deve informar sua aposta através de 5 números inteiros no intervalo de 1 a 100. No servidor, os números da aposta devem ser armazenados em um vetor. O vetor da aposta não pode conter números repetidos. O algoritmo deve realizar o sorteio, gerando 5 números aleatoriamente no intervalo de 1 a 100. Os números sorteados também devem ser armazenados em um vetor. O vetor do sorteio não pode conter números repetidos. Se o usuário acertar menos de 3 números, ele ganha 0% da premiação. Se o usuário acertar 3 números, ele ganha 50% da premiação. Se o usuário acertar 4 números, ele ganha 75% da premiação. Se o usuário acertar os 5 números, ele ganha 100% da premiação. Na interface, o algoritmo deve
      informar:
      a. O valor da premiação.
      b. O vetor da aposta.
      c. O vetor do sorteio.
      d. O valor do prêmio recebido pelo usuário.
       
      Gostaria de ajuda para como posso verificar os valores iguais entre os vetores (verificar se a pessoa acertou algum numero)
      Obrigado!
       
       
       
       
       
       
       
    • Por Albertodias77
      Preciso muito dessa ajuda.
      Crie o algoritmo que a partir de um vetor com um número indeterminado de números pares obtenha três outros vetores a partir do vetor inicial: números pares, números impares e números primos (o algoritmo terá de contemplar as três funções distintas).
      *recolha do vetor através da leitura de uma string contendo os valores separados por “,”
      *display no ecrã dos 3 vetores resultantes na forma de lista separado por “,” na seguinte ordem: números pres, ímpares e primos. Considere a hipótese de um ou mais vetores estarem vazios, indicando tal no display.
      *pausa no final para se verem os resultados (ReadKey)
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.