Jump to content

Search the Community

Showing results for tags 'Visualg'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 113 results

  1. Daniel Amaral Dos Santos

    Me ajudem com uma questão por favor

    Olá pessoal, estou com bastante dificuldade em resolver uma questão, e gostaria de saber se alguém poderia me ajudar com isso. Consegui escrever algumas linhas de codigo, mas realmente nao sei como proceder com esse programa. Segue a pergunta: TAREFA PRÁTICA 2 (Variáveis Simples, Estrutras Lógicas de seleção e repetição) Considere a sua turma da disciplina de Introdução à Ciência da Computação que você faz parte. Use para os dados de entrada, para cada aluno: a sua matricula M (inteiro) e as notas das provas P1 (real) e P2 (real). Suponha que existam 5 tarefas práticas TP1, ...., TP5. Entre com as notas das tarefas práticas TP1, ... TP5. Para confirmar o que digitou, escreva as mensagens e as notas de entrada. Faça algoritmo que: a) Leia o número N de alunos da turma. N deve ser fornecido via teclado. Suponha um valor de N inteiro. O algoritmo deve verificar se o aluno foi aprovado ou reprovado. b) Considere a média aritmética ponderada das provas de cada aluno: MP = ( P1 + P2 )/2. Considere que a média das tarefas práticas é MT = (0.20*TP1 + ... + 0.20*TP5), supondo 5 tarefas práticas. A média final MF = (0.4*MP + 0.6*MT)/2.0. Se 9.0 <= MF <= 10.0, então, o algoritmo deve escrever uma mensagem "ALUNO APROVADO". Escreva MF. Se 7.5 <= MF < 9.0, então, o algoritmo deve escrever uma mensagem "ALUNO APROVADO". Escreva MF. Se 6.0 <= MF < 7.5, o algoritmo deve escrever uma mensagem "ALUNO APROVADO". Escrva MF. Se 3.0 <= MF < 6.0 então o algoritmo deve escrever uma mensagem "ALUNO EM RECUPERAÇÂO". O aluno deverá fazer outra prova para recuperação, Obtendo uma nota NR. Entre com esta nota NR, e a nota final será calculada como MF = (MP + NR)/2. Se 0.0 <= MF < 6.0, então, o algoritmo deve escrever uma mensagem "ALUNO REPROVADO". Se 0.0 <= MF < 3.0, então, o algoritmo deve escrever uma mensagem "ALUNO REPROVADO". c) O algoritmo deve fornecer ao final, a média aritmética MEDFINAL das notas MF dos alunos da turma. Deve escrever a mensagem identificando a média da turma, "A MEDIA DA TURMA É = " . Segue o que eu consegui escrever até agora: Var // Seção de Declarações das variáveis N: Inteiro p1, p2, TP1, TP2, TP3, MP, MT, MF, SomaMF: Real Flag: Real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... leia(N) leia(p1, p2, TP1, TP2, TP3) MP <- ((p1 + p2)/2) MT <- ((0.20 * TP1) + (0.20 * TP2) + (0.20 * TP3)) MF <- (((0.4 * MP) + (0.6 * MT)) / 2) Se (9 <= MF) escreval("Aluno conceito A ") fimse Se então escreval("Aluno conceito B ") fimse Fimalgoritmo Aguardo a resposta de alguém e agradeço desde já.
  2. Yavanna

    Dúvida Visualg (Básico)

    Galera, não entendi por que tenho que por dois "FimSe" no seguinte programa: algoritmo "semnome" var M, N1, N2: Real inicio Escreva("Sua primeira nota") Leia(N1) Escreva("Sua segunda nota") Leia(N2) M<-(N1+N2)/2 Se (M>=7) entao Escreva("Parabéns, você está aprovado") senao se (M>=5) e (M<7) entao Escreva("Você está em recuperação") senao Escreva("Sinto, muito") FimSe Fimse fimalgoritmo
  3. Preciso escrever um algoritmo no VisuAlg com um menu com 3 opções: Cadastrar, Pesquisar e Sair. Para cadastrar, devo fazer uma "ficha de cadastro" utilizando a função REGISTRO. Criei um algoritmo, mas o VisuAlg lê somente um bloco dos Escolha/Caso que fiz, ou seja, quando tento voltar no menu para selecionar outra opção o VisuAlg encerra meu algoritmo. Ajuda aew na moral, pelo amor de Deus!!!! Algoritmo "semnome" // Disciplina : // Professor : // Descrição : // Autor(a) : // Data atual : Procedimento menu Inicio Escreval ("Software RH Master - Soluções em Cadastro") Escreval ("*****************************************") Escreval ("Selecione uma das opções: ") escreval ("1- Cadastrar") escreval ("2- Pesquisar") escreval ("3- Sair") leia (opcao) Fimprocedimento tipo cadastro = registro nome: caracter telefone: caracter email: caracter fimregistro Var opcao: inteiro // variável para menu de opções // variáveis para cadastrar funcionario: vetor [1..3] de cadastro c: inteiro respCadastro: caracter // variáveis para organizar aux: caracter o: inteiro // variáveis para pesquisar pesquisa: caracter Inicio menu escolha opcao Caso 1 Para c de 1 ate 3 faca Escreva ("Nome completo: ") Leia (funcionario.nome[c]) Escreva ("Telefone: ") Leia (funcionario.telefone[c]) Escreva ("Email: ") Leia (funcionario.email[c]) escreval ("------------------------------") Fimpara //Ordenação de nomes da agenda Para o de 1 ate 3 passo 1 faca para c de 1 ate 2 passo 1 faca Se funcionario.nome[c] > funcionario.nome[c+1] entao aux <- funcionario.nome[c] funcionario.nome[c] <- funcionario.nome[c+1] funcionario.nome <- aux fimse fimpara fimpara menu Caso 2 Escreva ("Digite o nome que deseja pesquisar: ") Leia (pesquisa) Se (pesquisa = funcionario.nome[c]) entao Escreval (funcionario.nome[c]) Escreval (funcionario.telefone[c]) Escreval (funcionario.email[c]) Senao Escreva ("Nome não cadastrado!") Fimse menu Caso 3 Fimescolha Fimalgoritmo
  4. Olá, estou com um exercício para resolver, mas estou com dificuldade de achar a solução. No caso, eu preciso criar um algoritmo que escreva uma frase na tela até que uma tecla seja digitada (que nem quando há mensagem do windows). Alguém poderia me ajudar?
  5. I_mean_It

    Rotinas Visualg

    Boa noite, comecei a estudar lógica de programação a pouco tempo, e estou com uma dúvida sobre passagem de parâmetros por valor e por referência. Sei a estrutura de cada um e como funciona, porém não sei quando devo usar um ou outro. Será que alguém poderia tentar exemplificar para mim? Estou aprendendo no Visualg.
  6. Bom dia galera. Bom não sei se minha duvida esta no local certo. se não estiver me perdoem. gostaria de u ajuda para validar a data desse algoritmo. porque do jeito que esta pode colocar qualquer data que dar certo e teria que ser a data atual. desde já obrigado pela ajuda. Algoritmo "Alg_Estoque" // Disciplina : [Informática Aplicada] // Professor : Sergio Lins // Descrição : criar um sistema que exiba o menu com uso adequado de estrutura // de controle combinado com laço de repetição. Conforme as regras. // Autor(a) : Manoel Estevam Neto // Data atual : 20/02/2018 Var // variáveis opcao, saldoIni, saldoTot: inteiro prod, dCompra, dVenda: caractere vUnit, vTot: Real qCompra, qVenda: inteiro Inicio repita escreval("-------------------------------") escreval("*** Sistema de Estoque ***") escreval("-------------------------------") escreval("* 1.Compra *") escreval("* 2.Venda *") escreval("* 3.Saldo *") escreval("* 4.Resumo *") escreval("* 5.Sair *") escreval("-------------------------------") escreva("Digite a opção desejada: ") leia(opcao) escolha(opcao) caso 1 escreval("-------------------------------") escreval("*** Sistema de Compras ***") escreval("-------------------------------") escreva("Digite o nome do produto: ") leia(prod) escreva("Digite a quantidade do produto: ") leia(qCompra) escreva("Digite a data da compra (dd/mm/AAAA): ") leia(dCompra) escreva("Digite o valor unitário: ") leia(vUnit) // escreva("Digite o valor total: ") // leia(vTot) vTot <- (qCompra*vUnit) escreval("Compra realizada com sucesso") escreval("| Produto | Data da Compra | Quant. | Valor Unit | Total |") escreval("| ", prod, " | ", dCompra, " | ", qCompra, " | ", vUnit, " | ", vTot, " |") caso 2 escreval("-------------------------------") escreval("*** Sistema de Vendas ***") escreval("-------------------------------") escreva("Digite o nome do produto: ") leia(prod) escreva("Digite a quantidade do produto: ") leia(qVenda) escreva("Digite a data da venda (dd/mm/AAAA): ") leia(dVenda) escreva("Digite o valor unitário: ") leia(vUnit) vTot <- (vUnit*qVenda) escreval("Venda realizada com sucesso") escreval("| Produto | Data da Venda | Quant. | Valor Unit | Total |") escreval("| ", prod, " | ", dVenda, " | ", qVenda, " | ", vUnit, " | ", vTot, " |") caso 3 saldoIni <- 10 se (saldoIni < 10) entao escreval("Hora de ir as compras!") senao saldoTot <- saldoIni + qCompra escreval(prod," em estoque é = ", saldoTot) fimse caso 4 saldoIni <- 10 saldoTot <- saldoIni + qCompra escreval("-----------------------------------------") escreval("*** Resumo ***") escreval("-----------------------------------------") escreval("| Saldo Inicial... ",saldoIni, " |") escreval("| Compras ........ ",qCompra, " |") escreval("| Vendas ......... ",qVenda, " |") escreval("| Saldo Atual..... ",saldoTot-qVenda, " |") caso 5 escreval("Obrigado! E volte sempre") outrocaso escreval("Opção inválida!") fimescolha ate opcao = 5 Fimalgoritmo .Inclusive no caso 3 seria necessário dar baixa no saldo do estoque.
  7. Alguém pode me ajudar com esse trabalho da Faculdade? to sem ideia de onde começar. – Elabore um algoritmo que solicite ao operador a idade de um grupo de pessoas (várias), processe e apresente: a) a idade média das pessoas; b) a maior idade e quantas pessoas a tiveram; c) a menor idade e quantas pessoas a tiveram. Atenção: 1) quando a idade informada for igual a zero, finalizar as entradas e mostrar os resultados processados. 2) Validar corretivamente para que a idade não seja inferior a zero e nem superior a 120. 3) Verificar se houve entrada de dados, caso não, dê uma mensagem. 4) Lembre-se que a primeira idade informada será a maior e/ou menor em relação as demais idades que serão informadas. Observação1: 1) Criar as seguintes funções: a) Uma função para validar corretivamente a idade para estar no intervalo de 0 a 130. b) uma função para processar o cálculo da média, retornando o resultado para o código principal onde será mostrado. 2) NÃO usar estrutura de vetor e/ou matriz.
  8. nad_nov <- "" Escreva ("Informe a idade do nadador: ") leia(idade) se idade < novo entao novo <- 0 * novo + (idade) nad_nov <- (nome) fimse Pessoal , eu desenvolvi um algoritmo em portugol para uma questão no qual pedia uma série de coisas, entre elas pedia de O nome do nadador mais novo , e é justamente a parte que não deu certo. Como eu armazenaria o nome do nadador mais novo após vários loops?
  9. Pessoal, estou tentando fazer um jogo da velha um pouco diferente do padrão. É uma versão bem simples. Só que um dos comandos está dando problema e eu não faço ideia o porquê disso. Vejam: algoritmo "Jogo da Velha" var jogo: vetor[1..3, 1..3] de inteiro i, j: inteiro cont: inteiro pos1: inteiro pos2: inteiro num: vetor[1..9] de inteiro Procedimento Topo() inicio EscrevaL ("---------------") EscrevaL (" JOGO DA VELHA ") EscrevaL ("---------------") cont <- 1 Para i <- 1 ate 3 faca Para j <- 1 ate 3 faca jogo [i,j] <- cont Se jogo[i,j] = num[pos1] entao Escreva ("| X|") senao Se jogo[i,j] = num[pos2] entao Escreva ("| O|") senao Escreva ("| ", cont, "| ") FimSe FimSe cont <- cont + 1 FimPara EscrevaL () FimPara EscrevaL ("---------------") FimProcedimento Procedimento JogadaJ1 () inicio Repita EscrevaL ("Digite a posição para o jogador (X)") Leia (pos1) Se num[pos1] = jogo[i,j] entao Escreva ("JOGADA INVÁLIDA. Digite outra posição") FimSe Ate num[pos1] <> jogo[i,j] num[pos1] <- pos1 Topo () JogadaJ2 () FimProcedimento Procedimento JogadaJ2 () inicio Repita EscrevaL ("Digite a posição para o jogador (O)") Leia (pos2) Se num[pos2] = jogo[i,j] entao Escreva ("JOGADA INVÁLIDA. Digite outra posição") FimSe Ate num[pos2] <> jogo[i,j] num[pos2] <- pos2 Topo () JogadaJ1 () FimProcedimento inicio LimpaTela EscrevaL ("---------------") EscrevaL (" JOGO DA VELHA ") EscrevaL ("---------------") cont <- 1 Para i <- 1 ate 3 faca Para j <- 1 ate 3 faca jogo [i,j] <- cont Escreva ("| ", cont, "| ") cont <- cont + 1 FimPara EscrevaL () FimPara JogadaJ1 () fimalgoritmo Ainda não terminou, mas há um erro de sintaxe na linha do "Se jogo[i,j] = num[pos1] entao" e "Se jogo[i,j] = num[pos2] entao". Alguém pode me dizer por quê ?
  10. Olá galera estou com dificuldade para fazer um algoritmo que seria"Entrar com o número e a base em que se deseja calcular o logaritmo desse número e imprimi-lo." ,mais não sei como calcular logaritmo sem ser com a função LOG que faz essa conta na base 10 .
  11. Na verdade, eu sei como escrever um algoritmo que diga se é primo ou não. Mas, a maior dificuldade é encontrar a estrutura que seja capaz de dizer qual o primo anterior à este. Por favor ajudem-me.
  12. Meus amigos, bom dia! Meus amigos boa tarde! Vocês poderiam me ajudar com um exercício em visualg? Exercicio: "Colocar em MAIOR o maior de A,B e C e em MENOR o menor deles, sendo que A, B E C devem ser lidos. Imprimir os valores lidos e os determinados." (Tenho que perguntar os três números para o usuário e compará-los de uma vez) Eu fiz assim: algoritmo "Maior_e_Menor" var A,B,C, MAIOR, MENOR: Inteiro inicio escreval ("Digite o primeiro número") leia (A) escreval ("Digite o segundo número") leia (B) escreval ("Digite o terceiro número") leia (C) se (A>B) e (A>C) então MAIOR <- A senao MENOR <- A fimse se (B>C) e (B>A) então MAIOR <- B senao MENOR <- B fimse se (C>A) e (C>B) então MAIOR <- C senao MENOR <- C fimse escreval ("Os números digitados foram: ", A,B,C) escreval("Maior: ", MAIOR) escreval("Menor: ", MENOR) fimalgoritmo Eu fiz um teste, e não deu certo: --------------------------------------------- Início da execução Digite o primeiro número 5 Digite o segundo número 6 Digite o terceiro número 7 Os números digitados foram: 5 6 7 Maior: 7 Menor: 6 // AQUI DEVERIA SER 5 Fim da execução. -------------------------------------------- Alguem pode me ajudar por favor? Obrigado!!
  13. Var vetorA: vetor [1..10] de inteiro VetorB: vetor [1..10] de inteiro i:inteiro num:inteiro media:real result:real Inicio i<-1 Para i de 1 ate 10 faca Leia(num) vetorA [i]<-num i<-i+1 Fimpara escreval("") escreval("calculando o dobro...") escreval("") para i de 1 ate 10 faca timer (50) VetorB[i] <- VetorA[i] * 2 escreva(VetorB[i]) fimpara para i de 1 ate 10 faca media <- VetorB[i] + VetorB[i] result <- media/10 fimpara Fimalgoritmo Eu estou com problemas nessa ultima estrutura para, pois queria fazer a média do VetorB, porém não sei como. agradeço desde ja
  14. Estou começando agora a programar, faço alguns exercícios para exercitar, e queria saber porque toda vez que executo o programa Visualg informa que esta faltando o "fimse" na linha 34, se eu colocar mais um "fimse" funciona, mas assim ficaria 3 sendo que existem apenas 2 condicionais, uma "se" e outra "se" ninhada. Segue o algorítimo, quem poder me explicar o porque, agradeço: Algoritmo "Equação" Var a,b,c,x1,x2,D: real Inicio Escreval("----EQUAÇAO DE SEGUNDO GRAU-----") Escreval("") Escreval("Digite o valor de a: ") Leia (a) Escreval("Digite o valor de b: ") Leia (b) Escreval("Digite o valor de c: ") Leia (c) D <- (b^2)-4*a*c x1 <- (-b+ RaizQ(D))/(2*a) x2 <- (-b- RaizQ(D))/(2*a) se (D > 0) entao Escreval("Delta : ",D," , maior que zero, ou seja, 2 raizes") Escreval(" X1: ", x1) Escreval(" X2: ", x2) senao entao se (D=0) entao Escreval("Delta : ", D," , sendo assim, uma raiz") Escreval(" X1: ", x) se não entao Escreval("Delta: ", D," , Raiz negativa!") fimse fimse Fimalgoritmo
  15. Estou tentado fazer esse trecho do meu código funcionar enquanto(n <> "s") e (n <> "n") faca escreva("") leia(n) fimenquanto mas ele retorna este erro
  16. Galera estou precisando de ajuda para saber se essa questão está certa. Faça um algoritmo que leia um número N e mostre todos os números múltiplos de 5, no intervalo de 1 a N. var cont, n, soma:inteiro inicio n <- 1 soma <- 0 enquanto ( n <> 0 ) faca escreval("Valor ") leia(n) se (n % 5 = 0) entao soma <- soma + n escreval (n, " é multiplo de 5") senao escreval (n, " não é multiplo de 5") fimse fimenquanto Não sei se é exatamente isso que a questão pede. Outras questões que estou em dúvida são essas 6- Faça um algoritmo que leia um número inteiro N (maior que 11) e mostre os números entre 11 e N que quando divididos por 11 produzam resto igual a 5. (utilizar estrutura SE...ENTAO dentro da estrutura (REPITA... ATE). 10- Escreva um algoritmo para ler 2 valores e se o segundo valor informado for ZERO, deve ser lido um novo valor, ou seja, para o segundo valor não pode ser aceito o valor zero. Depois mostrar o resultado da divisão do primeiro valor lido pelo segundo valor lido. (utilizar a estrutura REPITA... ATE) 5- Faça um algoritmo que leia um número N e mostre todos os números múltiplos de 5, no intervalo de 1 a N.
  17. Ola A estrutura se deste algoritimo esta dando erro,agradeço se alguem puder me ajudar. // Função :6) Faça um algoritmo que o usuário informe dois números inteiros, que o segundo //número divida o primeiro e que se o resto for par, o quociente for ímpar e o resultado //for maior que 3, informe que ele venceu o desafio do algoritmo, e independente de //vencer ou não mostre os resultados das operações. // Autor :Emerson Reinecke // Data : 03/08/2017 // Seção de Declarações var n1,n2:inteiro resultado,quoc,resto:real inicio escreval("Digite um numero:") leia(n1) escreval("Digite um numero:") leia(n2) resultado<-(n1/n2) resto<-(n1 mod n2) quoc<-(n1 div n2) se (resto=0) e (resultado>3) e (quoc mod 2 = 0 ) entao escreval("Voce Venceu o Desafio do Algoritmo!") escreval("O Resultado da operação foi ",resultado,"") escreval("O Quociente da operação foi ",quoc,"") escreval("O Resto da operação foi ",resto,"") senao escreval("O Resultado da operação foi ",resultado,"") escreval("O Quociente da operação foi ",quoc,"") escreval("O Resto da operação foi ",resto,"") fimse fimalgoritmo
  18. Receber um número inteiro e imprimir a soma de todos os números inteiros entre este número e seu segundo múltiplo. Imprima também o primeiro e o segundo múltiplos deste número:
  19. sabem fazer algumas dessas questões? 1- Fazer um algoritmo que armazene em um vetor os 10 primeiros valores primos. 2. Escreva um algoritmo que peça um número n ao usuário, e que gere um novo n de acordo com a seguinte regra: • se n é par, n = n / 2 • se n é impar, n = 3 * n + 1 • imprime n • O programa deve parar quando x tiver o valor igual a 1. Por exemplo, para n = 13, a saída será: 40 -> 20 -> 10 -> 5 -> 16 -> 8 -> 4 -> 2 -> 1 3. Crie um algoritmo que peça um número inteiro ao usuário, e imprima a seguinte tabela: Informe um valor: 4 1 2 4 3 6 9 4 8 12 16 4. Fazer um algoritmo que leia um número que servira para controlar os primeiros números ímpares. Deverá ser impressa a soma desses números. Suponha que o número informado será maior que zero, caso não seja, informar o erro. Exemplo: Informe um número: 5 1 3 5 7 9 A soma dos 5 valores impares é: 25 5. Fazer um algoritmo que armazene em um vetor os 10 primeiros valores primos. 6. Fazer um algoritmo que leia um vetor N de 20 posições. Troque a seguir, o 1° elemento com o ultimo, o 2° elemento com o penúltimo, etc., até trocar o 10° com o 11°. Mostrar o vetor modificado. 7. Fazer um algoritmo que que leia um vetor K de 30 posições. Troque a seguir todos os elementos de ordem ímpar do vetor com os de ordem par imediatamente posterior. Mostrar o vetor modificado.
  20. Faça o programa que apresenta a seguinte saída, perguntando ao usuário o número máximo. Este número deve ser sempre ímpar. Exemplo: Entrada: 9 Saída: 1 2 3 4 5 6 7 8 9 2 3 4 5 6 7 8 3 4 5 6 7 4 5 6 5
  21. Faça um programa que apresente a seguinte saída, perguntando ao usuário o número máximo. Este número deve ter ímpar. Exemplo: Entrada: 9 Saída: 1 2 3 4 5 6 7 8 9 2 3 4 5 6 7 8 3 4 5 6 7 4 5 6 5 Obs.: tem que ser em PORTUGOL
  22. Crie um algoritmo que calcule os N primeiros termos de uma PA (progressão aritmética). O algoritmo deve receber o primeiro termo, a razão e a quantidade de termos que devem ser apresentados. Ao final mostre os dez termos da sequencia. O cálculo de cada termo obedece a seguinte fórmula an<- a1+(n-1)*r, onde: an - n-ésimo termos n- número do termo r - razão algoritmo "PA" var razao, n, a1, an: inteiro //Inicio escreva ("Entre com a razão:") leia (razao) escreva ("Entre com o primeiro termo:") leia (a1) escreva ("Entre com o elemento N:") leia (n) an<-a1+(n-1)*razao escreva ("O elemento" ,n, "é:" ,an) fimalgoritmo Eu consegui fazer esse algoritmo só não sei como mostrar os dez termos da sequencia, me ajudem, por favor!!!
  23. ficarei muito grato se alguém puder me ajudar com esse exercício 1) A partir da intercalação de dados de dois vetores de 5 números inteiros cada, com dados ordenados crescentemente, montar um terceiro vetor de 10 elementos, de tal forma que este tenha os dados dos dois vetores anteriores e também esteja ordenado.
  24. Boa tarde pessoal, Estou tendo dificuldades com o seguinte exercício sobre vetores: algoritmo "satanás" var v : vetor[1..30] de inteiro i, j, menor, maior, tmp : inteiro inicio para i de 1 ate 5 faca leia(v) se(i = 1) entao maior := v[1] fimse se ((i = 2) e (v > maior)) entao menor := v[1] maior := v[2] senao se ((i = 2) e (v < maior)) entao menor := v[2] fimse fimse se ((i <> 1) e (i <> 2) e (v > maior)) entao maior := v senao se ((i <> 1) e (i <> 2) e (v < menor)) entao menor := v fimse fimse fimpara tmp := v[1] v[1] := menor menor := tmp v[5] := tmp maior := tmp para i de 1 ate 5 faca escreva(v) fimpara fimalgoritmo Eu consegui fazer a troca do 1º número pela posição do menor e do último pela posição do maior, mas o menor não vai para a primeira posição e do maior pelo último. Por exemplo: o usuário informa 5 números: 5, 2, 3, 1, 4 A troca acontece: 1, 2, 3, 1, 5 Observe que foi o 1 foi pra posição do 5, mas o 5 não foi para a posição do 1, do mesmo jeito que o 5 foi para a última posição, mas o número da última posição não foi para o lugar do 5. :( Obrigado desde já.
  25. dillan

    Visualg

    Peguei este algoritmo em um livro mas quando faço no visualg sempre dar erro onde está o problema: Algoritmo "semnome" // // // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Nome do(a) aluno(a) // Data atual : 09/05/2017 Var mes:inteiro Inicio leia (mes) caso mes seja 1 faca escreva("Janeiro") seja 2 faca escreva("Fevereiro") seja 3 faca escreva("Março") seja 4 faca escreva("Abril") seja 5 faca escreva("Maio") seja 6 faca escreva("Junho") seja 7 faca escreva("Julho") seja 8 faca escreva("Agosto") seja 9 faca escreva("Setembro") seja 10 faca escreva("Outubro") seja 11 faca escreva("Novembro") seja 12 faca escreva("Dezembro") senao escreva("Valor Invalido") fim_caso Fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.