Jump to content

Search the Community

Showing results for tags 'Visualg'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 123 results

  1. Olá, gostaria imensamente que alguém me ajudasse a colocar o resultado em letra maiúscula. Sei que existe uma função chamada "maiusc" mas não estou sabendo como usá-la. Obrigada, desde já
  2. Camilla03

    Visualg exercício enquanto

    Elabore um QUIZ de 10 perguntas e respostas sobre cada disciplina: Matemática, Sociologia e Filosofia do 1o ano. Cada pergunta deverá ter 5 opções de escolha de resposta. Além disso, cada questão contemplará duas tentativas do usuário, isto é, se o usuário responder uma resposta incorreta, terá uma 2a chance na questão que valerá 70% da nota desta questão. Cada questão deverá dar "feedback" (retorno ao usuário) de acerto ou dica se o usuário não acertar. O usuário escolherá no início do programa sobre qual disciplina ele deseja responder as questões. Ao final de cada rodada, exiba um ranking de notas.
  3. algoritmo "semnome" // Função : // Autor : Marlon R.Muniz // Data : 07/05/2018 // Seção de Declarações var id_cidade: inteiro nome: caractere acidentes: inteiro maior_acidentes: inteiro cidade_maior_acidentes: caractere id_cidade_maior_acidentes: inteiro veiculos: inteiro i : inteiro maximo: inteiro maior_veiculos : inteiro cidade_maior_veiculos: caractere id_cidade_maior_veiculos: inteiro menor_veiculos: inteiro cidade_menor_veiculos: caractere id_cidade_menor_veiculos: inteiro Inicio MAXIMO <- 2 maior_veiculos <- 0 menor_veiculos <- 0 para i de 1 ate MAXIMO passo 1 faca escreva("codigo da cidade:") leia (id_cidade) escreva("nome da cidade:") leia ( nome) escreva("numero de veiculos:") leia (veiculos) escreva("numero de acidentes:") leia (acidentes) //1. o cÓdigo e o nome da cidade que possuem o maior nuumero de veículos se maior_veiculos < veiculos entao maior_veiculos <- veiculos cidade_maior_veiculos <- nome id_cidade_maior_veiculos <- id_cidade fimse .//2. o código e o nome da cidade que possuem o menor n´umero de veículos se (menor_veiculos > veiculos) entao menor_veiculos <- veiculos cidade_menor_veiculos <- nome id_cidade_menor_veiculos <- id_cidade fimse //o valor do maior ´indice de acidentes de trˆansito, assim como o c´odigo e o nome da cidade `a qual pertence esse indice fimpara Escreval( "Cidade com maior quantidade de veículos" , cidade_maior_veiculos , "id" , id_cidade_maior_veiculos ) Escreval( "Cidade com menor quantidade de veiculos" , cidade_menor_veiculos , "id" , id_cidade_menor_veiculos ) _________ Fiz isso baseado em outro exercício que roda liso e de bônus alguém pode me ajudar a organizar o escreval? Quando aparece os dados, não aparece o espaço que coloquei, fica tudo misturado
  4. Não consigo lembrar para imprimir a tabela ascll no visual
  5. "Escreva um algoritmo que leia o nome, idade e sexo de 10000 pessoas finalizando a digitação quando o nome for igual a espaço. Mostrar o total de pessoas digitadas, o percentual de homens e de mulheres, a média de idade e o nome e idade da pessoa mais velha e da pessoa mais nova." Estou resolvendo esse exercício mas não consegui fazer a média dentro do para. Algoritmo "numero2" // Disciplina : [Linguagem e Lógica de Programação] // Professor : Antonio Carlos Nicolodi // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Lucas // Data atual : 21/04/2018 Var // Seção de Declarações das variáveis idade, x, pessoas, homens, mulheres : inteiro velha, nova:inteiro media, num : real nome, sexo, nomevelho,nomenovo : caractere Inicio // Seção de Comandos, procedimento, funções, operadores, etc... velha <- 0 nova <- 200 pessoas <- 0 homens <- 0 mulheres <- 0 num <- 0 para x de 1 ate 2 faca escreva ("Insira o seu nome: ") leia (nome) se nome=" " entao interrompa fimse escreva ("Insira seu sexo(F/M): ") leia (sexo) escreva ("Insira sua idade: ") leia (idade) limpatela media <- idade pessoas <- pessoas+ 1 se sexo="M" entao homens <- homens +1 fimse se sexo= "F" entao mulheres <- mulheres+1 fimse se idade > velha entao velha <- idade nomevelho <- nome fimse se idade < nova entao nova <- idade nomenovo <- nome fimse fimpara homens <- homens * 50 mulheres <- mulheres * 50 escreval ("A pessoa mais nova é: ",nomenovo,", sua idade é: ",nova) escreval ("A pessoa mais velha é: ",nomevelho,", sua idade é: ",velha) escreval ("O número total de pessoas é: ",pessoas) // escreval ("A media da idade é: ",media) escreval ("O percentual de homens é: ",homens, "%") escreval ("O percentual de mulheres é: ",mulheres,"%") Fimalgoritmo Gente deu tudo certo, só não consegui fazer a media das idades, se alguém puder ajudar agradeço muito. Obs: em vez de colocar 100000 eu coloquei só 2 para ficar mais fácil testar.
  6. Solicite dois números inteiros onde o segundo deverá ser no mínimo 20 unidades maior que o primeiro e no máximo 50 unidades, e posteriormente apresente todos os números primos deste intervalo.
  7. Rodrigo Yuzo Matsubara

    Duvidas com visual G

    Boa tarde pessoal, Sou novato em VisualG, não sei como fazer estes execícios abaixo, alguém poderia ajudar? Obrigado. 4) Solicitando 15 valores inteiros entre 10 e 200, apresente a quantidade de números pares informados. 5) Solicite 10 números inteiros entre -100 e 100, e apresente a quantidade de números ímpares, e a média aritmética dos números pares. 6) Construa um algoritmo que solicite 10 números e apresente a média aritmética dos mesmos. 7) Considerando que a nota bimestral de um aluno seja calculada através da média ponderada de 4 avaliações, solicite os dados (notas e respectivos pesos) e apresente a média. 8) Solicite 10 valores inteiros ao usuário e apresente a média harmônica deste conjunto. 9) Construa um programa que gere N números randômicos entre 64 e 1239 e os apresente ao usuário. O valor de N deverá ser indagado ao usuário. Dica: Utilize o comando RANDI. 10) Solicite dois valores inteiros (A,B) onde B deve ser obrigatoriamente maior que o valor de A. Posteriormente, apresente o produto entre as duas variáveis, sem no entanto utilizar o operador de multiplicação (*). 11) Solicite um número inteiro e positivo, e posteriormente apresente se o mesmo é ou não um número PRIMO. 12) Solicite um valor inteiro maior ou igual a zero, e posteriormente apresente o seu FATORIAL. 13) A sequência de Fibonacci é uma sequência de números inteiros, começando por 0 e 1, na qual cada termo subsequente corresponde a soma dos dois anteriores. Os números de Fibonacci, são, portanto, os números que compõem a seguinte sequência: 0, 1, 1, 2, 3, 4, 8, 13, 21, 34, 55, 89, 144, 233, ... Desta forma, desenvolva um algoritmo que apresente os N-primeiros termos da sequência de Fibonacci. O usuário deverá fornecer o valor de N. 14) Construa um algoritmo que solicite o divisor e o dividendo de uma expressão e posteriormente apresente o quociente inteiro desta operação sem no entanto utilizar o operador de divisão (/). O divisor obrigatoriamente deverá ser MENOR que o dividendo. 15) Solicite dois números inteiros onde o segundo deverá ser no mínimo 20 unidades maior que o primeiro e no máximo 50 unidades, e posteriormente apresente todos os números primos deste intervalo. 17) Uma universidade deseja saber algumas informações estatísticas referente a uma sala de aula com 40 alunos. Para isso, fora elaborado um questionário contendo as seguintes perguntas: - Nome do aluno - Data de nascimento (DD/MM/AAAA) - Sexo (F/M/O) - Signo - Altura - Peso Desta forma, deseja-se apresentar no final as seguintes informações: a) Percentual de alunos do sexo Feminino b) média de idade dos alunos c) nome e peso da pessoa mais pesada do sexo masculino d) quantidade de pessoas do signo de GEMEOS abaixo de 1,75m de altura e) nome e altura da pessoa mais baixa f) média aritmética de peso de todos os alunos entrevistados g) percentual de pessoas que nasceram em ano BISSEXTO h) quantidade de pessoas que nasceram em dias PRIMO J) quantidade de alunos por signo
  8. Problema: Numa fábrica de peças, o salário base de um operário da linha de fabricação é R$ 240,00. Além do salário base, o operário tem um adicional de produtividade baseado na quantidade de peças que ele fabrica por mês que é pago segundo os requsitos a seguir: Se o número de peças é inferior, ou igual a 500: receberá apenas o salário base. Se o número de peças é superior a 500 e inferior, ou igual a 750: Será adicionado R$ 0,50 por peça fabricada acima das 500. Ex. se fabricou 501 receberá R$ 240,50. Se o número de peças for superior a 750: Receberá R$ 350,00 (fixo) mais R$ 0,75 por peça fabricada acima das 750. Ex. se fabricou 751 receberá R$ 350,75 Desenvolva um algoritmo que permita entrar com o número de peças fabricadas por um operário e imprima seu salário.
  9. Rodrigo Yuzo Matsubara

    Duvidas com visualG

    Boa noite Galera, Sou novo no grupo, tenho duvidas referente ao exercício abaixo: Ler dois valores para as variáveis A e B, e efetuar as trocas dos valores de forma que a variável A passe a possuir o valor da variável B e a variável B passe a possuir o valor da variável A. Apresentar os valores trocados.
  10. Rodrigo Yuzo Matsubara

    Visualg duvidas

    Boa noite Galera, Sou novo no grupo, tenho duvidas referente ao exercício abaixo: Faça um Algoritmo que receba dois números e ao final mostre a soma, subtração, multiplicação e a divisão dos números lidos, entre o primeiro e o segundo.
  11. Daniel Amaral Dos Santos

    Me ajudem com uma questão por favor

    Olá pessoal, estou com bastante dificuldade em resolver uma questão, e gostaria de saber se alguém poderia me ajudar com isso. Consegui escrever algumas linhas de codigo, mas realmente nao sei como proceder com esse programa. Segue a pergunta: TAREFA PRÁTICA 2 (Variáveis Simples, Estrutras Lógicas de seleção e repetição) Considere a sua turma da disciplina de Introdução à Ciência da Computação que você faz parte. Use para os dados de entrada, para cada aluno: a sua matricula M (inteiro) e as notas das provas P1 (real) e P2 (real). Suponha que existam 5 tarefas práticas TP1, ...., TP5. Entre com as notas das tarefas práticas TP1, ... TP5. Para confirmar o que digitou, escreva as mensagens e as notas de entrada. Faça algoritmo que: a) Leia o número N de alunos da turma. N deve ser fornecido via teclado. Suponha um valor de N inteiro. O algoritmo deve verificar se o aluno foi aprovado ou reprovado. b) Considere a média aritmética ponderada das provas de cada aluno: MP = ( P1 + P2 )/2. Considere que a média das tarefas práticas é MT = (0.20*TP1 + ... + 0.20*TP5), supondo 5 tarefas práticas. A média final MF = (0.4*MP + 0.6*MT)/2.0. Se 9.0 <= MF <= 10.0, então, o algoritmo deve escrever uma mensagem "ALUNO APROVADO". Escreva MF. Se 7.5 <= MF < 9.0, então, o algoritmo deve escrever uma mensagem "ALUNO APROVADO". Escreva MF. Se 6.0 <= MF < 7.5, o algoritmo deve escrever uma mensagem "ALUNO APROVADO". Escrva MF. Se 3.0 <= MF < 6.0 então o algoritmo deve escrever uma mensagem "ALUNO EM RECUPERAÇÂO". O aluno deverá fazer outra prova para recuperação, Obtendo uma nota NR. Entre com esta nota NR, e a nota final será calculada como MF = (MP + NR)/2. Se 0.0 <= MF < 6.0, então, o algoritmo deve escrever uma mensagem "ALUNO REPROVADO". Se 0.0 <= MF < 3.0, então, o algoritmo deve escrever uma mensagem "ALUNO REPROVADO". c) O algoritmo deve fornecer ao final, a média aritmética MEDFINAL das notas MF dos alunos da turma. Deve escrever a mensagem identificando a média da turma, "A MEDIA DA TURMA É = " . Segue o que eu consegui escrever até agora: Var // Seção de Declarações das variáveis N: Inteiro p1, p2, TP1, TP2, TP3, MP, MT, MF, SomaMF: Real Flag: Real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... leia(N) leia(p1, p2, TP1, TP2, TP3) MP <- ((p1 + p2)/2) MT <- ((0.20 * TP1) + (0.20 * TP2) + (0.20 * TP3)) MF <- (((0.4 * MP) + (0.6 * MT)) / 2) Se (9 <= MF) escreval("Aluno conceito A ") fimse Se então escreval("Aluno conceito B ") fimse Fimalgoritmo Aguardo a resposta de alguém e agradeço desde já.
  12. Yavanna

    Dúvida Visualg (Básico)

    Galera, não entendi por que tenho que por dois "FimSe" no seguinte programa: algoritmo "semnome" var M, N1, N2: Real inicio Escreva("Sua primeira nota") Leia(N1) Escreva("Sua segunda nota") Leia(N2) M<-(N1+N2)/2 Se (M>=7) entao Escreva("Parabéns, você está aprovado") senao se (M>=5) e (M<7) entao Escreva("Você está em recuperação") senao Escreva("Sinto, muito") FimSe Fimse fimalgoritmo
  13. Preciso escrever um algoritmo no VisuAlg com um menu com 3 opções: Cadastrar, Pesquisar e Sair. Para cadastrar, devo fazer uma "ficha de cadastro" utilizando a função REGISTRO. Criei um algoritmo, mas o VisuAlg lê somente um bloco dos Escolha/Caso que fiz, ou seja, quando tento voltar no menu para selecionar outra opção o VisuAlg encerra meu algoritmo. Ajuda aew na moral, pelo amor de Deus!!!! Algoritmo "semnome" // Disciplina : // Professor : // Descrição : // Autor(a) : // Data atual : Procedimento menu Inicio Escreval ("Software RH Master - Soluções em Cadastro") Escreval ("*****************************************") Escreval ("Selecione uma das opções: ") escreval ("1- Cadastrar") escreval ("2- Pesquisar") escreval ("3- Sair") leia (opcao) Fimprocedimento tipo cadastro = registro nome: caracter telefone: caracter email: caracter fimregistro Var opcao: inteiro // variável para menu de opções // variáveis para cadastrar funcionario: vetor [1..3] de cadastro c: inteiro respCadastro: caracter // variáveis para organizar aux: caracter o: inteiro // variáveis para pesquisar pesquisa: caracter Inicio menu escolha opcao Caso 1 Para c de 1 ate 3 faca Escreva ("Nome completo: ") Leia (funcionario.nome[c]) Escreva ("Telefone: ") Leia (funcionario.telefone[c]) Escreva ("Email: ") Leia (funcionario.email[c]) escreval ("------------------------------") Fimpara //Ordenação de nomes da agenda Para o de 1 ate 3 passo 1 faca para c de 1 ate 2 passo 1 faca Se funcionario.nome[c] > funcionario.nome[c+1] entao aux <- funcionario.nome[c] funcionario.nome[c] <- funcionario.nome[c+1] funcionario.nome <- aux fimse fimpara fimpara menu Caso 2 Escreva ("Digite o nome que deseja pesquisar: ") Leia (pesquisa) Se (pesquisa = funcionario.nome[c]) entao Escreval (funcionario.nome[c]) Escreval (funcionario.telefone[c]) Escreval (funcionario.email[c]) Senao Escreva ("Nome não cadastrado!") Fimse menu Caso 3 Fimescolha Fimalgoritmo
  14. Olá, estou com um exercício para resolver, mas estou com dificuldade de achar a solução. No caso, eu preciso criar um algoritmo que escreva uma frase na tela até que uma tecla seja digitada (que nem quando há mensagem do windows). Alguém poderia me ajudar?
  15. I_mean_It

    Rotinas Visualg

    Boa noite, comecei a estudar lógica de programação a pouco tempo, e estou com uma dúvida sobre passagem de parâmetros por valor e por referência. Sei a estrutura de cada um e como funciona, porém não sei quando devo usar um ou outro. Será que alguém poderia tentar exemplificar para mim? Estou aprendendo no Visualg.
  16. Bom dia galera. Bom não sei se minha duvida esta no local certo. se não estiver me perdoem. gostaria de u ajuda para validar a data desse algoritmo. porque do jeito que esta pode colocar qualquer data que dar certo e teria que ser a data atual. desde já obrigado pela ajuda. Algoritmo "Alg_Estoque" // Disciplina : [Informática Aplicada] // Professor : Sergio Lins // Descrição : criar um sistema que exiba o menu com uso adequado de estrutura // de controle combinado com laço de repetição. Conforme as regras. // Autor(a) : Manoel Estevam Neto // Data atual : 20/02/2018 Var // variáveis opcao, saldoIni, saldoTot: inteiro prod, dCompra, dVenda: caractere vUnit, vTot: Real qCompra, qVenda: inteiro Inicio repita escreval("-------------------------------") escreval("*** Sistema de Estoque ***") escreval("-------------------------------") escreval("* 1.Compra *") escreval("* 2.Venda *") escreval("* 3.Saldo *") escreval("* 4.Resumo *") escreval("* 5.Sair *") escreval("-------------------------------") escreva("Digite a opção desejada: ") leia(opcao) escolha(opcao) caso 1 escreval("-------------------------------") escreval("*** Sistema de Compras ***") escreval("-------------------------------") escreva("Digite o nome do produto: ") leia(prod) escreva("Digite a quantidade do produto: ") leia(qCompra) escreva("Digite a data da compra (dd/mm/AAAA): ") leia(dCompra) escreva("Digite o valor unitário: ") leia(vUnit) // escreva("Digite o valor total: ") // leia(vTot) vTot <- (qCompra*vUnit) escreval("Compra realizada com sucesso") escreval("| Produto | Data da Compra | Quant. | Valor Unit | Total |") escreval("| ", prod, " | ", dCompra, " | ", qCompra, " | ", vUnit, " | ", vTot, " |") caso 2 escreval("-------------------------------") escreval("*** Sistema de Vendas ***") escreval("-------------------------------") escreva("Digite o nome do produto: ") leia(prod) escreva("Digite a quantidade do produto: ") leia(qVenda) escreva("Digite a data da venda (dd/mm/AAAA): ") leia(dVenda) escreva("Digite o valor unitário: ") leia(vUnit) vTot <- (vUnit*qVenda) escreval("Venda realizada com sucesso") escreval("| Produto | Data da Venda | Quant. | Valor Unit | Total |") escreval("| ", prod, " | ", dVenda, " | ", qVenda, " | ", vUnit, " | ", vTot, " |") caso 3 saldoIni <- 10 se (saldoIni < 10) entao escreval("Hora de ir as compras!") senao saldoTot <- saldoIni + qCompra escreval(prod," em estoque é = ", saldoTot) fimse caso 4 saldoIni <- 10 saldoTot <- saldoIni + qCompra escreval("-----------------------------------------") escreval("*** Resumo ***") escreval("-----------------------------------------") escreval("| Saldo Inicial... ",saldoIni, " |") escreval("| Compras ........ ",qCompra, " |") escreval("| Vendas ......... ",qVenda, " |") escreval("| Saldo Atual..... ",saldoTot-qVenda, " |") caso 5 escreval("Obrigado! E volte sempre") outrocaso escreval("Opção inválida!") fimescolha ate opcao = 5 Fimalgoritmo .Inclusive no caso 3 seria necessário dar baixa no saldo do estoque.
  17. Alguém pode me ajudar com esse trabalho da Faculdade? to sem ideia de onde começar. – Elabore um algoritmo que solicite ao operador a idade de um grupo de pessoas (várias), processe e apresente: a) a idade média das pessoas; b) a maior idade e quantas pessoas a tiveram; c) a menor idade e quantas pessoas a tiveram. Atenção: 1) quando a idade informada for igual a zero, finalizar as entradas e mostrar os resultados processados. 2) Validar corretivamente para que a idade não seja inferior a zero e nem superior a 120. 3) Verificar se houve entrada de dados, caso não, dê uma mensagem. 4) Lembre-se que a primeira idade informada será a maior e/ou menor em relação as demais idades que serão informadas. Observação1: 1) Criar as seguintes funções: a) Uma função para validar corretivamente a idade para estar no intervalo de 0 a 130. b) uma função para processar o cálculo da média, retornando o resultado para o código principal onde será mostrado. 2) NÃO usar estrutura de vetor e/ou matriz.
  18. nad_nov <- "" Escreva ("Informe a idade do nadador: ") leia(idade) se idade < novo entao novo <- 0 * novo + (idade) nad_nov <- (nome) fimse Pessoal , eu desenvolvi um algoritmo em portugol para uma questão no qual pedia uma série de coisas, entre elas pedia de O nome do nadador mais novo , e é justamente a parte que não deu certo. Como eu armazenaria o nome do nadador mais novo após vários loops?
  19. Pessoal, estou tentando fazer um jogo da velha um pouco diferente do padrão. É uma versão bem simples. Só que um dos comandos está dando problema e eu não faço ideia o porquê disso. Vejam: algoritmo "Jogo da Velha" var jogo: vetor[1..3, 1..3] de inteiro i, j: inteiro cont: inteiro pos1: inteiro pos2: inteiro num: vetor[1..9] de inteiro Procedimento Topo() inicio EscrevaL ("---------------") EscrevaL (" JOGO DA VELHA ") EscrevaL ("---------------") cont <- 1 Para i <- 1 ate 3 faca Para j <- 1 ate 3 faca jogo [i,j] <- cont Se jogo[i,j] = num[pos1] entao Escreva ("| X|") senao Se jogo[i,j] = num[pos2] entao Escreva ("| O|") senao Escreva ("| ", cont, "| ") FimSe FimSe cont <- cont + 1 FimPara EscrevaL () FimPara EscrevaL ("---------------") FimProcedimento Procedimento JogadaJ1 () inicio Repita EscrevaL ("Digite a posição para o jogador (X)") Leia (pos1) Se num[pos1] = jogo[i,j] entao Escreva ("JOGADA INVÁLIDA. Digite outra posição") FimSe Ate num[pos1] <> jogo[i,j] num[pos1] <- pos1 Topo () JogadaJ2 () FimProcedimento Procedimento JogadaJ2 () inicio Repita EscrevaL ("Digite a posição para o jogador (O)") Leia (pos2) Se num[pos2] = jogo[i,j] entao Escreva ("JOGADA INVÁLIDA. Digite outra posição") FimSe Ate num[pos2] <> jogo[i,j] num[pos2] <- pos2 Topo () JogadaJ1 () FimProcedimento inicio LimpaTela EscrevaL ("---------------") EscrevaL (" JOGO DA VELHA ") EscrevaL ("---------------") cont <- 1 Para i <- 1 ate 3 faca Para j <- 1 ate 3 faca jogo [i,j] <- cont Escreva ("| ", cont, "| ") cont <- cont + 1 FimPara EscrevaL () FimPara JogadaJ1 () fimalgoritmo Ainda não terminou, mas há um erro de sintaxe na linha do "Se jogo[i,j] = num[pos1] entao" e "Se jogo[i,j] = num[pos2] entao". Alguém pode me dizer por quê ?
  20. Olá galera estou com dificuldade para fazer um algoritmo que seria"Entrar com o número e a base em que se deseja calcular o logaritmo desse número e imprimi-lo." ,mais não sei como calcular logaritmo sem ser com a função LOG que faz essa conta na base 10 .
  21. Na verdade, eu sei como escrever um algoritmo que diga se é primo ou não. Mas, a maior dificuldade é encontrar a estrutura que seja capaz de dizer qual o primo anterior à este. Por favor ajudem-me.
  22. Meus amigos, bom dia! Meus amigos boa tarde! Vocês poderiam me ajudar com um exercício em visualg? Exercicio: "Colocar em MAIOR o maior de A,B e C e em MENOR o menor deles, sendo que A, B E C devem ser lidos. Imprimir os valores lidos e os determinados." (Tenho que perguntar os três números para o usuário e compará-los de uma vez) Eu fiz assim: algoritmo "Maior_e_Menor" var A,B,C, MAIOR, MENOR: Inteiro inicio escreval ("Digite o primeiro número") leia (A) escreval ("Digite o segundo número") leia (B) escreval ("Digite o terceiro número") leia (C) se (A>B) e (A>C) então MAIOR <- A senao MENOR <- A fimse se (B>C) e (B>A) então MAIOR <- B senao MENOR <- B fimse se (C>A) e (C>B) então MAIOR <- C senao MENOR <- C fimse escreval ("Os números digitados foram: ", A,B,C) escreval("Maior: ", MAIOR) escreval("Menor: ", MENOR) fimalgoritmo Eu fiz um teste, e não deu certo: --------------------------------------------- Início da execução Digite o primeiro número 5 Digite o segundo número 6 Digite o terceiro número 7 Os números digitados foram: 5 6 7 Maior: 7 Menor: 6 // AQUI DEVERIA SER 5 Fim da execução. -------------------------------------------- Alguem pode me ajudar por favor? Obrigado!!
  23. Var vetorA: vetor [1..10] de inteiro VetorB: vetor [1..10] de inteiro i:inteiro num:inteiro media:real result:real Inicio i<-1 Para i de 1 ate 10 faca Leia(num) vetorA [i]<-num i<-i+1 Fimpara escreval("") escreval("calculando o dobro...") escreval("") para i de 1 ate 10 faca timer (50) VetorB[i] <- VetorA[i] * 2 escreva(VetorB[i]) fimpara para i de 1 ate 10 faca media <- VetorB[i] + VetorB[i] result <- media/10 fimpara Fimalgoritmo Eu estou com problemas nessa ultima estrutura para, pois queria fazer a média do VetorB, porém não sei como. agradeço desde ja
  24. Estou começando agora a programar, faço alguns exercícios para exercitar, e queria saber porque toda vez que executo o programa Visualg informa que esta faltando o "fimse" na linha 34, se eu colocar mais um "fimse" funciona, mas assim ficaria 3 sendo que existem apenas 2 condicionais, uma "se" e outra "se" ninhada. Segue o algorítimo, quem poder me explicar o porque, agradeço: Algoritmo "Equação" Var a,b,c,x1,x2,D: real Inicio Escreval("----EQUAÇAO DE SEGUNDO GRAU-----") Escreval("") Escreval("Digite o valor de a: ") Leia (a) Escreval("Digite o valor de b: ") Leia (b) Escreval("Digite o valor de c: ") Leia (c) D <- (b^2)-4*a*c x1 <- (-b+ RaizQ(D))/(2*a) x2 <- (-b- RaizQ(D))/(2*a) se (D > 0) entao Escreval("Delta : ",D," , maior que zero, ou seja, 2 raizes") Escreval(" X1: ", x1) Escreval(" X2: ", x2) senao entao se (D=0) entao Escreval("Delta : ", D," , sendo assim, uma raiz") Escreval(" X1: ", x) se não entao Escreval("Delta: ", D," , Raiz negativa!") fimse fimse Fimalgoritmo
  25. Estou tentado fazer esse trecho do meu código funcionar enquanto(n <> "s") e (n <> "n") faca escreva("") leia(n) fimenquanto mas ele retorna este erro
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.